Z-wave switch driver update broke my SmartThings?

Noticed over the past day that it didn’t seem like my lighting motion automations were working correctly. When I had time to look into it tonight it seems like none of my zwave switch devices have reported since 7/18 just before 9pm PDT, and I can’t turn them on or off from the app.

I tried power cycling a few of the switches that have interrupts without any effect.

This is affecting Zooz, Inovelli Red, and GE switches and dimmers, and also an Aeotec relay switch, it seems.

Looking at the affected devices they are all using the Smartthings edge Zwave switch devices driver and it has a version of 2023-07-18T19:11:37.792922131

This seems suspect that the date of the driver is right before all of my Z-wave switch devices using the driver stopped working.

Is anyone else having the same issue?

I just lost a couple switches due to drivers being changed without any input. They became LAN devices and stopped working. One was virtual, so I recreated it, the other is a zigbee switch and now it just says it’s a Zigbee Thing…and won’t work, nor will it let me change the driver. Way to go ST.


It’s really frustrating.

A week ago I had another two switches stop working that I had to delete and pair again and re add them to all of their routines, and now those two are non-responsive again since 7/18.

Two weeks before that my whole setup broke because of suddenly missing virtual switches which I had to spend an hour or two recreating. I’m losing a year of automation time savings in the past month and about ready to try to migrate to HA or hubitat from acratch, just to try and gain some future stability.

You probably need to switch to drivers designed for your switches. Zooz has drivers for most of their products. Inovelli ha drivers for their switches. And @philh30 has drivers for GE switches.

Search this forum and you should find links to these drivers.

1 Like

My switches won’t let me change the driver. They say the footprint doesn’t match…I didn’t change anything.

I am having the same issue with my Boshe Motion Sensors, they are all now considered “Zigbee Things” instead of motion sensors???

Thanks, Paul. Your suggestion worked for me.

I couldn’t find a specific inovelli edge driver channel searching the forum (but I guess I didn’t go to the manufacturer website) but those switches worked with a Mariano Z-wave switch and child MC driver (as did some qubino flush relays that weren’t working with the ST z-wave switch edge driver), and I found and installed the philh30 switch driver for GE and Zooz drivers for my Zooz switches.

Overall, this is a pretty crappy user experience to have auto driver updates break things without notification to the end user and without the option to roll back to a previously working driver. (And the default smartthinga provided driver to stop working on EVERY z-wave switch.)

I don’t think most of the people I know would be able to figure this out without help.

1 Like

Usually the easiest way to search for edge drivers, including those provided by device manufacturers, is to use the quick browse lists in the community-created wiki. The information about the Inovelli channel is listed there in the manufacturers section.


1 Like

Hi @Rigging65 the migration to drivers was announced on 28th Mar and 8 days ago another announcement was created. if your device is a Zigbee thing that means that the device doesn’t match with any generic fingerprint, so the most likely that the device was using a custom DTH. About the virtual device if you create a virtual DTH it must be migrated to a virtual not a LAN for example this is one that was migrated:

We saw your post here about your virtual switch RYAN, we checked that and it’s using a custom edge driver, if this device was migrated recently it must be migrated to a virtual, not a LAN device.

Also, I see that you ask something similar on this post Legacy virtual switches stopped working (July 2023) - #38 by Rigging65