Inovelli Z-wave switches suddenly unresponsive

Hello,
I have installed two Inovelli Z-Wave smart switches. They were both working fine for a while and suddenly started to be unresponsive in the SmartThings app. I can still operate them manually (lights turn on/off) and the on/off status would be correct and updated in the app. But I cannot turn them on/off from the app, nothing is happening. Any help would be appreciated. I tried to repair the z-wave network, exclude/include the switches, reboot the hub - nothing is working. I also installed the device handler from the Inovelli website, still the same issues.
Anyone else experiencing the same issues ? You can I get my switches to work properly ?

Thank you for the help.

I have three Inovelli switches so far and they are all working as I type this. I haven’t updated their DTH in a while but why update when they are working.

Based on what I am reading in your write up is that the SmartThings app shows the right state of the device but cannot be controlled via SmartThings. app correct?

Yes, the state (on/off) is correct in the app and is updated if I manually interact with the switches. But if I try to turn on/off in the app (or using my google assistant), nothing happens. Sometimes I can change the state once, and then the switch gets unresponsive. For example it’s ON, I switch it OFF via the app and then I cannot do anything more via the app or assistant.

Good morning Caroline,

Thanks for writing about this and sorry for the issues you’re having. I’ve re-read this a few times and am honestly stumped at why this would happen, but let’s see if we can figure it out.

First, can you confirm you’re using the SmartThings Classic App?

If so, there’s one other thing that may be causing this that I can think of off the top of my head and it’s the, “Device Health” being turned on.

If you click on the Menu within your ST App, you’ll see a spot that says, “Device Health” – can you turn that off and then exit your app and then re-open it and see if that does the trick?

Outside of that, I guess can you explain what you’re seeing when you look in your app? Does it show the little red dot that says, “Unavailable”?

Hang in there, we’ll figure it out!

Eric
Founder | Inovelli

Thanks for the help Eric.

I confirm that I am using the SmartThings Classic app.

I believe I already tried to disable the device health - I’ll do it again tonight just to re-test.

Otherwise the switches are not listed as unavailable (no red dot). I’ll do more trouble shooting tonight and can take screenshots of the app if that helps.

This sounds like the same exact thing that happened to a few of my GE ZWave (not plus) switches.

The device appears online
The device reports status
The device will not activate from the ZWave network
Local control of the device works

This is being reported a few times in the community on different devices… In my case I had to exclude and re-add the switches. Support appeared to help another user in this thread:

Including @Kianoosh_Karami who helped that user.

1 Like

Yeah, no problem – happy to help!

We’ll get to the bottom of this. I know ST has been working hard behind the scenes on a few things, which always have unintended consequences, but they’re pretty good at working though them.

If you wouldn’t mind looking at @nathancu’s thread and seeing if that helps as well that would be awesome, but just in case others have the same issue, let’s keep the thread going. I’m actually really glad you posted this and I’ll look forward to your response and/or screenshots tonight when you’re home.

Have a great day!

1 Like

Could you please message me your hub ID? and the device node ID for which you are having the problem?

So here’s what happened when I tried tonight.
I started with testing my living room light switch. I was able to turn on/off several times from the app. Then I tried my bedroom switch. I was able to turn on from the app, but not off (unresponsive). I disable the device health in the app, it did not change anything.
I went back to testing my living room switch, unresponsive as well.

When I manually press the switches, light is turned on or off, no issues with that. ON/OFF status in the app is instantly updated to the right state.

I’ll have a look at the other thread you mentioned and see if it helps.

Hey Caroline,

This actually seems to be an issue now with a few customers who are writing in (they can turn on the device, but not off).

@Kianoosh_Karami – can you help? I’ve had a few people write in with this problem. What should I tell them to do?

Thanks everyone for the team effort, I really appreciate it. We’ll get to the bottom of this!

I had 2 of these devices. One works just fine 99% of the time, the other one behaves exactly like what Caroline described. These switches are 2 month old.

I just wanted to give an update that I am looking at this issue, I should hopefully have a solution or work with the Innovelli folks to resolve the matter.

Thanks for your patience

Hey @caro.rosin – was this ever resolved on your end?

Not yet, working with @Kianoosh_Karami to find the problem. I excluded/included the two switches today, still the same issue. I believe @Kianoosh_Karami has enable debug logging from my hub, so he’s going to check what went wrong. We’ll post an update if we find what is wrong !

Hi all, just wanted to post an update on my issues.

So I tried to exclude/include the two switches again a few days ago. It didn’t change anything (they started to act weird almost immediately). Kianoosh looked at our logs and found that the switches were not responding correctly (correct me if I’m wrong !)

However, two days ago, I unplugged/re plugged the SmartThings hub (from power) and since then the two switches are working properly and can be controlled from the app again. It’s like nothing ever happened. I had tried to do the same (unplugging the hub) in the past but it hadn’t work. So I am not sure if this is a coincidence or not. Bottom line is, for the past two days, the switches are working properly. So I’ll continue monitoring them and will post an update if I have more issues.

Thank you again @Kianoosh_Karami and @Eric_Inovelli for the help !

Few weeks later, another update. So it looks like the switches would work fine for one or two days every time I unplug/replug the power from my hub. And after a while, the same behavior starts again. I only use them manually for the moment (which defeats the purpose of have smart switches :frowning:). I am in contact with Inovelli to get a replacement and hope that will solve the issues !

Same issue here.
I just received 4 Inovelli Switch NZW30 w/Scene.
1 - works without issue (every time)
1 - will not pair
2 - are paired but showing the same issue a as above. The switches will seldom change state via software commands. stuck on [TURNINGON] or [TURRNINGOFF] in the UI. When the state is changed directly from the switch the state change is impedivity reflected on the control panel every time.

Resolved my issue with switches not working via software.
I found something with the “Raw Description” in the configuration.
The switch that was working had a Raw Description that looked like this:
zw:L type:1001 mfr:0312 prod:1E00 model:1E00 ver:1.03 zwv:4.61 lib:03 cc:5E,86,72,5A,85,59,73,25,27,70,5B,75,22,8E,55,6C,7A role:05 ff:9D00 ui:9D00

The two that were not looked like this:
zw:L type:1001 mfr:0000 prod:0000 model:0000 ver:0.00 zwv:0.00 lib:00 cc:5E,86,72,5A,85,59,73,25,27,70,5B,75,22,8E,55,6C,7A role:05 ff:9D00 ui:9D00

zw:L type:1001 mfr:0000 prod:0000 model:0000 ver:0.00 zwv:0.00 lib:00 cc:5E,86,72,5A,85,59,73,25,27,70,5B,75,22,8E,55,6C,7A

Aer removing the devices (de-registering) the first time I re-paired one it looked the same. Removed it once more and re-paired both the looked like this:
zw:L type:1001 mfr:0312 prod:1E00 model:1E00 ver:1.03 zwv:4.61 lib:03 cc:5E,86,72,5A,85,59,73,25,27,70,5B,75,22,8E,55,6C,7A role:05 ff:9D00 ui:9D00

zw:L type:1001 mfr:0312 prod:1E00 model:1E00 ver:1.03 zwv:4.61 lib:03 cc:5E,86,72,5A,85,59,73,25,27,70,5B,75,22,8E,55,6C,7A

All is working now.

Update - after getting replacements from Inovelli : same issue with the new switches. I thought it was working because they were responding correctly for a few days, and then the same thing started again.
I tried to get my ST hub closer, but it didn’t seem to change anything.

I’ll try to have a look at the “raw description” like @Mike_S suggested - hopefully that will be the solution to my problem !

Hello all:
having the same issue in that the NZW31 switch works manually, and sporadically works with SmartThings/Alexa. Have deleted/added unit several times into the SmartThings hub, reset the hub, ensured hub health is not activated - no luck. Running network repair, get a message of “Failure to update route” so this has not improved performance.

Any help would be appreciated so I do not have to return the item and buy a different brand.

Thanks

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.