Z-wave repair missing in Web portal and not working on app

My Z-wave network is a disaster since moving to the new edge drivers. It’s made worse by the fact that when I run a z-wave repair from the app, it just runs forever w/out messages. And, the new web interface I don’t see any z-wave repair utilities. I’m stuck! Having spent $1000’s my wife is getting really frustrated with so much not working. My request is simple, please re-enable the web portal access to z-wave repair and messages. I’m pulling my hair out trying to debug!

My setup has been running on 95% edge drivers for several months, with the last couple of devices only transitioning last week. My z-wave was fine until this weekend, when automations became slower or completely stopped - so I think it’s something other than the actual driver migration (unless the device that transited last is chatty and bogging things down :thinking:). A network repair seemed to improve things but only temporarily. I did get messages for a couple of unknown devices that failed to update but haven’t had time to identify and troubleshoot. I agree that z wave repair from the IDE, with the ability to view live logs, has always felt more reliable than in the app, where I’m always wondering whether I missed a report because my phone went to sleep and the repair never seems to complete (not just recently), along with being able to see device IDs for troubleshooting purposes.

Provide us with details on which devices you are experiencing issues with… brand/model and Edge driver being used. You can find most details in Advanced web app.

The advanced web app doesn’t have the z-wave repair utililty! It used to be in the IDE. When I run the app version it starts but never finishes and never shows any status.

But, I now see several z-wave switches offline. Some newer and some have been working for years: Kwikset lock, Zooz Multi-relay, Zen22 and 76 switches, August pro lock just to name the first several I see. Please help. Thanks

I would not worry about z-wave repair at this point until you get all your device issues resolved.

let’s start with the zooz… are you using the zooz edge drivers or the ST stock drivers? You want to change them over to the zooz edge drivers. https://community.smartthings.com/t/st-edge-zooz-edge-driver-channel/246497

for the locks, you may want to exclude those, reset them them and pair them again. if those use S2, scan the QR code when adding,

if any of your switches are GE/Jasco… update to @philh30 ge drivers. [ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

OK, let’s start with the one that is causing me the most problem: The Zen16 multirelay. It is offline, using the Zooz edge driver, and was working fine until last week. Now it drops offline and often sticks “on” meaning that even the RF remotes don’t work. So we have no way to get in the garage.

One other “clue” is that when things do work, they can take more than 10 seconds to respond. The tools on Smartthings are just so inadequate. How can I find a problem node? How can I check health of the network? Why can’t I see a map of the response times and the paths?

Anyway, I have several z-wave devices offline, some won’t connect at all if I try to reconnect, and like I said, the z-wave repair tool in the app starts but never finishes nor gives status.