Wemo switch integration


#1

Hi there.
I bought the smartthings hub v2 but can’t connect my wemo switches. App doesn’t find them automatically and they are not in the options. Any ideas?


WeMo device types not appearing in 'new device' list
ST isn't seeing Wemo switch & Wemo switch is offline
#2

Have you done the following?

If so and it isn’t working, it’s probably best to get in touch with support.

http://support-uk.smartthings.com/hc/en-gb/categories/200752662-Contact-Us


#3

Thanks. I tried that, but there is no Belkin in the options just Aeon Labs. I’ll try the support.


#4

Yeah, I’m having the same problem and I have tried the guide that’s listed above.

I go to Marketplace -> Lights & Switches -> Outlets and no WeMo listed, only “Samsung SmartThings” is available.


#5

Just an update, I’ve been playing with the web console and added my own smartapp using the “wemo (connect)” template. Then launched it via my Android phone, and was able to add my wemo switches from there. :grinning:


Issues so far
(Kevin [Yorkshire UK]) #6

Wemo Connect finds my 4 Wemo switches OK , I select them via ‘Tap to set’+’ and then click ‘Done’ and ‘Done’ and I get the error 'Failed to save page: firstPage". Tried this several times… any ideas ? iOS app.

(I saw a similar post on the US board from a while back with a support reply saying we’ve fixed it… try again now and it worked for the user reporting the issue.)

Just tried on the Android app and I get ‘An unexpected error occurred’ at the same point where the iOS error message happened.


#7

I’m guessing you added your own smartapp using the “wemo (connect)” template yeah?

If you check the live logging from the web IDE, do you get an error like this?

13:09:54: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Wemo Switch’ in namespace ‘smartthings’ not found. @ line 232
13:09:54: debug Creating WeMo Switch with dni: BxxxxxxxxD9
13:09:54: debug getChildDevices(false), children=0
13:09:54: debug Installed with settings: [selectedSwitches:[BxxxxxxxxD9, Bxxxxxxxxx81]]
13:09:50: debug REFRESH COUNT :: 6

If you do, (and @JDRoberts might kill me for suggesting this), then try adding the wemo switch to “My Device Types” (remember to save & publish!) and then try again…

Please let me know if this works as it will confirm a suspicion of mine!


(Kevin [Yorkshire UK]) #8

Yes… exactly that logging output, and adding the device type seems to have worked for me - certainly the error has gone and I think I have one controllable device from SmartThings

I keep losing most of my Wemo devices as discoverable (they disappear in the Wemo iOS app too) so I’ll need to wait for them to come back and then add them in. It’s almost as if SmartThings is contributing to knocking them out as before this they were very reliable. The one device that I think SmartThings now has control of has also now gone AWOL in the Wemo app now.

K


#9

Good to hear that seems to work!

I found that my WeMo switches were rather unreliable even before smartthings, so not too sure if they are to be blamed.

You could try pulling the wemo switches out of the power socket and then plug them in again, that usually fixes things (temporary in my case!)

By the way, thanks for letting me know! I’m waiting for one other person to try a similar workaround and then I’ll know for sure.


(Kevin [Yorkshire UK]) #10

I seem to have control of all 4 of my devices now and changing state from SmartThings does propogate to other SmartThings client apps and the Wemo app instantly. However changing state from the Wemo app (or IFTTT) does not update SmartThings (but does control the switch)… So it looks like SmartThings is not seeing the Wemo status updates.

The last firmware update from Wemo improved the reliability substantially. Before they were really awful


#11

If you look at the live logging long enough, it does periodically check the wemo status but I don’t think it’s instantaneous, did you try the refresh button?


(Kevin [Yorkshire UK]) #12

Ahh - so they’re polled, which is a shame as obviously the status events are there, a half baked solution really but hopefully it’ll get updated and improved in the fullness of time.


#13

That’s not smartthings’ fault, so they can’t change it. Lutron holds a patent on dimmers, including dim able bulbs, updating their status to controllers. It covers all radio frequency lighting, including zwave, zigbee and Wi-Fi.

Lutron has been aggressive about protecting this patent, so Only manufacturers who pay a license fee to them can provide this feature. Leviton does for some models, Cooper does for most of theirs, pretty much nobody else does. Not even Philips for the Hues.

Most other manufacturers believe consumers do not want to pay the extra cost to cover the patent, so they don’t pay it, and instead just recommend polling occasionally if the controller needs the status.


(Kevin [Yorkshire UK]) #14

That explains a lot although in my simple world it seems somewhat unreasonable that Lutron should be able to get a patent on such a fundamental aspect of operation . Even then I would have hoped that as Wemo is predominantly UPnP it would have fallen outside of the patent. In my case it’s the Wemo outlet switches that I’m using so not sure if they would fall into the patent or not.

It’s a shame for automation adoption that such obstacles get created.


#15

As an engineer, I’d have to respectfully disagree.

Lutron has put a ton of money, time, and energy over literally decades into improving the engineering of basic light switches. Their dimmer patent is pretty old and was very significant at its time. Patent protection is what encourages this type of sustained research, and leads to the availability of advanced technology for the everyday consumer, rather than just hack your own solutions.:sunglasses:

.


(Kevin [Yorkshire UK]) #16

As an engineer too… let’s just agree to differ. I have a personal issue when patents seem to be overly wide in scope and damage adoption. I now see there are loads of posts about this across many forums… I must have snoozed through them all over the past few years so the heads up is much appreciated… Maybe the patent expires soon … I’m not sure.

Anyway, the patent clearly mandates that we already have the most workable code so that’s good


(Aaron S) #17

Just to clarify… Wemo is not certified for the UK integration at this time. It was removed from Marketplace and will be removed from the UK compatible devices page (if it hasn’t already).

There are a couple unsupported workarounds using the IDE or IFTTT, but I’ll leave that someone else… :smile:


#18

It’s still on the UK support pages…

http://support-uk.smartthings.com/hc/en-gb/articles/204684572-Which-Belkin-WeMo-devices-will-work-with-SmartThings-Labs-


(Tom Wilkie) #19

Any idea when this might be certified? Just got my hub and its a bit of a surprise that it doesn’t work with Wemo devices.


(Stephan H.) #20

I did as you prescribed and got my Wemo switch working as well. Thank you!