Wemo Switch issue

I have a single wemo switch from before I got my Smartthings hub. It is set up on a schedule (15 minutes before sunset until 11pm). It worked fine standalone, but once I added it to smart things it’s been very flaky.

  • it turns on at random times for no reason, with nothing in the activity log
  • If I leave the wemo schedule in place, it often either doesn’t work at all or turns on and stays on
  • If I switch to a Smartthings schedule, it turns on at the correct time but turns off hours early and sometimes doesn’t work at all
  • It shows as Not Detected in the wemo app

Any suggestions? I could either just use it standalone or I could switch to a ZWave switch I suppose but it would be nice to get it working

While I definitely run into issues with SmartThings controlling WeMo switches, I haven’t had any trouble with the WeMo’s internal scheduling. I’d try doing a factory reset on that switch.Also make sure you’re using the latest app and firmware. They’ve gotten a lot better over the last year as far as I can tell.

Uninstall it from ST then reinstall it

I recently had a big struggle with the WeMo Light Switch. It just wasn’t working as it should. In the end, I decided to uninstall the device and reinstall it.
After I uninstalled it, ST didn’t recognize the switch anymore. I tried everything. I logged out of the mobile app, killed it and restarted it. I unplugged the hub, waited for 10 minutes, and booted up the hub. I reinstalled the firmware on Wemo. I reinstalled the firmware on the router. Nothing helped. ST was unable to discover the WeMo.
Then suddenly, after a few days, the WeMo was recognized and I was able to install it. But no time for celebrations. The most simple operation, turned the switch on and off, was not working properly. When I was trying to turn on the switch, it would show ‘turning on’ and then it would go back ‘on’. But actually, the switch was turned on by ST. It just did update the status properly. A few days later, it suddenly started to work.

I never understood what the issues were and if it would happen again, I would not know how to ‘fix’ it. During this time, the native WeMo app was working flawlessly.

OK, I’ve done a factory reset and rediscovered it with the wemo smartapp… This time I set it up in ST using Mode Magic for 15 minutes before sunset and an off schedule at 10:45 using Lights & Switches. No wemo schedule. We’ll see how that goes.

Wemo isn’t really working well at all. I’ve removed my 4 wemo devices from SmartThings. I found that ST would send commands to the switches but they wouldn’t change state. I’m using the official wemo app now and just have rules setup. This are rock solid in the official app like you seem to have mentioned. It sucks to not have the integration working. I’d suggest using regular zwave devices for any future things you pick up. Generic zwave stuff seems to work great. I recently installed a Leviton DZR15-1LZ and have been very impressed with how well it responds to commands.

Yeah, I’m going to go back to using it separate from ST and maybe replace it with a Z-Wave switch. Since reseting and reconfiguring, every day it randomly turned on and off throughout the day. I captured once case while live logging and the only thing that was happening was ST was polling. Not sure if there’s a Wemo bug that is triggered by a poll or if ST is doing something wrong.

Hopefully the ST team will spend some time testing this and fix it if on their end or work with Belkin if not.

Did you upgrade to the new firmware recently? My light switches all stopped working about a week ago when I upgraded to the latest firmware. I told support but I haven’t seen a resolution yet.

I know my devices had the newest firmware and weren’t working. Devs NEED to do a once over on everything in SmartThings Labs to actually fix these things.

I’ve been using Wemo for a couple of years now. I have close to 25 devices. All are connected through SmartThings except the insight switches and cameras.

My challenges with Wemo are what brought me to SmartThings, I’ve had ST for less than a week. I’m pretty tech savvy and not hesitant to get in and play with things.

Some observations on Wemo with the Wemo app (btw firmware and app is kept current):

  1. Random Wemo devices become unavailable in the wemo app for no reason. A combination of starting/restarting the app, connecting through local network versus LTE usually results in the devices reappearing. The devices that appear to be the most unstable are the insight switches, cameras, and sometimes motion.

  2. Devices turn on and turn off randomly. I believe Wemo has an issue deleting old rules. I used the “vacation” functionality once… lights turning on and off around the house to simulate presence, and although that rule is now deleted, the behavior persists. What’s unusual is that the device responds as if it has been turned on/off and throws a message to IFTTT. This does not appear to be a network connectivity issue. I’ve used the app based reset functionality to no avail. I’ve never tried hitting the reset on the switch itself… appreciate I have many many switches.

  3. Periodically the WEMO devices cause the ApplePlay enabled receivers to get knocked off the network. I appreciate this sounds completely ridiculous. However, it’s a well documented issue in the Wemo forums. At the current app level and firmware levels, this problem appears to be gone.

Observations about ST and Wemo

Updating the hub to support the Wemo extension did not work. Support had to intervene and do it for me. They advised that the self service update for the Wemo smartlabs app wasn’t working.

  1. Discovery seems to work well, it just requires patience. It took probably 10 minutes or more to find all my devices.

  2. I’m able to use ST rules to control the Wemo switches, when everything is working correctly.

  3. Wemo devices always appear in the ST iphone app; as you’d expect. However, I am often unable to control the Wemo switch. I get two recurring cases… (a) attempt to turn on/off a switch from the wemo app and nothing happens; and (b) attempt to turn on/off a switch and the ST app says “turning on” or “turning off”, the action WORKS, but the app never changes state. It appears continues to wait for an ack or response from Wemo. If I reset the ST app, hard close it and open it again, the ST app believes the action has not taken place.

I’ve not found a way to reliably force the ST app to get the updated status of the Wemo device. Start/stop the app doesn’t work. Going into and out of the Lights & Switches app doesn’t work. Refresh from the main Things app doesn’t work (pull down on the app and release). And finally, refresh from the specific Wemo switch (Thing) doesn’t work.

Half the time, or maybe a little more, I am able to open the native Wemo app and control the switch. However, often (half the time?) the Wemo app is doing a discovery. The Wemo switches transition from available to grayed out and then eventually available again when the discovery is complete.

I’ve hesitated to put this in front of support because I believe the issues are on the Wemo side. The Wemo app and availability of the Wemo switches is quite hit and miss.


1 Like

Has anyone managed to get any stability form their Wemo integrated devices?

I have a couple of Wemo plugin switches that work with the Wemo App, but the ST just never manages to control them. Most of the time ST has no idea of the actual state of the Switches and when asked to turn them on/off, says it has done so, but the Wemo just seems to ignore those requests.

Similarly, my Wemo Motion activity is also almost always ignored or lost on ST. Motion is seen, Wemo app notices, but unless I go and refresh the device on ST, it remains oblivious to it all.

This is completely crazy that almost all of the time, ST has little to no control over these connected devices…

I gave up on Wemo integration. I have one Wemo light switch that I have set up with the Wemo software with timed on/off. I’d like to do more with it, but it’s too unreliable. Eventually I’ll probably replace it with z-wave.

Someone else was having issues with there Wemo stuff. I talked to tech support about the issue that i was having with my Wemo and he suggested to me assigning each device a “static IP address”. After working out how to actually do it “im not very tech savvy” i was able to do it and i am happy to say that it is working great!! well for now anyways.

I don’t know if that will solve your problem but it definitely helped me with my Wemo sensors.

Good Luck to you!

Any update from Smartthings on this issue?

My WEMO switches and plugs are using the WEMO app for sunrise/sunset times and “away” random modes. I can override the operation from the Smartthings app but the status doesn’t update to the new condition. The command is sent from Smart things and the WEMO switches changes state, as shown on the WEMO app, but Smartthings doesn’t update.

I found a workaround using IFTTT to actually switch the Wemo stuff, since ST couldn’t do that reliably. Basically, I have ST toggle a virtual switch for things like Sunrise/Sunset, specific motion, etc, then IFTTT spots those virtual switch changes and flips the Wemo switches for me.

Another godsend has been SimpleRuleBuilder by JoeC (search for the thread here). It allows me to build more sophisticated rules, including things like restroing virtual switch states, turning off Wemo switches after a period of time elapsed, etc.)

1 Like

My work around for the Wemo issues was to get a GE replacement, and ditch the Wemos. Goodness, those things are frustrating.

Hi, Curt,

I ran into the same issue as you: “WeMo devices become unavailable in the WeMo app while my iPhone is connected to the home WiFi network . If my iPhone is connected to LTE, WeMo devices immediately become available.” Do you know any solution to the problem?

I don’t know whether the issue is related or not. My WeMo motion sensor sometimes will stop reporting motion activities to SmartThings (hub v2).


I had issues too with my Wemo devices. Then I moved my ST hub from being plugged into my modem, to plugging it into one of my router’s ports. It found all 8 of my Wemos, with no issues since.

Update… I have gotten rid of all wemo devices; now on GE, Aeon, or ST devices. Everything is so much more reliable.

1 Like