Is anyone else having huge problems with WeMO integration?


(Joel W) #1

From the first day I installed SmartThings hub on my WeMo system I have had nothing but problems. I have been told by support they are working on it. But there was no fix. The last conversation I had with support I was told that after V2 hub is released they will work on this problem. I am so disgusted as I asked support before buying the hub if WeMo works well and was answered yes. I feel like someone picked my pocket. If all your programing staff is devoted to the new Hub don’t desert your customers that have bought your V1 hub. This is just not a good business practice. I have a lot of money invested in this system and am so frustrated with the way things are handled. So here I am venting.


(Bobby) #2

You are NOT alone ! I have five insight and they are a real pain! I wish I knew before what I was getting into, but Echo integration sounded so good, I had to have them. Oh well another HA wasteful experience, but not as painful as the Lutron Caseta.


(Robert Merrill) #3

I have one WeMo switch. And it is a headache every time it looses power. Each time I have to add it back in to ST.


(Joel W) #4

What bothers me is that I asked the question directly “is WeMo fully integrated into SmartThings?” And I was told yes.


(Cris D) #5

Ever since my 7 Wemo devices (I don’t include the insight) took firmware update 2.00.9399, they cannot be found by SmartThings. I blame Wemo for the break, but it’s not like they need permission from ST to update their stuff. I have a ticket in hoping ST can update on their end and mend the break.

With the new app out and v2 in peoples hands soon, I can guess that wait will be longer since they need to resolve ST stuff first, 3rd party devices next.


#6

I have only one WeMo switch, but I has worked without fail (minus some early hiccups with old firmware) using Belkin’s own app, and since integrating it with Echo it has operated as expected 100% of the time. It is only when using it with ST that it doesn’t work. Even this moment it shows the wrong state within the ST app but correctly in its own.

WeMo gets slammed here often, but my experience has been that ST is the issue with respect to it.


(Keith Croshaw) #7

I ended up with two virtual switches connected to wemo through IFTTT. Works fine now. 4 IFTTT rules per switch though…


(Joel W) #8

I had no problem with the new App it found the WeMo switches and updated the firmware. My problem is that the WeMo switches go on and off as they should using the schedule I set in ST but the status is never updated in the App. If I have a light that goes on at sunset it goes on but the app says off. So if I am away from home I can’t depend on it as I truly don’t know the condition. So I have to use the WeMo app, so my question is why did I buy the ST Hub if I need to use the Belkin program? ST has had lots of time to fix this problem and it has been ignored, not that tech support doesn’t answer, but the answer is always the same remove the switch and start over, not acceptable.!


(Paolo) #9

I’m as frustrated as you are. I bought Smartthings because Wemo is on the “list of products tested by SmartThings and verified to work with SmartThings.”

Even the new UI does not address a very basic shortcoming; not able to simultaneously display the various readings from a multi-sensor. The best thing I can say is that at least now you don’t have to shake your device to identify it.

Does V2 even have an on-bord real time clock?
Good thing they have Smart Tiles… oh wait…


(Morgan) #10

I’ve stopped using any integration for my Wemo devices because ST and Wemo simply don’t work. The integration has been SO poor, i’ve almost done the same thing for the Netatmo but I still have hope for it yet.


(Cris D) #11

Are your Wemo’s on the latest firmware? I too was told to do the reset thing, to no avail. And you can get it on app 2.0 also? I guess you are one step before me, but neither one of us is getting anywhere. Bummed.

I bought 3 of the motion sensor / switch combos for 75% off at my local dept store. They work fine through the Wemo app, but I want the ST app to be primary. Now I am considering selling them. I already have ST motion sensors in the same spots, and am moving to in wall switches and plugs for a clean look.


(Joel W) #12

I am on firmware WeMo_WW2.00.9399PVT-OWRT-LS and ST version 2.0.0 (1157)


(Scott) #13

It was and is occasionally. The problem is that Beliin can bel real it at will. I’m replacing my WeMo switches with GE. When SmartThings fails to control your WeMo stuff have a look in the WeMo app. I’m guessing yours like mine will show this devices as disconnected. WeMo is crap, replace it.


#14

Nope. The WeMo app works for me every time. Right now it shows the correct state and ST does not. If I change the state in ST nothing happens despite ST indicating the WeMo is connected. Yet, I can tell Alexa to turn it off, and it will do so with a correct state change in the WeMo app.


(Joel W) #15

My WeMo App works every time, if the WeMo switch is on it shows on but the ST app shows off. I am thinking about getting Alexa. is it hard to setup with smartThings?


#16

It couldn’t be easier. You don’t even need ST since Echo is compatible. Mine is connected through ST, but as I mentioned the ST app state won’t change even when Alexa switches the WeMo.


(Joel W) #17

I have to look more into this as I would like to control my Honeywell Thermostat also if possible, which is WiFi.


(Realy Living Dream) #18

I’m with you . I wound up just uninstalling the wemo app because it always showed my switch as disconnected. I know it is NOT since I can turn it on/off with Alexa and IFTTT recipes with it work fine. Only WeMo can’t seem to find the WeMo switch. “Everybody else” finds it just fine. After the 3-4th time I contacted Belkin and got the same boiler plate of well reset it to reconnect to WiFi. I could not get them to understand that if I can control it through IFTTT and Echo, see on on my router it is obviously still connected. So I reset it and a day or week later it is lost again. I’m just glad I only bought the one just to see how it worked with Echo. I really do not like the not being able to dim the lights. Come on ST V2

Maybe your and mine were made by the same guy on the same Monday morning.


(Scott) #19

my GE replacements are in. I may use the WeMo stuff in the kids bathroom where it’s not as big of a deal if automation fails.


(Joel W) #20

I was told the other day they are working on fixing the inconsistency of the WeMo integration, so I will take them at their word. I just hope it is soon. I am holding off buying any other equipment until this is fixed, if it isn’t I will move to another platform.