V3 hub steady blue, st says it’s online but…

My V3 hub has been experiencing some weird behavior lately. Now no behavior at all and I’m dead in the water with 134 dead devices.

Background: I’m up-to-date on all the latest firmware, so whatever the latest one is, that’s the one I have. Things would stop responding/appear off-line and then randomly go back online then Monday: everything off. Nothing will go back on.

The hub is a steady blue. I’ve rebooted my modem, my router/eero pro v6 mesh network, and my hub. (All more than once.)

The hub is connected via Wi-Fi, but I have tried ethernet as well. Nothing works.

For what it’s worth I have never had connectivity problems before with this. It is literally 2 unobstructed feet, measured, from a router. Never been moved and nothing is in its way and nothing’s been moved or added since I put it there in 2020. I know enough not to tempt fate.

Smartthings has escalated the issue and is reading the logs, and apparently it’s has Wi-Fi connectivity and good signals and everything looks good. It’s just not reaching their servers. They tell me they’ll get back to me.

I did nothing. Literally nothing.

Is anyone else going through this or has anyone experienced this? Would love to know what fixed it. If anything.

I feel like they changed some thing and all of a sudden it’s not working. I’m afraid of buying another hub only to have the same problem. In fact, I have one (an aeotec) sitting on my coffee table in an unopened box, which I would love to try out, but I’m afraid it won’t work.

Thanks for reading this far and I hope someone has some answers because I don’t think Smartthings does.

do you use any type of ad/malware blocking such as PiHole or use a VPN?

I will throw out one thing to try since you have already tried everything else. Try temporarily changing your DNS servers used by your router. If using your ISP’s DNS servers… change to a Public DNS server such as Cloudflare ( or Google ( or whatever DNS server is acceptable to you. Or if using one of the Public DNS servers, switch to your ISP’s DNS. If it does not resolve the issue, change it back. Will it resolve the issue… who knows… most likely you will need to wait for ST.

good luck!

I had this same issue a few month back. I wrote an long explanation of how I fixed it on Reddit in the r/SmartThings forum. That forum has sadly been deleted, along with my step by step recovery procedure. The short version is look for “soft factory reset” The gist of it was similar to a hard factory reset, but as soon as the light turn yellow, release the paperclip from the reset button. Mine was on a V3 hub, so it might be slightly different on a V2.

I haven’t been able to find the source I found my solution on, but look around for that specific term “soft factory reset” and see if that will solve your issue. I was in quite a panic when it happened to me as I had just days earlier migrated my 155 devices from my V2 hub to my V3 hub when it just went offline and the blue light. After the “soft factory reset” everything came back just like it was and I didn’t lose anything.

Hi and thank you so much for writing!

I have a V3 as well. When you do a soft reset, it doesn’t remove any of your automations, scenes, or devices does it? Although at this point, I’m fully expecting to have to crack open the box with the new hub in it, and start from scratch.

Hi, and thank you for writing! I don’t have either of those things going on, but I did wonder about access via another net work. I wish I had one to test it on. I’ll wait for SmartThings, but I might try that soft reset mentioned below.

No, the “soft” factory reset did NOT remove any of my devices. As, soon as the LED turns yellow, remove the paperclip - do not wait for the light to go solid or it will do a HARD reset.

I stumbled on this while I was in a panic because I had just finished migrating all of my devices off of my V2 hub and then a day or so later the light went blue. All of the devices showed offline in the app. I tried adding the WiFi to my hub, since I was wired and that didn’t work either. I thought maybe the physical port had gone bad.

I’m really upset with Reddit That was my first post and I was documenting the procedure for anyone else that might have the same issue, since it took me days to uncover the “soft” factory reset. In 35 years of IT, I had never heard that term.

Luckily, I still had my V2 hub and it was online the whole time. That told me it wasn’t my router blocking traffic. It’s frustrating when things like this happen. My V3 hub had been online for about 6 months before I started my migration and then took a digger a couple of days after I finished. I was so glad to find the article about the soft reset, it worked for my hub and everything came back online. The hub cycled through a bunch of colors and at one point it stuck on red for a while and I thought that was it, but then it it finally went green.

This wasn’t the issue with the Australian internet provider was it? I think I stumbled on that on Reddit.

No, I’m in North America. Like I said, my V2 hub was online and green the entire time my V3 hub wasn’t working. That’s how I knew it wasn’t an ISP or router/firewall issue on my side.

Oh my god this is killing me. Before I attempt the soft reset I had to contact SmartThings just to verify that it was something that still worked (with my luck it would be something they made impossible for the unit to do with the last firmware update,) or something that they might suggest I should try.

The tech I spoke to just now is fairly adamant that it will reset everything and I’ll lose everything. I don’t think he knew what soft reset was because I said it a couple of times, and he seemed a little confused over it. Doesn’t sound like it’s a really widely known thing. (Like you said) but you’d think at least that smarttthings would know it.

I will keep looking around for soft reset articles but so far all I keep getting are about hard reset.

I wonder if I should try to aeotech hub sitting in its box mocking me across the room. It’s unopened, but I’m terrified that I’m going to end up with the same error.

Did I ask you why you were moving over from a V2 to V3?

Thanks for the hand btw. Helpful. Feel at sea.

soft factory reset by following these directions:

  • Disconnect the power cable from the Hub
  • Using a pin or a small tool, hold down the reset button on the back of the Hub
  • While continuing to hold down the reset button, replace the power cable
  • When the LED on the front starts flashing yellow, release the button
1 Like

Hi! Thank you.

I’ve just been perusing your other posts on this. Think I should just try it, yeah? I’m a bit (understatement) scared. Mostly that it won’t work. Lol.

Note: as soon as you see flashing yellow… do not continue beyond that because if you see solid yellow… that is the hard reset and you lose everything.

1 Like

You bet your sweet bippy.

It doesn’t need to be on ethernet does it?

Good question. I believe you need ethernet and would need to set up wifi again but I am not certain. I don’t remember ever seeing anyone talk on this topic.

Well, now I am kind of wishing I waited to find that out yikes - because I did it already on wifi and it went through the color schemes and now it’s flashing yellow.

Should I try it again on ethernet?

plug in the ethernet cable

Tried it again on ethernet. Solid blue. Sigh.

So when you put the paperclip in, plug the power cable back in, it flashes yellow, like a maniac. Hopefully that is the flashing I should’ve been waiting for. It started immediately – there was no waiting so I immediately removed the paperclip. Sadly went through iterations. Solid blue .