Smartthings V3 Hub won't stay connected to WIFI

About 3 or 4 weeks ago my 2018 V3 hub started disconnecting from WIFI. If I unplugged it to reset, it would reconnect but only stay connected (green light) for 5 or 10 minutes and go offline again (flashing blue or solid blue light). This hub has been stable for years with no new devices added recently. It has all z-wave devices: 16 switches, 6 plugs, and 5 door locks.

I have factory reset it a number of times and still the same (with none of the devices added back in). It’s connected to a 2.4Ghz channel and assigned a fixed IP address as suggested in other threads but no change. It does stay connected while configured for wired Ethernet but I need it WIFI for physical location.

As far as I know there has been no change to my WIFI network aside from assigning a fixed IP for the V3 hub. I do see that a recent update was pushed, but not sure that affected my V3 hub.

Any advice?

Is the hub disconnecting from WiFi or connected to WiFi but not connected to ST servers with an offline status? Can you ping it? Reboot your router?

Do open a ticket with ST support. Tap on Menu and select Contact us. Also try the “offline diagnostics” also in the same Menu section.

The hub is disconnected from the WiFi router. It shows up in the device list of “off” and I can not ping it.
As far as offline diagnostics, it says there is a problem and to delete the hub and re-add it. I have done that several times.
Thanks, I will open a ST support ticket, have not done that yet.

the hub was working in the same location using WiFi before the issue began? Do you have an idea of what date the issue began with your hub? is the WiFi strength good in that location? Not that any of those questions will lead us to the solution.

Unfortunately I don’t know when it began, it was about three weeks ago. The hub had been in the same location for years and worked fine. To troubleshoot I moved it into the same room as the router but is still having problems. Not a signal strength issue.

1 Like