Time based events failing?

@slagle Lools like routine with sunset offset is failing for me at least with the new app update today. I have opened a ticket. Even putting the routine at a specific time failed.

Sunrise/sunset not working
Smartthings v2 hub not communicating as well as v1
Trouble shooting a routine – where to start
Door Lock Up On Close inconsistent lately?
Turn off after motion stops
Sunrise/sunset not working
Gentle Wake Up
Is GE Z-wave light switch compatible with v2 hub?
Trouble with status display
Frustrated by the state of things
Frustrated by the state of things
Routines to turn on are not triggering
Frustrated by the state of things
If the internet connection is lost
"Pollster" - A SmartThings Polling Daemon
runOnce stopped working
runOnce stopped working
Hello, Home Phrase Director - Control modes (through hello home phrases) based on occupancy and "sun state"
runIn and runOnce not working?
Repairing Zigbee Mesh
Smart Lighting Design Bit me Again
Timed events (Smart Lighting) periodically failing on my v1 hub
Timers waiting for date in the past
Timers are very inconsistent
Perplexing - Really like Smart Things system, but the problems! Your perspective on Smart Things please?
Smart Lighting automation with timers not triggering reliably
Smart Lighting Automations - Not working anymore
T- 48 hours and nothing but crickets from Smartthings
UPDATE: Recent SmartThings User Experience & Platform Performance
T- 48 hours and nothing but crickets from Smartthings
Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support
Keep Me Cozy II - randomly ramping up heat setpoint?
[Device name] unreachable is 0? (Zigbee errors after platform update)
Good Bye! Routine not working
Adding a new User in app v2
Adding a new User in app v2
SmartApps not working
Adding a new User in app v2
BST/GMT Confusion
Is anyone using Monoprice Z-Wave devices?
New Hub And Suggestions

I set it again for 6:45 PM specifically at a certain time and I am pretty sure it will fail.

The above failed. Along with the Smart Lighting failure. Lights turn on with motion after sunset.

Sunset is long gone but lights don’t turn on with motion. Looks like 2.0.4 is thumbs down for me at least.

Mine are also failing after update.

Edited to add: I just checked, some also failed before I updated the mobile app. But this is new today. As opposed to the vanishing device state problems yesterday. :scream:

Glad it’s not just me…

Same issues here as well.

My sunset triggers all worked as expected today, so it’s not everyone. I didn’t add or change them after updating, but I did update before sunset.

Mine has remained unchanged (lights on at sunset) for months with zero issue. Has triggered till yesterday. And I never mess with it but occasionally changing the offset based on changing sunset here in NE. This is my first failure in months. Then I decided to change it specific time with a new routine to test which failed royally as well.

Same here. Routines are not firing as they should. Motion activated lights come on but do not go off. Checking timeline shows commands being issued at correct times, just not responding to “off”. Hub v2 user.

Not limited to ios. I use android and my lights did not come on at sunset. Also, I can’t get Pollster to work no matter how many times I reset it or reinstall. It won’t fire scheduled events.

I have one scheduled automatically for goodnight at 9:10 PM. I am sure (gut feeling), will fail as well.

I was under the assumption that the Smart Lighting App was one of the more stable reliable features of ST. Today my automated Lights which go on at 6pm did not go on, second time in a week. Activity log shows no attempt to turn them on. I have not lost internet or had any type of network outage. Is this a common thing? I have had ST about 2 weeks now, so Im still new to it.

I have been experiencing the same issue. 2nd time this week that lights did not trigger.

I thought the Smart Lights app ran locally?

Same here, Smart Light did not fire. I am still on v1.

Some of the automations I set up worked at first, but at some point in the past day or two simply stopped. They were simple automations such as creating a three way switch by turning on another switch when one was turned on and off.

I have one that stopped working all together and another that started taking close to 5 seconds to turn on the second switch, not a big deal, but with the old “Big Switch” app it was nearly instantaneous.

A final one that stopped working all together was to turn on the outside lights when the backdoor was opened after dark. This worked but just stopped.

I restarted my hub, but that didn’t help anyone else having problems?

Yes, I have one that just died and I can’t resuscitate. I blamed it on some development I was doing, but your post makes me rethink that. I will give it overnight to come back.

Yeah, my bedroom lights on at dark failed to work tonight… But my porch lights on at dark worked just fine.

Is not the app, my friend. Is your phone, switch to Android so you can still run 2.0.3 and have the same issues. But switch to Android though, is worth it.


I’ve had one fail and the rest worked. Though I noticed I’ve some bulbs not showing the proper status in the app as well…

There’s an update? To the app? ? ? Wool it stop crashing? ? ? Dear god please say yes!