Smart Lighting automation with timers not triggering reliably

Hey all,

I had no problems with my old V1 hub and my V2 hub was also been working until about 3 weeks ago. Now, the majority of my Smart Lighting automations which utilize Timer triggers are failing to either turn on and/or turn off at the right times. It’s not 100% of the time and not always the same automations, but every day I can guarantee that the majority of them will fail.

When I check the event logs for the lights which should have turned on/off at a certain time, there are no relevant events…just like the timers didn’t even fire. If I look deeper at the automations in dev.smartthings.com I can see things like this:

Handler: stopHandler
Next run time: 2016-02-06 11:00:02 PM PST
Previous run time: 2016-02-05 11:00:02 PM PST
Status: Waiting

Handler: triggerHandler
Next run time: 2016-02-04 5:00:02 PM PST
Previous run time: 2016-02-03 5:00:02 PM PST
Status: Waiting

Either the triggerHandler or the stopHandler will often have a “Next run time” in the past…which doesn’t seem good.

I’ve contacted support@smartthings.com about this and they told me to delete and re-create the troublesome automations I did that, but no joy. I also emailed support@smartthings.com back to let them know that it didn’t work, but it’s taking at least 3 days between replies :frowning:

Anyone else seeing this or has been through this problem on a V2 hub?

Thanks,

Plus a million more - All the same issue.

Anything time based is failing. Search - you can’t miss the numerous topics.

2 Likes

Don’t forget this 3.5-month old thread. :wink:

1 Like

Just grabbed a couple of recent ones.

Maybe we should start one thread and get the posts and view counts so damn high that it makes the email of popular topics from now until the end of time.

EDIT:

1 Like

Mea… I don’t even bother reporting these failures or posting about it anymore. It’s the most-known fault within ST, and no one at any level of the organization can deny it. At the end of the day they’ll fix it or they won’t, and each of us will make our own decision to put up with it or move on.

3 Likes

I’ve always had the issue occur occasionally (very occasionally)…it’s only been the last 3 weeks that things have gotten so much worse :frowning:

This has been a constant issue for me over the last week. I’m so tired of this platform failing that I haven’t even bothered to report it.

Ditto Daveuk100 and others

For what it’s worth, I too am having trouble with timer based smart lighting. This is a recent phenomenon. Not sure if I should be happy or sad knowing others have the same issue too

I received a reply from SmartThings support today (waited 6 days and eventually had to ping, but they then responded quickly):

“The issue with Routines and SmartApps not firing has to do with some issues on our end that are a top priority for our engineers. I’ll make sure to let our engineers know what’s going on with your case so they can look into a deeper cause. We’re actively working to improve on our platform and apologize for any trouble the Routines and SmartApps may have been causing you. Once we have a permanent fix in place, we will notify you via email. In the mean time, you can manually update the schedule on your side. Just enter the Routine or SmartApp settings and tap Done/Save. If the Routine and/or SmartApp still isn’t firing as it should, let me know the email address attached to your account and I’ll see what I can do from my end.”

I been Having the same problem about 2 weeks ago. I have 2 Cree LED connected bulbs on schedule and those are the ones that I have issues with. Sometimes the schedule turn on but never off, or never turns on. If you go under things I am able to toggle on and off fine. My driveway lights and on a GE dimmer that is controlled with the Smart Light app. those on the GE Dimmer works fine on the schedule no issues. I have deleted all the schedules and created new ones and nothing.

Daveuk100 what model are the lights or switch that are failing with the Smart Light app?

Yes, I have been experiencing the same problems. Just bought smarthings at the beginning of the year. Everything works fine, except–the timers. They work intermittently or not at all. I reprogrammed all of my notifications (changing the times slightly) and everything worked fine up until a week ago, then everything stopped working. So today, I tried setting my “Lights On” notification to 2 minutes into the future. 2 minutes later it worked. Ditto with my “Lights Off”. So now I’ve set them back to their original times and we’ll see.

I came home from work tonight and wondered why my wife was walking around a half dark house. Apparently my switches that trigger at sunset came on, but my bulbs set at specific times through Smart Lighting failed. A few weeks ago it was the switches that didn’t trigger, so I’m not so sure the problem is isolated to just the timers.

I had done the following and Smart Lighting has been working on schedule ever since.

  • Remove the Schedule Associated with the Light(s) that are not working

  • Remove the Light(s) from SmartThings(ST)

Then I joined those lights to ST and Added Smart Lighting Schedule.

They have added an Update button under Home >> Installed Smart Apps [List Smart Apps] but this update button did not fix the issue for me when the schedule did not work.

My solution was removing the schedule associated with the lights, Removing device from ST and adding them again.

I continue (for the last 3+ weeks) to have scheduling failures with the “Once a Day” App. It works about 75% of the time. All I’m trying to do is turn on & off a switch at the same two times each day. Sucks that I have to wake up at midnight and & 6AM every day just to make sure Smartthings is doing what I paid for.

Thanks z_samurai - I am going to give this a try (I took the whole hub back to factory defaults and I am going to reinstall everything). It’s absolutely ridiculous that we have to do this all over again (just did it a few months back for the v1 to v2 upgrade).

I find it very sad that more advanced operations such as turning on/off lights based on motion and proximity sensors works perfectly, and yet the “Smart Lighting” app can’t even turn the lights on/off reliability based on a fixed time! The saddest part is how long it’s taking for SmartThings to fix this issue…

Daveuk100, before you start putting all the lights on schedule. I would just put 1 or 2 and set them in fixed time to turn on like 5minutes from the [current time] and off after 5 Minutes.

I did this testing after they where added to ST and the schedule [Fixed Time] has been working ever since (Knock on wood)

Sigh…

I reset my hub (removed all devices etc and deleted my location) and slowly re-added the devices back to the hub. Things were working fine all the way along and my “Smart Lighting” timers were working great for just over a day. Unfortunately, today they are back to being broken again…same exact issue with lighting timers not firing and history showing no attempt to even turn on the lights.

I’m really sick of the reliability issues. The v2 hub was meant to solve many problems and so far it’s been worse than v1. SmartThings support doesn’t seem to be providing any updates on the issue and still lists everything as working 100% on their status page.

I received a free Wink hub a little while back when I bought some GE Link lightbulbs via wink.com. From other threads it seems like people are having much better success with Wink and it’s actually able to provide reliable lighting timers. I’m going to switch for a while and see how things go.

Couldn’t agree more.

I’ve had two months straight of broken behavior now. For about a month, the Gentle Wake Up was having issues with the timer/scheduling where it would get stuck halfway, and this past month after that, literally nothing set to trigger based on time has worked.

Most frustrating about it though, is SmartThings’ insistence that everything is fine. Check the status page at any point, and it’s always ‘operational’. The platform is flat-out broken.