[ST Edge] Unable to uninstall/delete Zigbee Button driver

Hello,

I have ran into a bit of bother trying to remove the Zigbee button edge driver, not trouble installing/uninstalling the others. I get a 504 error in browser and when trying to delete within the app, it hangs for a while then I get a “Check your network connections.” error.

The driver seems to be assigned to an Ikea button, I have tried the following:

  • Removing the device and deleting/uninstalling the driver
  • Changing the device driver to another driver (in the hope I could then uninstall)
  • Turned the hub off and on (v3 Firmware: 040.00006)
  • Unenrolling re-enrolling from the beta program

The only other option I can think of is to completely reset the hub, I really don’t want to do that and lose all of my setup. Please help me!!

I have also had a read of this similar post but a different issue, I believe.

I’m not at the computer I use for my ST work right now, but I think those timeout errors tend to indicate a device is still using the driver. If you’re confident that’s not the case, I would try the CLI before nuking my hub.

Hi! Did you check if you keep receiving logs from a device that is using this driver?
This can be seen using the logcat command in the CLI.
To be able to delete a driver, you must make sure no device is still using it. Have you tried to delete the driver by following the steps I shared here?