Help deleting Zigbee devices

I have deleted some zigbee remotes of various brands with plans to add back using Edge drivers for local control. The issue is that I deleted from the app but the devices are still showing in the IDE. I tried re-adding using the stock DTH and but they are not adding back correctly if at all.

Eria dimming remote
Ecosmart remote
In US on V3 hub

I should also add that I’ve tried rebooting the hub several times

Once I confirmed the Edge driver(s) I wanted to use were on the hub, I deleted the devices with the app and immediately added them back and they picked up the Edge driver.

I can’t get them removed from the hub. After deleting from app the device stills shows active in the IDE and automations continue to work despite device not showing in the app.

Did you try deleting them from within the IDE?

I did but they will not delete from the IDE.

To recap:

  • Deleted device from ST app, still appears in IDE
  • Tried deleting from IDE and says cannot delete
  • Tried repairing devices, only partially integrates and still will not delete from IDE, does delete from ST app but still shows in IDE
  • Rebooted hub
  • Opened ST support ticket