[ST Edge] Issues with the Zigbee motion driver

I tried the ST zigbee motion edge driver for a SmartThings motion sensor.
I got it to pair but only the temperature worked. Motion or battery are not working.
I clicked the uninstall button and deleted the device so as to go back to the old dh. When I try to pair my sensor again it keeps picking up the edge driver.
How do I fully uninstall the edge drive as the uninstall button is not working.
Thank you.

Hi, Ashley! It’s good to have you back.
Which device are you trying to integrate into this driver?

You need to uninstall the driver from your Hub, this option is also shown on the invitation channel page.

Hi Nayelyz.
I was trying a SmartThings motion sensor (Samjin).
Yes I did un-install from the hub on the invitation page.

mmm…that’s odd.
Please, go to the SmartThings app and follow these steps:

  1. Enter to the Hub and select menu (three-dot symbol on the upper-right corner)
  2. Tap on “Driver”, “Zigbee Motion Sensor” appears on the list?
  3. If so, select the driver and click on “delete”
  4. If not, try to reboot the Hub to force its refresh
1 Like

Perfect. Thank you. I didn’t even know that menu was there.
I am experimenting with the edge drivers and this was my first try.
I will give it another go with a few more of my many devices🤦🏻
Once again thanks.

No problem, we can also check why it is not working correctly for the device. To do so, I would need your help by getting the Hub logs and sending them to me by direct message or to build@smartthings.

The instructions to enable the Hub logs are in this post:

Will do this tomorrow for you.

1 Like

Sorry about this.
I’ve downloaded the CLI file and opened it in a terminal window on my Mac.
I presume that’s what the instructions mean🤦🏻
What is the next input into the terminal window.
Thank you

Following on from Nayelyz advice I deleted the ST sensor, uninstalled the drivers and rebooted the hub.
Re-installed the ST motion sensor driver and re-paired the ST motion sensor.
Everything now working.
Now onto my other devices. Hope there are drivers for Hive motion and contact sensors.
Ps I still would like to help with sending hub logs in case of future issues.

I’m glad it’s working now. As we’re in beta for Edge drivers, some inconsistencies are expected, rebooting and deleting the package to start from zero can help solve some of them.

In the terminal you should see that you’re inside the directory where you saved the ST CLI file. Eg. In Linux:


Then, you just need to type the file name (“smartthings”) and add a command to trigger the authorization:

user@...:/mnt/c/smartthings_cli$./smartthings devices

Then continue the steps:

  1. This will open a browser page where you have to log in to your account and authorize the access.
  2. Once it says “you can close this window”, run the command smartthings edge:drivers:logcat .
  3. It will prompt you the IP address of your Hub which you can find in the IDE > My hubs.
  4. Select the corresponding driver

Sorry. Am I missing something. Command not found message.
I’m just getting used to Macbook terminal so I’m unsure if I’ve missed a command somewhere.
I’ve blanked out the Mac user details.
Thank you

Hi, @Ashley69, sorry for the delay. I couldn’t test the CLI function in a MacOS, but here’s a conversation that could help you out:

1 Like


I’ll give it a look.

Hi nayelyz

Just to let you know this thread helped get up and running.


1 Like

Glad to hear that!
The Hub logs give us a better reference when we see issues with our devices.
I’ll be around in case you need more help :smiley: