Unable to uninstall the driver from the hub

Hi,
st edge:drivers:uninstall -H <hub id> <driver id>
returns the following error:

    Error: Request failed with status code 504: "<html>\r\n<head><title>504 Gateway Time-out</title></head>\r\n<body>\r\n<center><h1>504 Gateway
    Time-out</h1></center>\r\n<hr><center>openresty</center>\r\n</body>\r\n</html>\r\n"

The driver was removed from all channels, the hub was rebooted multiple times, but I’m still unable to remove it from the hub.

Thanks

Hi, @ygerlovin.
Are you using a Personal Access Token or the automatically generated token by the smartthings-cli OAuth page for the authentication?

Try using the --token flag at the end of the command:

st edge:drivers:uninstall -H <hub id> <driver id> --token=xxx-xxx-xxx

Hi @nayelyz
I’m using cli, I guess the token was generated automatically.
I have no problem to run other cli commands, like
smartthings devices for example

Do you have a device that could be using this driver?
Try adding the PAT in the command to see if you get the same error. I haven’t been able to replicate the error using both Token types.
If you still receive the error, try to follow these steps to see if you get a clearer error message:

  1. Publish the driver in the original channel
  2. Create an invitation for that channel.
  3. Open the channel invitation page and check if the driver appears as installed there too
  4. If so, open the Developer tools of the browser (Ctrl + Shift + i) and try to delete the driver from there.
  5. Check if you receive an error in the console.
1 Like

Thanks @nayelyz .

I think there is synchronization issue between the cloud and the hub.
After about a hour and several hub reboots I managed to delete the driver.

I also can report that I quite often get errors when executing commands too fast from the CLI (from batch script).
For example, I have a script that updates several capabilities, than makes a driver package and installs it on the hub.
Even if I run this script several times without any modifications to capabilities/presentations or to the source, I get errors in different places or no errors at all.
I suppose it depends on the load of the cloud servers.

I too see this gateway timeout all the time. It’s quite aggravating. I find that several retries or waiting several minutes usually clears it up. I do not include the PAT in my command lines.

2 Likes