[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

Good news! Thanks for letting me know.

I’m a bit worried that SmartThings is no longer recognizing Edge camera devices. I was told early on that Edge doesn’t officially support cameras, so we may be seeing things being incrementally disabled that were once working. Others have reported they don’t even have the Add camera groups option any more in the app…

1 Like

A significant blow if true Tod.

Could mean 2 things, a new camera interface due or just a removal of a truely useful feature

Yea, I’m not really sure what is going on. I’m still able to create new camera devices and groups without a problem on iOS. Maybe we need to have everyone having this problem report it to SmartThings Support. It could just be another app issue.

To be honest Tod, i have little faith with ST support, if i use the words, unable to insert camera into camera group using Beta Onvif camera driver… i cannot see how support would even know what it means, it appears they do not even know camera groups exist

Outside of us users here on the forum, you expert code jockies and the iner forum of ST developers, what we use and try is un documented and un replyable in an meaningful manner from support

Wouldnt be so bad if ST put there devs here to help, but… yeah

1 Like

hi
im on android and cant find camera groups anywhere, also since the last app update new devices go straight into my living room they no longer go in no room assigned.
martin

Is that where your hub is? Mine are going to my Basement, which is where the hub is in the app.

On another note, motion alerts are now… not working, on any of the 4 cameras. Worked for several hours this morning/afternoon just fine.

1 Like

yes my hub is in my living room

Diversifying from the thread title briefly but to the point of features (possibly) being deprecated
Virtual devices and using rooms for storing v devices which are really a place for a condition… i do it, i use it but it makes me twichy…

Just had 46.08 installed on the hub, deleted latest camera and ran a search for same camera, found no issues as before but continues to fail when trying to add to existing camera group or new camera group, so 46.08 was no fix

1 Like

Camera 2 has now started sending notifications Tod with no input or changes apart from using latest driver i guess, i havent touched it but its working

Still unable to add the 1st camera to group though

Created a v camera and this shows same issue, unable to add to camera group

Edit
Good news, ST has washed the server i am connected to, removed my old Smartlighting app AND re enabled camera group inclusion

All back to normal as normal gets at the moment

1 Like

I have installed the SmartThings CLI tool and have accessed the logs. What would be most useful… should I remove all of the cameras and the driver, reinstall the driver and start logging from there?

What are you seeing in the logs now, without touching anything?

Nothing too interesting. Occasional HTTP responses of Unauthorized, but those are usually followed up with the same request that is successful.

2023-01-25T21:50:02.318769356+00:00 DEBUG ONVIF Video Camera V1.1 Sending RenewSubscription request to http://192.168.1.53/onvif/Events/SubManager_2023-01-25T19:00:46Z_0
2023-01-25T21:50:02.378575189+00:00 DEBUG ONVIF Video Camera V1.1 HTTP Response Header: HTTP/1.1 401 Unauthorized
2023-01-25T21:50:02.380346522+00:00 DEBUG ONVIF Video Camera V1.1 Sending RenewSubscription request to http://192.168.1.53/onvif/Events/SubManager_2023-01-25T19:00:46Z_0
2023-01-25T21:50:02.451578106+00:00 DEBUG ONVIF Video Camera V1.1 HTTP Response Header: HTTP/1.1 200 OK

That says the driver is still humming along and periodically renewing event subscriptions with your camera. So things seem to be ok from that perspective. Have you tried hitting the Refresh button on the device Controls screen?

If your camera stopped sending events then it may need re-starting or maybe you changed something in its configuration?

I was just testing in ONVIF Device Manager and this is the result when motion is detected. So, the camera does appear to be sending the data.

I have rebooted the camera, the Smartthings Hub and removed all the cameras from SmartThings, uninstalled and reinstalled the driver and re added the cameras.

Can you do me a favor and give me the driver version you have installed on your hub? I’ve lost track…

By chance did your camera events stop getting reported around the same time as a hub firmware update?

There was a change in the firmware that broke some of my drivers.

The alternate test version of the driver might possibly fix it, but let me look at the code first. Don’t want to cause any more disruption for you if not absolutely necessary.

I suspect that may have happened. Looks like I started the day on 1/23 with 45.00011 and around 4 pm it updated to 46.00008. Around 5 pm that day I noticed the alerts had stopped.

Hello, got my Amcrest camera to connect and subscribe to events with no problem. I also have another virtual camera. I’m having the same issue on iOS and Android where I can’t create a Camera Group.

Has there been any progress on this by chance? Is there some nifty workaround I’m missing?

TIA