Edge Driver for Aqara Temperature and Humidity Sensor?

I just added a xiaomi temperature sensor (@veonua edge driver). It shows temperature and humidity but does not show the percentage of battery (0%).

Maybe after 24 h

I will wait 24 hours.
I also added the Aqara Water Leak Sensor, which works great.

The temperature sensor already shows the battery level!

Why have these drivers not got there own thread so users know they exist and can test them ?


I have had a conversation with @veonua and although he is very happy people are finding his work useful he points out they are absolutely NOT for general useage and will not have any support, they are more a developers learning curve and as such should not be relied upon in any manner, they also do not run locally in automations

So please, if installing any of @veonua pre Beta drivers from his chanel please keep this in mind


Thank you, I’ll give it a try as soon as my hub allows me to pair the Aqara sensor I want to use for testing.

I also sent him a message and I’m sorry that he can’t continue developing the drivers because what I tried works very well.

there are several purposes for these drivers

  • a proof of concept, so ST could not say “we can not support Aqara”
  • create seeds for the developer community so that followers can start developing on some basis
  • show\understand limitations of the Edge platform. Maybe even push ST developers in the right direction to make the Edge more agile, powerful
  • My own curiosity and desire to have faster drivers for my own home

As @fido mentioned no support is intended. If it works for me, that’s good enough.
There are many things I am not happy with and are out of my control.

  • even if the Edge platform is declared to be “local”, and there is an icon in the app. I have never seen automations act with internet cable unplugged.
  • UI is not consistent, it looks like there are 3 or even more different ways to do the same thing. Some features can be not reachable/invisible on another platform or even in another room
  • compound devices are poorly supported. E.g two/three button switch is not available for the light groups and Google assistant.
  • I have no clear understanding of how fingerprinting works. For example, I am able to connect Aqara motion sensor but not Xiaomi, although they are very similar

Hi @Alwas, then I will test my local automations to see what they do.

They won’t work locally nor should have the local icon if automation have:

  • some delay in then action
  • maintain x time the state in the conditions
  • Turn off auto after x time
  • If they have to send notifications.
  • There are some capabilities that are not local with DTH either, I don’t remember now what they are.

It may have the local icon because it met local requirements and no longer meets them. In these cases, when editing and saving again, it loses the local icon

1 Like

Thanks @Mariano_Colmenarejo , I’ve found the cause of what was happening in my case, working with an edge driver that sends get requests, I pulled the Ethernet cable to the hub to test local automations, when I realised the Ethernet cable was in fact useful to communicate on the network, I pulled a different Ethernet cable further up my network, then the automations worked as expected without internet.

1 Like

Disconnect internet feed to router, and try to run Automations then. I had them running successfully. Edge driven Switch is sending on/off to outlet without issue. Also hub is sending on/off Automations to Edge driven Bulbs, no problem.
You will see that Automation is happening, but it will not be seen in the app, as app needs Internet to see device status/update. Once you connect Internet again, it will update app with current status.
I have tested this with @Mariano_Colmenarejo and @krlaframboise Edge drivers. Local execution works fine, as long as you don’t use those timers, that Mariano mentioned.

1 Like

Veonua, thank you for sharing your drivers. I am playing with the Aqara Cube and the Aqara water leak and both are working. Once again thanks for sharing your work it is much appreciated.

@veonua thanks for shared your work!
One question, I want try with the * Aqara Motion Sensor (RTCGQ11LM) but in the GitHub - veonua/SmartThingsEdge-Xiaomi: SmartThings Edge drivers for XIaomi and Aqara devices i don’t understand if I can use it:


yes you can, actually I am having hard time with Xiaomi motion sensor, while Aqara works smoothly

1 Like

Based on your experience with Aqara devices would you recommend them? At least those you have in use? They are affordable and availability is great too. :thinking:

Thanks veonua for creating these drivers compatible with Aqara devices. I added two Aqara motion sensors and while they report motion and lux properly, battery percentage doesn’t work (shows 0%). Is this a current limitation?


the battery question is as old as this forum, try to search.

It is not recommended to use a driver from the channel as it is, the drivers are created as example for developers.

Hi Hafo,

Whether the battery status got updated for the water leak sensor?


I saw the battery status after one hour.
Sometimes it also helps to disconnect - connect device.