Announcement | SmartThings Edge for Devices and Automations

A post was split to a new topic: [ST Edge] Issues joining device with a driver

How exactly do we join a device with a driver? I have installed the driver for the Aqara Cube, but what do I do next?

You need to:

  1. Open the SmartThings app, go to add (+) > device
  2. Click on “Scan nearby” and put your device in pairing mode.
    Note: You can also select the device from the device catalog if possible
  3. There, you should see the device was discovered, after that, wait a few seconds (so the joining process is finished).
    Note: If you see the device wasn’t paired correctly (the device was created but you’re not receiving events - for Zigbee mostly), try to pair the device again and wait a few more seconds in the “scan nearby” page.
  4. Go back to the devices list and you should be able to find it there, it might be in the “No room” section

This makes me think. Does it have to be “scan nearby” or can you choose the device under its brand?

1 Like

Yes, that’s also possible. If a compatible Edge driver is found, it will be selected before the stock DTH.

2 Likes

2 posts were split to a new topic: [ST Edge] Issues pairing a device with the driver

That’s 120 seconds! Who’s going to wait for 120 seconds on that screen?

I thought we had to use ‘Scan Nearby’ to start with? Have I confused myself or has something changed?

Doesn’t make any different to me as pairing using the device catalogue has been broken on the Android app for a number of releases now (it doesn’t select the correct hub if you have more than one, and can even select one in a different location to the one you are in).

That’s not always the case, this is just to consider in case the first time wasn’t successful. It’s generally faster. Editing the post above for clarification…

1 Like

Any news on this Paul? My Iris iL07/iMagic by GreatStar 1117-S got to a point where it was staying online, but would not report motion. Resetting and re-adding didn’t help. I deleted it and reset/re-added and it added as a device but whenever it detects motion the LED flashes green and then blue which seems to indicated it isn’t fully paired.

@Automated_House is this because you tried switching to ST’s Edge driver?

Correct, using the SmartThings provided Edge driver.

1 Like

7 posts were split to a new topic: [ST Edge] Using Switch Edge driver as a reference

Nothing definitive to report as of yet but changes at least for some identified device health issues are in discussion and development. @carter.swedal has been doing the legwork on that front and may be able to provide some more information after we pin things down. The fixes lined up may not work for all devices and we are looking at both specific device fixes (e.g. configuring the device to do periodic reports of other attributes if the ones configured today are not working according to spec) as well as improving some of the inferences made by the core protocol code used to automatically determine the expected reporting interval and fallback “ping” behavior for devices.

For the devices not working are other attributes (if supported) such as battery or temp reported at all? Sorry if these devices don’t support those, I’m being lazy and not looking up the specs as I don’t have those particular devices in my home or test setups. Not receiving the attribute at all does seem like a configuration problem for those devices.

1 Like

2 posts were split to a new topic: [ST Edge] Some questions regarding Edge as a user

For the iris il07 the temperature and humidity report fine. Motion is the only attribute that doesn’t report.

4 posts were merged into an existing topic: [ST Edge] Some questions regarding Edge as a user

@Paul_Oliver, told me that he was using my channel’s zigbee motion sensor Mc driver, which is a modification of the original, with temperature reporting settings and it worked fine for him.
In case you want to try it

2 Likes

I’m trying to setup ST dev env in my macOS High Sierra & need some help as I can’t really follow the over simplified guide.

I followed instruction from smartthings-cli, Step 1. Download the binary from releases tab of the github page, in the page, I saw the Assets section, expend the section, downloaded smartthings-macos-zip.

Different from Step 2, after download, I expend the file, I got an executable file with the name “smartthings”. (not sure why the github step 2 say install it and rename to smartthings, probably not updated).

I move it to a folder call “st_edge”, go into command prompt, navigate to the “st_edge” directory, Following step 3 on the “smartthings-cli” github page, fire the command “smartthings --help”, response is “command not found”.

So what did I missed?

To execute a binary in the current working directory on a Unix system you’ll need to add ./ (dot slash) before the binary name. So to execute the smartthings command in that directory run ./smartthings

This page summarizes some of the history on why this particular bit is required (it’s security related). Linux FAQ: Why Do We Need a Dot Slash Before a Local Command | MangoLassi

3 Likes