[ST Edge] GE/Jasco Zigbee Switches and Dimmers

This is an Edge driver for GE/Jasco zigbee switches and dimmers. The intended models are the 45856 switch and the 45857 dimmer, as those are the models that I own and can test on. Power and energy monitoring are supported for both (properly scaled regardless of your hub firmware version). The switch has no other configuration options. The dimmer has the following options:

  • Default Dim Level - The default dimming level when the device is turned on (a tap on the physical switch or an ON command from the hub). A value of 0 restores the dimmer to the previous level when the switch was last on. Values from 1-100% will scale based on the minimum and maximum dimming settings. This is the only configurable option that I’ve found that is stored in the device - all other settings are programmatic and will apply only to commands originating from the hub.

  • Dimming Transition Time - The time in tenths of seconds to transition to a new level when a set level command is sent. Values can range from instant (0) to 1 hour 49 minutes 13.4 seconds (65534). A setting of 65535 uses the default transition time configured in the dimmer hardware, which for the 45857 is instant. This setting applies only to commands originating from the hub.

  • Transition Time Scaling - Enabling this setting will use the Dimming Transition Time as the time to move from 0 to 100%, and will scale any smaller change to take a proportional amount of time. For example, if the Dimming Transition Time is set to 10 minutes and the level is changed from 25 to 75% (a 50% change), the transition will take 5 minutes. This setting does not apply if the Dimming Transition Time is set to 65535. This setting applies only to commands originating from the hub.

  • Maximum and Minimum Dim Level - Configurable maximum and minimum dimming levels. The device uses dimming levels of 0 to 255 instead of the 0 to 100% displayed in the app. In order to provide greater granularity in setting these limits to match the performance of your light bulbs, these settings use the 0 to 255 values native to the hardware. This setting applies only to commands originating from the hub. Note that, if the physical buttons are used to dim below the minimum level, the app will show a dim level of 0 and the switch in the ON state. A minimum dim level that is set greater than the maximum dim level will be ignored, with 0 being used as the minimum instead.

The behavior of the LED indicator can only be configured with a sequence of quick button taps. Tapping up 3x and then down 1x will cycle through the different options.

Please note that, as of January 2022, Edge is in beta and therefore this driver should also be treated as such.

To install:

Use the following link to enroll in the channel and install the driver on your hub: Channel Invitation . This channel also includes separate drivers for GE/Jasco z-wave switches and dimmers and motion switches and dimmers.

If your device is already using an Edge driver, you can use the driver utility in the app to switch drivers.

If your device is currently using a Groovy DTH, you will need to remove and then add it back to SmartThings to pick up this driver. If you have any custom Groovy DTHs installed that have the device’s fingerprint, either delete the DTH or comment out the fingerprint before attempting to re-join the device.

Code:

2 Likes

Phil I have just installed this new driver and it appears to work well, although the power does not report a value. I would have expected it to show around 20 watts

Are you seeing any power events posting in event history? Wondering whether the issue is no data or that the data is scaling too small. Did you switch from another Edge driver or did you move this device fresh from Groovy?

Assuming you’re seeing events posting, try a hub reboot as a first step since that will restart the driver. and re-query the divisors from the device. The divisors (to scale the meter reports) are queried from the device when the device is first added, and then also whenever the driver restarts.

I changed drivers in the app, from Mariano_Colmenarejo’s.

I just did a hub reboot but it did not change, there are no power events in the app history.

But at https://my.smartthings.com/ it does show the correct power meter value 18.6 W.

Does history on my.smartthings.com show anything weird, like a spike power reading right after you switched drivers that’s powerful enough to fuel a flux capacitor?

With the power showing on the web interface it’s sounding like an app display issue. This driver is all stock capabilities, and the power report handling is nearly stock except for the bug fix, so I don’t think there’s any issue in the driver profile that could cause this. My first guess is that there was a high reading during the couple of seconds following the driver switch that’s outside the bounds of what the app can display.

The other quick thing to try is app restart and clear cache.

It could be a firmware issue, 0.41.x Beta lists the following fix:

  • Bugfix for Edge Driver backed Zigbee devices with the Power Meter capability reporting power levels that were off by a factor of 1000 (incorrect conversions between Watts and Kilowatts)

Are you on the beta firmware?

That bug is one that I reported. This driver already overrides the default handler that had that bug, and therefore should operate the same before and after the firmware update. If you were affected by that bug then you would see improperly scaled power readings on the web interface too.

No I’m not on the beta firmware and of course now that I went back to my.SmartThings with the light on at 100% it shows 0W, go figure.

There were no power readings only on/off/level and the time

Phil,
This morning the power reading is showing correctly.

1 Like

I’ve recently started using Edge drivers so I’m not up to speed on how they work.
I set up one of my switches with this and noticed they are no longer local.
Is there something I need to do to make devices using the Edge drivers to work locally instead of using the cloud?

Edge drivers are truly local, but the IDE incorrectly lists them as cloud.

2 Likes

@philh30 I’m trying to use your driver. I see in the setting it shows options for indicator light but doesn’t show up in webCoRE as an available device. Anyone else see this same thing? I like to control my indicator lights based on STHM status and can’t see any other way to do it other than webCoRE.

The Jasco zigbee switches don’t have a way to control the indicator light by radio.

My driver for the Jasco z-wave switches has the indicator light in settings. To control the indicator through automations, it would have to be exposed as a capability command (most likely on a custom capability).

That’s a shame as the groovy handler worked well for this but when I added the new device it automatically added with an edge driver instead.