Jasco/GE Dimmers stopped 'remembering' last setting since migration to stock Edge Driver

First time posting here - apologies if I’m in the wrong spot but any redirects/advice/ideas would be appreciated!

I have about 10 GE/Jasco dimmer switches that have worked flawlessly for years - through SmartThings, Alexa, etc. One of the main things I use it for is to dim lights in the house and then have them turn on to that same dimmer setting so it doesn’t feel like we live on the surface of the sun.

Starting about 2 days ago, all these switches stopped respecting the last remembered dimmer setting - but only when SmartThings (or Alexa, connected to SmartThings hub) turns it on. If I use the paddles directly, it recalls the last setting.

My dimmer switch’s model numbers are 14294 and I’ve attempted factory resets of the switches, re-adding them, and poking around settings. I know there may be a “Light Preset” parameter, but I don’t see it in the default firmware that SmartThings applies when they’re re-added to my network.

Any known issues atm I should be waiting for? Any thoughts on how I might fix this? Again, thanks for any and all help!

1 Like

Tagging @philh30

1 Like

Have the devices converted to Edge drivers? The easiest way to check is to look for a Driver option in the device’s menu. Assuming they have, the stock Edge driver for these devices is the cause of what you’re seeing. Try swapping to the driver linked below:

2 Likes

@philh30, you’re amazing (props to @JDRoberts for the bat signal). That 100% fixed it.

Just updated to that driver on one of my switches and it’s remembering the settings properly now.

I assume I need to do this for all of them? I’ve seen lots of posts/comments referencing Edge drivers.

Is this a recent development? Do I need to stay vigilant for potentially other disruptions/breaks elsewhere in my network/setup?

3 Likes

Unfortunately, yes.

Smartthings began the automatic conversion to edge drivers in the last few weeks, but it’s rolling out very slowly, they don’t tell you which devices are being migrated, and you just have to wait and see if you lose any functionality. :thinking:

I’m glad Phil’s custom driver worked for you, it’s been a great benefit to many community members. :sunglasses:

3 Likes

Gotcha - I’ll keep an eye out. Hoping this thread makes it to Google’s indexes soon so others can see this if they’re having this problem.

Thanks a ton to both of you!

1 Like