GE/Jasco 45857 Zigbee dimmer ramp rate and limits

I just installed a GE 45857 Zigbee dimmer with a GE Add On switch in a 3-way.

It works fine, dimming and switching from either side.

But the dimming ramp rate, from either switch, is really fast. When trying to dim to a low setting I’m always having it go all the way to off.

These are my first Zigbee switches, I’ve only had pocket sockets and sensors up to now with all switches and dimmers being Z-wave.

Is there any way to control the ramp rate on the dimmer and to set a lower limit? The Zooz ZEN27 dimmers have this and it’s very helpful.

I searched the community but all hits seem to be two or more years old so I don’t really trust them.

HI @HalD,

To be honest, my wife and I never really noticed this because we’ve gotten so use to talking to Alexa to control things now, but I see what you mean.

I remember coming across this dth a while ago, but I never got around to testing it:

The device preferences allow you to set a transition time (ramp rate equivalent) and min/max values. With the new app now letting us to get to settings, I may try this handler out and see how it works. Note thought that the device will move from local to cloud, if that matters to you.


I probably will use Alexa most of the time.

And I do care about moving the execution to the cloud. The delays tend to be just enough to be annoying.

Guess I have to decide which is more important. Let me know if you try it out.

1 Like

No go. I didn’t notice a difference, but I noticed that my ramp rate up or down isn’t really too bad after all. I tried on all 4 of the dimmers we have, each controlling either LED or halogen bulbs. With the LED’s you could see it step down/up, while the halogens were smooth transitions.

If I can find the zigbee specs for these dimmers I’ll see if I can find where they could (or can’t) support similar settings to their zwave counterpart. Perhaps their new zigbee 3.0 version will, but I have no plans to change out switches again.

Thanks! I’m not going to push my luck.

This dimmer is controlling 4 LED can lights. New type that are a one piece lamp with integrated trim, not the old style cans with socket. They are the same cans that I could not dim using a GE Enbrighten Gen2 Z-wave dimmer. I was kind of surprised the Zigbee dimmer worked at all.

1 Like

Just a note on the enhanced DTH… you would only use temporarily it to set the dim rate parameters. once they are set, they are stored in the switch itself. Once it is configured as you like it you can switch back to the original DTH and the parameters will stay.

Another note: I recommend you write down your original settings before you start changing them :slight_smile: Jut in case…

Here is what I used:

1 Like

If it’s changing settings that are stored in the firmware of the switch itself, you may be able to use the custom DTH to change the parameters, then switch back to the local DTH for every day operations. This definitely works for Z wave devices, I just don’t know if it will work on the SmartThings platform for zigbee.

It’s the same for zigbee DTH’s too. Like most ST handlerrs that I’ve seen, when you switch to one, it will initiate a config (at least it should), and if the parameter that was modified by another DTH is in the stock DTH, it will change again.

Anyway, I’m still looking for a spec doc on the supported clusters and attributes for this zigbee devi e.’s doc has a format error making it difficult to read through. Perhaps @tpmanley has any good references.

1 Like

That would be perfect. It’s what I do with the Zooz Z-wave switches.

But for the Z-wave devices I can see that there are parameters with the stock DTH even though they’re not identified by name.

I don’t see any parameters when I bring up the GE Zigbee dimmer in the IDE.

For the Zooz switches, I have their custom DTH installed so it gets selected when I install a new switch. Then I tweak parameters as needed and change to stock DTH.

The Enhanced GE ZigBee Dimmer Power DTH sets the transition time on each setLevel command and doesn’t change any parameters on the device so you’d have to use it long term to permanently adjust the transition time. There is a Zigbee attribute called the OnOffTransitionTime which can be used to set a parameter on the device but that DTH doesn’t currently set that attribute. I don’t know if that attribute is supported by that particular device (it’s optional in the ZCL spec) but you could try it out.

Just add this code to that DTH, switch your device to use it, change the Transition Time setting via the new or Classic app, and then change the DTH back.

def updated() {
	sendHubCommand(new physicalgraph.device.HubAction(zigbee.writeAttribute(CLUSTER_LEVEL, LEVEL_ATTR_ON_OFF_TRANSITION_TIME, 0x21, zigbee.convertToHexString(transitionTime,4))))

Cool, thanks! I’ll give that a try when I get home from work.