SmartTiles: Video Camera Compatibility

I can confirm what mongo stated about not being able to clear the values.

1 Like

I thought I was the only one having this issue…and it was annoying to see an extra non-working tile after I had deleted upto one last left char. However iOS App on the other hand didnt have any issues. I tested it on my wife’s phone and was able to delete the whole URL string completely. Probably a quick workaround for some of you until Alex get it fixed :-).

1 Like

@MongoRanger, @DjAnu, etc.:

Thanks all for confirming this problem and the optional work-arounds.


@625alex and I just agreed that not being able to clear out a Video Stream is a high priority issue.

That means fix is targeted for the 5.6.x release (“a few weeks”); or sooner as a hot-fix (5.5.x).

Release timing depends whether or not we run into complications or higher priority issues / bugs. There’s a few things on the radar to be investigated. Lada, lada, lada. :smiley:

1 Like

Thanks, @xbiggyl

It’s odd that the instructions from the Tenvis website don’t work, but this from you does.
Here’s the page I was looking at previously…
http://www.tenvis.com/blog/direct-url-to-iprobot3-videostream-and-image.html

Note: I know RTSP isn’t supported, but the regular URL way of doing it above that doesn’t even work.
Has anyone else gotten that to work?

Also, with this one from Elie A, can the size of the displayed image be changed?

p.s. Oh…I haven’t actually tried it from within SmartTiles yet, but just in web browser. I will test in ST later…

EDIT: Actually, this type of URL appears to be working as a generic MJPEG video stream, and not just the static/refreshed image. Has anyone else seen this yet?

1 Like

Having an issue removing a video tile since re-installing SmartTiles. I accidentally placed an entry under the Generic MJPEG video streams section and now I can not remove the entry. Every time I delete the entry it defaults back the the last item that I put in. It seems like I can not blank out the entry and therefore it leaves me with an unwanted tile as seen in the image.

Does anyone know of a way to clear an entry after it has been established?

I’m also having a problem flipping the playroom image again. I tried what worked before:

[quote=“625alex, post:92, topic:11633”]
After upgrading to latest version 5.4, try the following custom CSS:

.tile.video.mjpeg[data-link-i=“2”] .video-container { transform: rotate(180deg);}
[/quote]but it does not seem to be working now. The only thing I can think of is that I have placed all of the new entries under the Stop Motion video streams so the image can refresh every few seconds as I still have not found the appropriate code for live streaming of the F18921W V2 camera.

This is a known bug. See post 3 or so posts above.

Feel like an idiot that I didn’t see that. Any suggestions for flipping the playroom image? Does the css code need to change now that the entries are in the Stop Motion video streams section instead of the Generic MJPEG video streams section?

I’m surprised that your camera brand / model doesn’t offer URI (extra URL parameters) and/or configuration options in the Camera Settings, to change the orientation. Remember that this feed could be going to all sorts of different viewers. What model is it again?

I haven’t tried a Stop Motion version myself, but if I find something, I’ll post back.

dchau11 suggested that same thing back in July and I never tried it because the CSS code worked. The problem is that I have gotten rid of all of my Windows pc’s and only use Chrome OS (mostly chrome boxes) for all my computing needs. Foscam plugin does not work on Chrome OS. I could RDP into my parents setup and see if it works or dust off my old laptop but I am dreading the 30+ minute windows updates along with all the reboots that will be necessary by now (happy to be done with Windows). I have been meaning to install Linux on my chromebook; so that may be an option. Thanks for the help, I really appreciate it, and if you come up with a different CSS option I’m happy to try it out.

If you just need someone to install the Foscam Plug in from a Windows PC and log into your camera IP with credentials so that the FLIP bubble can be selected then I would be happy to attempt this for you.

Just trying to assist if needed.

Also, I tested the ability to remove an existing MJPEG Live Video Stream and have experienced the exact same outcome that is being discussed within the thread postings. I would have never (well not for a while) have known that I could not remove the live video stream.

Something else I experimented with was just inserting some bogus characters within the URL link to the live stream to see if I could “break” the link and make it no longer valid. Even though those bogus characters were retained within the URL address after clicking done the live Video persisted and WAS shown within SmartTiles Connect .

@BD0G thanks for the offer but I plan on installing Linux on my Chromebook this weekend. Should be a fun project.

1 Like

Flipping the camera in the Foscam app worked. Thanks everybody.

1 Like

Has any had any luck getting a stream from the Samsung SmartCam HD working in SmartTiles? If so, how can I go about getting that to work?

1 Like

Try this:

http://username:password@ipaddress/cgi-bin/video.cgi?msubmenu=mjpg

It’s working for me. There may be a more optimized stream option but I’m not sure.

Also, the username is likely “admin”.

Anybody have a data usage issue? I setup a dashboard with 3 cameras running the snapshot every 5 second method (which I thought would conserve data usage vs video).

I blew through 2 GB (over cell) in one day somehow and only looked at the dashboard for a minute or two.

Does it keep pushing data after you close the app? It was mostly background data according to the data usage tracker and was mostly Android and Chrome.

SmartTiles doesn’t currently “push” anything; the video feeds are actively polled by the browser.

If the browser is continuing to poll when the phone is off, you can try to disable background data for Chrome in the Android Data tracker, or use an active process killer.

I did that until I can figure out what is going on.

I downloaded a bit rate monitor and measured about 300 MB/Min. Clearly I need to rate limit the data.

I also noted that the browser kept requesting data even though it was not visible.
If you left the app by hitting the home button, it kept going. However, if you leave by hitting the back button (on a S5) it stops requesting data.

@N8JJ,

Even though you are viewing the images within a small tile, the actual video stream is not resampled or compressed in any way, it’s just shrunk to fit into the container. As the result, it’s very possible to consume large amount of data with 4 cameras.

Depending on the device that is used to display SmartTiles, it might be necessary to force quit the SmartTiles app to make sure that mobile data is not consumed in the background.

To reduce the bandwidth, check if your camera supports different resolutions and adjust your Stream URL parameters accordingly.

Also, there’s a configuration within the SmartTiles preferences to reduce video refresh rate. Default refresh rate is 5 seconds.

1 Like