SmartTiles: Video Camera Compatibility

Why can’t you load a single image from Blue Iris? (using the same method as stop motion video streams?


I don’t see that preference anywhere. What am I missing?

Sorry, I just checked and that feature never made it to production. It will be included in the upcoming release.

What are you referring to?

The Camera (image capture) requires it to be a device rather than allowing a URL to Blue Iris for an image capture

There is no way to access that image or video.

I have the D-Link DCS-930L cameras working with the following:

You can get this by right clicking the image in the browser (admin page for the camera) and copying the image url. If you just do image you won’t have the number string at the end and it won’t give a constant feed, you do need those numbers to make it work. At first, it would just load the picture initially and then go blank. Now it works constantly and updates properly.

Has anyone had any luck in getting the HooToo IP Cam HT-IP210P camera working? I personally hate these cameras but I’ve got them and want to use them. I’m unable to get the video feed to repond at all in any browser. The video stream url is:

Additionally, I’m having trouble with certain browsers not operating correctly. Chrome won’t display any cameras at all. Internet explorer does display the D-Link cameras, but not the HooToo Cameras. My mobile devices won’t display any videos at all either.

I solved this by putting the image URL into the MJPEG video section.

The MJPEG command is issued only one and when you command a refresh.
So every time I command a refresh, it takes a snapshot.

stopped working after latest Samsung 1.07 fw update

Nope, this still isn’t working. I’m showing blanks with X’s in them for the videos.

Solution for SightHound Videos:

Step 1: Find your public IP address and ensure port forwarding (if required) has been configured properly. Go to the remote-access url for your sighthound. Might be something like: or something like that. You can make these settings in your options section.
Step 2: In the mobile version of your browser page, go to your camera’s live page. Click and hold the camera (once the feed has loaded), and click “view”.
Step 3: Remove the dimensions from the url up to the image.jpg portion. Copy everything else.
It should look like so:
Step 4: Put this url in the GENERIC video feed in the smart tiles video section.

Problems I keep running into:

  1. I cannot delete previous entries. There are multiple video feeds and half of them shouldn’t be there.
  2. In mobile browser these images are stable, they just need to be refreshed with the page. In Chrome no images show at all (desktop). In Internet Explorer, the images show briefly and then go away.

Any solutions to the desktop solution would be grateful. I do find that the chrome version doesn’t ask for credentials to sighthound, whereas Internet Explorer does. The mobile version also doesn’t ask, but it seems to be handling things fine.

This is a known bug in the SmartThings Android mobile App. If you have access to an iPhone, I believe that you can delete the video Tile. Bug! Cannot blank out field: SmartTiles Video tile and others, SMS. Android v2.0.5

As usual, even though this bug affects many other SmartApps, SmartThings has not given a projected resolution date (or even officially confirmed that it will be resolved). I suggest contacting, as that is supposed to help raise the visibility and priority of referenced issues.

In the meantime, we believe we have coded a workaround into SmartTiles, but it won’t be ready for release for a little while longer as the release has a few other patches that need to be tested, etc… … Odds are that our fix will be released sooner than SmartThings’s, but it’s not a race. Or is it? :runner: :running_shirt_with_sash: :wink:

1 Like

Converting (nearly) any video feed into MJPEG for SmartTiles

I’m using a Samsung SmartCam Pro HD which supported MJPEG over HTTP when I got it, and then… it didn’t. Come to find out, Samsung pushed out a firmware update that removed all non-RTSP streams and apparently it’s never coming back. Thanks a ton, Samsung.

Anyway, this left me with no ability to stream my video feed to SmartTiles so I went looking for a solution. What I found is that VLC does a pretty good job of converting video streams into various formats. This will require a computer capable of running VLC 24/7. In my case, I’m running Windows but VLC is available for most platforms and my approach only requires a CLI, so you might be able to get this going on something like an RPi. Here’s what you need:

  • A system to run VLC on that is running full time. In the example below, I’m running it on a Windows system with an IP of using port 8000
  • Recent version of VLC (I’m using 2.1.5 on Windows as the 2.2.x releases have some critical bugs on Win64)
  • A stream URL for your existing camera that VLC supports (RTSP or whatever). For a Samsung SmartCam Pro HD with an IP of and the password set to “password” that URL would be: rtsp://admin:password@

Here’s how I’m launching VLC under Windows. Linux/Mac should work similarly but I haven’t tested them. This will run VLC in a command window without the GUI components which is handy for automation purposes:

vlc.exe -I dummy --play-and-exit rtsp://admin:password@ --sout=#transcode{acodec=none,vcodec=mjpg,vb=512,width=480,height=320}:standard{access=http{mime=multipart/x-mixed-replace;boundary=--7b3cc56e5f51db803f790dad720ed50a},mux=mpjpeg,dst=}

This will start a server which will present a SmartTiles-compatible MJPEG stream available at the URL:

I’m re-sizing the incoming stream down to 480x320 which is the size of a “medium” SmartTiles video stream in my (limited) testing. You can set the size to be whatever you like in the string. If you want to convert to a higher resolution, use a higher-res source stream from your camera.

For reference, if anyone is using the Samsung SmartCam HD Pro model SNH-P6410BN, these are the available RTSP streams that I’m aware of as of firmware 1.07. Everything else has apparently been disabled by Samsung.

1080P h264 30fps: rtsp://admin:password@
720P h264 30fps: rtsp://admin:password@
640x360 h264 30fps: rtsp://admin:password@
640x360 h264 20fps: rtsp://admin:password@
1080P MJPEG: rtsp://admin:password@

@Lgkahn @mba0823 @chriswheat all appear to be using this camera. Hopefully this might be of some help.


Hi there!

I am trying to use my Raspberry Pi 2 for the transcoding of an rtsp H264 stream to MJPG format that Smarttiles would read.

Unfortunately i cannot figure out the correct cvlc syntax. I am getting all kinds of errors.

Anyone can help with that?

Thanks a lot in advance.

What version of VLC? I found 2.2.x to be unusable for both MJPEG and HLS under Windows. Reverting to 2.1.5 resolved the issues I was having there.

Does anyone have a working Foscam C1 integration to the smartly dashboard? I cannot seem to get anything to work… All i get is a blank screen with a question mark. help?! tx

1 Like

@gblaze you can’t use MJPEG with the C1 since it’s not capable. You have to use the snappicture2 function with the image refresh.

1 Like

thanks 1tufgt. How can i configure this snap picture to smarttiles?

nevermind. got it. thanks for your help…

1 Like

Hi all,

I have picked up a Samsung SNH-E6411BN which i know isnt officially supported by SmartThings but if i can add this into SmartTiles its not so much of an issue. The quality (especially in low light through glass) is superb in my opinion and the form factor of this model is nicer / easier to hide than the officially supported pro version…

Back to my question - to access the mpeg stream i need to pass through the username and password as the first parameters within the url - which means it doesnt conform to the SmartTiles requirement of starting with “http://”

Is there anyway around this?

Eg the url i am working with would look something like this where:

username = admin
password = samsung
ipaddress =

Complete url = admin:samsung@

Hope this is something that i can work into SmartTiles!!


1 Like

Have you tried: …?

  • http://admin:samsung@ (or “https://…”).