SmartThings Hub v2 (updated to 47.10) losing control to Fibaro Z-Wave Switches

Anybody else having issues with control of devices since the new update?

Very similar to this update all control is gone.

Although this time it seems more specific to Fibaro Z-Wave switches. So suspecting Edge issues on the auto-update of the device drivers. Also not able to select new (Edge) drivers to prevent this. The SmartThings Z-Wave Switch driver causing the problem is 2023-04-11T19:49:58.144153692

Who can empathize or support finding the solution? Thanks!

ps: the status ticket mentioning similar issues is showing ‘closed’ while still not resolved

2 Likes

Tagging @nayelyz

3 Likes

Thanks for your compassionate message, Aiwas. Foremost, thanks JDRoberts for the instant mention to nayelyz.

FYI - the issue is SmartThings driver related. It is neither user, neither local network related.

For others affected: I’ve been able to find a (temp?) fix by installing new drivers, other than the SmartThings proprietary upgrades.

Cf. eg. https://zwave.eu/smartthings_edge_driver_collection/ (Single Switch version for Fibaro)

2 Likes

Hi, @mrbrcks
So, you previously couldn’t change the driver controlling the device because you didn’t have another compatible driver installed, right?

Also, could you confirm that changing the driver for the device solved the problem and going back to the driver from ST causes the same error? I’m just wondering in case there was a temporary glitch and it starts working again. If not, it means the driver is broken.

If possible, could you go back to the ST driver and collect some logs for us, please?

  1. Driver logs. For this, you need to set up the ST CLI and run the command below:
smartthings edge:drivers:logcat

You’ll find the Hub’s IP address in the IDE > “My Hubs” section
2. Also, please share the Hub logs that you can send from the IDE.

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below "send hub logs”

And, thank you for tagging me, @JDRoberts. It’s very helpful for us.

2 Likes

Happy to do it. I know you had asked to be informed of reports of issues with the stock drivers.

And thank you, as always, for your hard work and efforts on behalf of the user base. :sunglasses:

5 Likes

The only change in that driver, apart from new fingerprints, appears to have been intended to remove the button capability on Fibaro double switches.

Update: The Fibaro double switch was one of the new production default fingerprints.

@Alwas, I am also experiencing this problem with over a dozen switches by Aeotec. @JDRoberts was kind enough to point me here to watch how this unfolds. If the stock driver has a problem with this new firmware release, (47.10), there will be a whole lot more than the two of us having problems.

For anyone following, I’m having trouble with on/off button functionality too.

1 Like

@orangebucket, See my other reply on this thread. I’m experiencing exactly the same thing with both stock and custom drivers for Aeotec switches. Dead in the water here after the firmware update.

1 Like

I was merely attempting to contribute to the discussion by offering up what the changes to the Z-Wave Switch driver functionality this week were claimed to be as not everyone reads the Pull Requests. Apart from fingerprinting they seemed (to my eyes) to be specifically targeting the sub-driver for Fibaro double switches, removing code replicated from the DTH they believed was unnecessary. How this relates to the OP’s problem I couldn’t say. Update: The Fibaro double switch was one of the new fingerprints.

With the roll out of the hub firmware starting on Monday afternoon and the driver update on Tuesday evening (both in UK terms) it would be fair to suggest that this is a new combination to many users, with only users of the beta hub firmware and the production beta channel driver previously experiencing it for a week or so.

Your timeline does seem to be moving the focus to the 47.10 hub firmware release, at least to me.

2 Likes

I was aware that ST were changing the way they handled on/off events in dimmers and a little while ago I refreshed my memory of a PR from a couple of weeks ago in which it was noted that the Aeotec Smart Switch 6 wasn’t responding to switch multilevel commands with the new way of doing things and so they applied a fix for it.

I’d imagine that the changes may have come on stream with the new hub firmware which is why the 6 is apparently working with the stock handler. Perhaps the 7 also needed the fix but no one reported it?

Whether this is also a factor with the Fibaro switches that were the reason for this thread I couldn’t guess.

2 Likes

Right on. I have no idea, either, if it is related. The Aeotec problems may be related to this thread or may be a red herring altogether.

When I was searching for others with my problem and stumbled on this thread with the same symptoms at the same time (inoperable switches + firmware upgrade + on/off not working + stock drivers not working), I did what I’ve seen @JDRoberts do a lot in the forums… This: :thinking:

Have a great evening! -T

2 Likes

Hi @nayelyz - I had troubles setting up the ST CLI due to some update issues locally (not linked to ST). Did revert one device to the current ST driver to see similar issues & did send over the HUB logs for you to further evaluate. Sorry to not be able to assist further & good luck on the next deploy!

Yep same here.

Unfortunately I managed to screw up my whole system before I found this thread.
I only had 1 Zwave switch that was affected so i though the switch was faulty as it is a few years old so i bought another one but was the same. Relay works but no control from app or voice. I decided to try a hub reset only to discover that i don’t have the welcome code so now i have nothing working at all.

I have emailed, phoned, and live chatted with Samsung and so far they have either not been able to help (live chat) referred me to the live chat that cant help (phone) or not responded (email)

Anyone got any pointers or help to get a welcome code quickly. I need to get this back up and running even if the Zwave is not working.

Thanks

@Ske19 I replied to your other post in the forum in regards to obtaining a Welcome code. :slight_smile:

Once you get the hub back up and running and still encounter the z-wave issue, simply post details (brand/model) on the z-wave device that is not working. Use the following community developed tool for locating info on the device. Find the device, tap on details and take a screenshot of the section and post it with the other info noted above. https://community.smartthings.com/t/smartthings-api-browser-now-available-to-all/249907

Someone on the forum will offer assistance.

and yes, resetting the hub was probably overkill because you may still experience the same issue once you get the hub back up and working.

2 Likes

Thank for your help so far. The good news is my hub is back up and running. The bad news is none of my devices work properly. in particular Fibaro single switch and Fibaro dimmer 2.

Not sure what i need to do. Wait a bit longer or buy another brand of hub. It seams to be related to the firmware update a if not it is a massive coincidence.

Hi @Ske19

Install my Z-Wave Switch and child Mc driver from my channel in your hub

Make a driver change and it should work fine.

When they fix the stock driver you can go back to it

3 Likes

Hi, @mrbrcks.

I will see if that’s enough information for the team, can you share the approximate time when you reverted your device to use the ST driver, please? That helps the team to find the corresponding messages in the Hub log.
Also, please provide support access to your account:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again

Hi thanks that has worked great

1 Like

It worked! Thanks!!!

3 Likes

Hi,

I am not sure exactly how to install your driver.

I clicked the link in your message. Enrolled. Found the driver and clicked Install. What should I do next? I went in to the IDE and tried to edit the device handler but I could not see any new handlers to choose?

Where am I going wrong?

Thanks!