Smartthings Hub disconnected | Can no longer add it to Smartthings App on Android (no matter what I try)

Hello All,

This is my first post here, sorry if I am missing out on any details, please let me know and I will provide the missing info :slight_smile:

  • Smartthings Device - im6001-v3p01
  • Problem Statement - Hub disconnected and now won’t connect, even after hard reset
  • Error when adding hub in Smartthings App - Couldn’t download device controller. Try again by tapping the device card
  • Hub connection mode - WiFi (have tried Wired Network as well)

Background

I have had Smartthings im6001-v3p01 for at least 4 years now, never had issues before. This is the first time I experienced an issue with the hub.

Two days ago, the hub got disconnected and displayed a blinking Blue LED, which indicates there’s no network. Rebooting the hub made no difference, the Blue LED still kept blinking

Just like my other Zigbee lights, when they go Offline in Samsung Smartthings App, I simply remove them and add them again. That’s what I did with the Smartthings hub and to my surprise I can no longer add the hub to the app. This made me realize I have to hard reset the hub.

Followed the instructions to the point, and after a few minutes, got the flashing red and green light which means the hub was ready to be paried again. Everything went normal via Smartthings app and I thought life was so easy and good. But at the last stage in Smarthings App, I see “Downloading Updates 0/88MB” and next second, Success. When I click Done on Success, I don’t see the hub in the App but I see the error - Couldn’t download device controller. Try again by tapping the device card.

At this point, the app shows a pop-up message again stating a hub has been discovered and when I follow the steps, I get Error 33-513.

The above steps were with Wifi. Thus, I thought I’ll reset the Hub again and try Wired Network (Wired is always better than Wifi, no matter what)

I have had the same results, I can no longer add the Hub to the Smartthings App

Screenshot

Further Troubleshooting

  • Uninstalled Smartthings App and have re-installed it on my phone via Google Play Store (I am using Pixel 4xl and have also tried it from Pixel 6 Pro)
  • Hard reset hub multiple times (atleast 7 times by now) and wired the network connection, cannot see any progress
  • Confirmed on my router that the hub is detected & gets the IP Address
  • Recently, discovered the following post from Smarthings Release Notes

Hunch

At this point, I have a feeling the bug is in Smarthings App, but I could be wrong

Requesting help

  • Any suggestions about the error - Couldn’t download device controller. Try again by tapping the device card.
  • Any other suggestions on how can I add the hub back to the App?

Reference Post - Stuck in Download device controller loop

Do you have another mobile device or tablet you can try adding the hub from? Also check that it hasn’t already been connected… either from another device or https://my.smartthings.com/advanced

The URL is great, something I was looking for. Thanks @jkp
I don’t see my hub or any other smart plugs in the list, except one which is directly connected to Smartthings (without the hub). Here’s these screenshot

The hub now shows Green (since my last reconfiguration) but I don’t see it under the hub (like shown in the above screenshot)

I can try resetting it again but I’ll run into same issue (I am very confident at this point).

Have you seen issues like this, where we primarily get the error on the App?

Another screenshot

There have been quite a few users lately resetting their hubs lately with some having difficulty getting it added back.

Thank you @jkp
It is unfortunate to have this issue with no resolution at all.
Per your suggestion, I tried another phone (Pixel 2 this time) but it lands at the same issue.

I do no have iOS device (I am an Android guy) and that sort of makes me believe that the issue is with the App itself. I tried reaching out to their Support via App and it says “Under Maintenance”

Any bright ideas? Else I’ll just live with this for now and hope the update fixes the issue

All I can say is keep trying. Some of those users said it took some time before they were able to get it added back.

Thanks @jkp
I’ve created a Support ticket with Smartthings Support. I am hoping to hear back from them & will update this post.

Until then, I’ll try adding the hub back :frowning:

1 Like

Hi @jkp
I was able to resolve the issue. The RCA was very surprising to be honest. Here’s what happened

  • I reached out to SmartThings Support Team. They gave me many suggestions on how to reset the hub, etc, etc. They did mention that the Hub cannot connect to 192.168.42.xx subnet.

I looked at my network configuration and my network subnet was running on 192.168.50.xx range. Although the network IP range is not exactly the same (as mentioned by the Support Team), it was still in the same class (Class C Network).

Solution

  • I changed the DHCP in my router to a Class B Subnet range. Now I run on 172.16.53.xx range.
  • Once the network IP range was changed & internet was running, I had reset the SmartThings Hub again
  • Post the reset, connected the hub via Ethernet and started the discovery process in the SmartThings App.
  • The hub was discovered as everytime, but something was different. Post discovery, the hub registration took about 40 seconds, compared to 5 seconds during failed attempts.
  • After registration, there were a few updates downloaded on the hub, during this time the light on the Hub changed from flashing Red/Green to blinking Blue and then solid green. It is possible that hub got the new settings and was rebooting to apply them
  • The process on the SmartThings App completed & the hub was now successfully connected.

I can see the hub in SmartThings App as well as on https://my.smartthings.com/

Root Cause

  • SmartThing Hub cannot connect to a network running Class C Network (192 - 233 IP range)
  • The error on the SmartThing Mobile App - Couldn’t download device controller. Try again by tapping the device card is misleading. It should be more meaningful such as Network Subnet not supported or something on similar lines.

I hope this helps someone in the future. I do appreciate your help and suggestions.

1 Like

Ignoring the use of the obsolete classful network terminology (I still think in those terms, thirty years on from CIDR), the vast majority of the old class C network range was for public networks. If you mean the 192.168.x.y private IP range then I am afraid that still simply isn’t the case. I’ve never had a consumer grade router that doesn’t use one of those networks by default. I’ve got ‘x’ defaulting to 0, 1, 8, and 168 on various routers lying around. None are a problem with SmartThings.

I can’t recall ever being aware that the hub couldn’t connect to a 192.168.42.y network so that is useful to know, and I am hoping someone will jump up and offer a reason why. At a stretch I could imagine the effect extending to 192.168.32-47.y but it certainly isn’t anywhere near as broad an issue as you suggest.

It is valuable to know that any private network range could ever be a problem though. It wouldn’t really have been on my radar.