Cant connect to v3 hub

I just purchased a 3rd generation Samsung SmartThings hub, along with a multi-function sensor. I am trying to get the hub to work with the latest Android SmartThings app on the Android Play store.

The installation gets to the point where it scans the QR code on the router, then it gets hung for a while, finally giving up and displaying “Can’t Connect to Hub”. I tried this on 2 different home router networks, both of which have solid internet connectivity and good coverage throughout the house. It always gives up at the same point.

If this can be made to work, I’d like it to, but unless someone can help, I’m returning it to Amazon.


What is the color of the led light on the hub?

I also had trouble with mine but got it to work by connecting it to the router with an ethernet cable. I still have it using a wired connection, and haven’t tried unplugging it to see if it will use WiFi instead. I at least haven’t seen anything in the app that indicates an option to switch from wired to wireless. So… plugging it in might work for you but you might be stuck with a wired connection.

Flashing red/green

Red/green (blinking)

What it means: The Hub is ready to connect

What to do: You will see this when first plugging the Hub in to power out of the box, or after a factory reset. If you haven’t already, open the SmartThings app to connect your Hub.

So back at square one :slight_smile:

Hopefully your wireless network is not isolated from the Ethernet devices.

Just in case, here are the directions:

A couple comments/suggestions.

  1. Make sure you are using the new app and not the classic app to initially setup the hub
  2. Get the hub as close as possible to the wireless router, like within a few feet, optimally complete the intitial setup with an Ethernet cable.
  3. If you are only purchasing one multifunction sensor, please thoroughly read up on mesh networking in regards to zigbee and zwave devices. Your hub will have to be relatively close to the sensor and without interferences to be reliable. You must have a strong mesh network for these devices to be reliable.

Yes on #1 and no on #2.

Another poster who had this problem said he fixed it with a

wired connection to the router. I’ll try that when I get a chance.

In case it helps, I started out the setup process on WiFi, and then plugged it into the router when it got hung up. I’m home now, and just tried unplugging ethernet and the ST hub remembered my SSID and PW and connected right up. So if you want to eventually run it on WiFi then you might want to try to at least progress through the point where you enter your WiFi info and it connects before you plug in the ethernet.

Also, here’s a thread where some ST staff chimed in on this. I just skimmed it a bit and it looks like this is resolved in a recent firmware update.

Thanks for the replies; I finally got it working by using an ethernet cable connection to the router.

For those here that aren’t engineers or technicians, a little clarification on the technospeak that obfuscates much of the dialog on these sites and makes them marginally useful to many. A Mesh Network is a special type of local network where the devices on the network can act as sort of ‘repeaters’ for other devices. In this way, a device that can’t communicate directly with the main hub can use other devices that do have connectivity to the hub to relay the messages. This infers that at least one device needs to be in wireless range of the hub and other devices need to be able to find a path of devices that can communicate to each other back to the hub. This all happens transparently to the user. It’s very cool technology.