Schlage Connect BE469 Zwave Plus ZWAVE_S0_DOWNGRADE

I just purchased SmartThings v3 hub and BE469ZP Schlage Connect Smart Deadbolt. The instruction packet of the Schlage Connect Plus has a Z-Wave Plus logo, a DSK code, and a five digit code in a box (Not the lock programming code, but another code).

During pairing, the SmartThings (new app) app says: Remove the battery cover and press the button. If you are pairing using a QR code, Scan the QR code and then press the button. There is no option, however, to scan a QR code.

I am able to successfully pair the lock to the SmartThings hub, but upon pairing, an error message says “Some security features not supported. Your device has been connected, but it isn’t using the highest level of security. Use a newer Z-Wave device for the highest security.”

In IDE, the lock is correctly identified as Schlage COnnect Smart Deadbolt Door Lock, but in the Data section, it says: networkSecurityLevel: ZWAVE_S0_DOWNGRADE.

AFAIK, The networkSecurityLevel is supposed to say ZWAVE_S2, but I am unsure.

Any help would be appreciated. Thank you.

Schlage is ‘looking into this’ and SmartThings support apologized for not being able to help - because they couldn’t see the networkSecurityLevel from their side of IDE.

Interesting. They’ve been working on S2 support, but I haven’t heard it’s officially ready yet. @Kianoosh_Karami looks like S2 is close?

Their website (https://www.schlage.com/en/home/smart-locks/connect-zwave.html) says “The Schlage Connect Smart Deadbolt includes the highest industry security standards. By incorporating Z-Wave Plus S2 enhanced security, the Schlage Connect Smart Deadbolt provides an additional layer of encryption and protection from anyone attempting to access your smart home.”

Looks like it’s supposed to work. Fingers crossed that somebody has been successful with this!

Yes, the lock supports it. The SmartThings hub and/or app does not.

Ahhh… That’s sad.

See this post for a detailed explanation and what to do when the hub is ready with S2 security:

2 Likes

Did you get this fixed. It a Smartthings issue. Both my new Kwikset 888 say the same thing. Mine say networkSecurityLevel: ZWAVE_S0_LEGACY

1 Like

By default the new ST app always uses S0 for inclusion for maximum compatibility. The latest hub firmware now includes support for S2 but there’s no real advantage you will see as an end consumer in using S2.

However if your devices support S2 (unauthenticated or authenticated which requires you to have the DSK/QR code), in the new ST app click on + Devices -> Generic Z-Wave and follow the onscreen prompts. Keep in mind that not all custom DTH’s support the S2, most stock DTH’s should work fine and if you’re using a lock you can use this Enhanced Z-Wave Lock DTH it has the necessary modifications to support S2 with the latest hub firmware.

Thanks tried that, still doesn’t work.

Still says;

Current States
lockCodes: {}
scanCodes: Scanning
checkInterval: 3600

I think something is wrong with the lock itself.

Here’s the solution. The one I found after trying all day with the previous comments being useless.
CREATE A NEW ROOM WITHIN THE SMARTTHINGS APP. From there I connected with full functionality.

I had similar issue. And, found that the light on device turns solid red which indicated connection issue. I tried multiple times, and got the device blue light. After that, it works fine. I started with QR code scan.

1 Like

You may want to consider adding a beaming repeater close to your lock to improve it’s stability:

After losing connection to smartthings after a power outage I no longer can access the door lock, after reinstalling 10 times and getting your exact same messages myself. I have finally stumbled across this post and also have a limited access to my now called z wave device. It will not, no matter which steps taken or undone, allow Schlage connect to properly add itself with full functionality. If it is our devices it is still unacceptable and not a one off. Boo urns

Try this:

Good to know. Why is this?

Let me clarify that:

  1. If you feel you’re at risk of being hacked by someone parked close enough to your property, snooping your z-wave communications and having the patience to hack through the S0 encryption, then yes definitely you should go for S2 encryption
  2. S2 actually has one advantage, it reduces traffic on the Z-Wave mesh, so that’s a BIG plus if you’re devices that send a lot of traffic (like switches and plugs which report voltage, temperature, current etc every few seconds).
  3. S2 has a disadvantage if you’re using a lot of legacy S0 or non secure devices, it could have some compatibility issues (it should not as per the specs but real life happens). If you have a lot of legacy devices and you’re seeing issues crop up after pairing your device in S2 mode, then try switching back to S0

Otherwise now with the latest hub firmware S2 is actually the way to go for new devices.

1 Like