[RELEASE] Stelpro releases its Ki ZigBee Line-Voltage thermostat: the STZB402+

Hi there,

Stelpro released a new thermostat from its Ki series, the Stelpro Ki ZigBee Thermostat (STZB402+) aimed to control baseboard heaters, convectors and Fan-Forced Heaters up to 4000W powered at 240V (also works up to 2000W at 120V).

This model also features the “Off” mode, which prevent any heating.

When using this mode, please keep in mind the freezing risk, and be warned that the thermostat is still powered.
Even in “Off” mode, there are risks of shock hazard if you service the thermostat without turning off the breaker.

To this date, SmartThings did not yet publish Stelpro’s device handler for the STZB402+, so you may get the code here:

It is provided under the Apache 2.0 licence

The STZB402+ can be purchased here:


Are we sure that this amazon listing is for the correct model? The model number isn’t correct: STZ402+ vs STZB402+, and the item description mentions it being “Z-Wave” compatible.

Well… this listing is not “from Stelpro”.
It’s from another vendor who seems to resell them.
The listing is poorly written, I agree, but other people from this forum got the ZigBee version from this listing.

Stelpro will eventually sell the ZigBee thermostat on its own on Amazon and other platform, but I have no date so far from our marketing department to share with you.

Thanks for the update. I’ll go ahead and give this a shot. I’ll report back after I’ve tested it with my Fan-Forced Hydronic Baseboard Heater.

Based on the vague description on Amazon it seems this is Z-Wave+, Zigbee, and WiFi ready which contradicts what is over on the Stelpro website. It shows only two different models

4000 W KI Thermostat for the Smart Home - Zigbee (STZB402+)
4000 W KI Thermostat for the Smart Home - Z-Wave (STZW402+)

[quote=“rschandl, post:4, topic:69232”]
Thanks for the update. I’ll go ahead and give this a shot. I’ll report back after I’ve tested it with my Fan-Forced Hydronic Baseboard Heater.
[/quote] Just a word of caution. The manual says
This thermostat is NOT compatible with the following installations
• Inductive load
• Central Heating System
• Fan-forced heater (unit containing motor and fan)
• Heating load outside the specified ratings (Refer to section ‘’Technical Specifications’’)

Don’t know what your existing thermostat has to control your current setup but Stelpro has only one contact designed for the heating load. How does your thermostat control your existing fan now?

I’m just assuming that the amazon link above is for the Zigbee model (which supports the fan-forced heaters). If I end up receiving the Z-Wave model I’ll be returning it.

I did notice they had the correct part in the lower details: Item model number: STZB402+ so it looks good for you.

@rschandl - did it work for your fan-forced heater?

I tested it on my fan forced electric heaters. I have one thermostat connected to 3 heaters in my living room. I have 2 major issues:

  1. The device handler published below crashes my smartthings app each time I tap on the thermostat. So I am not able to use the app to control

  2. The heater fans sound very weird now. Instead of a stable white noise, they sound as if the fans are cycling between high and low intensity. 3 of them together sound even more weird.

Is anyone else seeing these issues? Are there any other z-wave/zigbee thermostat for fan forced electric heaters?

Hi Akash,

I assume you put the Fan option to “Yes”, right?
That sound is abnormal, I opened a support ticket with our customer care.

As for the app that crashes, it should work just fine if you copy the code from github.
Could you try to delete the device handler and copy the code again and then assign the device handler to your thermostat?


Yes, the fan option is “On” in the menu.

For the app, I exactly did what you said - Copied the code from github and assigned the device handler type “Stelpro Ki ZigBee Thermostat”. Let me try deleting the handler and redoing this. Thanks.

Hi @gouroufui,

The device handler is working now, thanks! However there is a small glitch when I am controlling the thermostat using Google home (GH). When I ask GH to turn ON the thermostat, it does it flawlessly. But, next, when I ask GH to set thermostat to a certain temperature, it says thermostat is in OFF state (even though the heater & fans are on!). I then again have to ask GH to ‘switch ON’ thermostat even though it’s already on. I am able to change setpoint after this. So basically need to ask GH to switch ON the thermostat twice to be able to control it. Switch OFF command from GH works fine. Anyway we can fix this?

As for the heater’s cyclic sound issue, I am getting a replacement thermostat to try out. Thanks for your prompt support!


Hi @akashr,

Glad to know that you are now able to use the device handler.

I have no insight how GH handles the integration with other devices.
There is no garantee that GH and Stelpro thermostat will work flawlessly.

Please check the following:

  1. The Eco mode is not a “standard” mode, so it may not be recognized by other devices such as Google Home. Are you using the Eco mode?
  2. When GH says the thermostat is in OFF state, does it mean “Off mode” or “Off period during a heat cycle”?

Okay, but can this GH + Smartthings+ stelpro compatibility be built or expected anytime soon?

  • I am not using Eco mode, but I realized because of these 3 modes, I have to command thermostat to switch ON twice to be able to control it. Is there any way to disable the ECO mode? Just have 2 modes, comfort and OFF.
  • when GH says OFF even though when it is ON, I guess there is some internal virtual switch which is OFF. I am not sure if that’s off period during heat cycle.

As for the compatibility between GH, ST and Stelpro, don’t expect something soon.
The reason why Stelpro published its device handler code is because ST is overloaded with integration requests, so adding Google Home in the equation would take even longer.

If you want to disable the ECO mode, you may edit the code provided by Stelpro and publish it on your devices.
However, be aware that any modification on the device handler is at your own risk.

I received 2 of the zigbee model today. One installed so far and am getting the cycle sound from the fan too. :frowning:

I’ve confirmed fan mode is set to ‘on’.

I’m using SmartThings with the device handler from the github repo.


@gouroufui - I received the replacement thermostat from Stelpro, but that didn’t resolve the issue. I am still getting the cyclic fan sound. The fan mode is set to ON.

I installed the 2nd one and get the cyclic sound from the units it controls too.:frowning:

At least I know it’s not just me.

Are yours 240v or 120v? Mine are 240v Cadet register style.


@JamesW - Yes, mine is 240V and cadet register style as well. :frowning:

I will double check with the customer service to see if they shipped you the fixed version or not.