[RELEASE] Aeon RGBW LED Bulb Advanced Device Handler

This is a handler for the Aeon LED Bulb that has a modern look and advanced functionality. You can use some of the built in programs for the bulb and additionally configure your own custom program in the device preferences page.

Along with the customizable programs, you can choose to have one of the default SmartThings presets (Daylight, Softwhite, ect.) change the bulb to a random color.

There are also a few configuration options if you are running firmware 1.05:

  • Default power on state
  • Customizable transition setting

You can also use my Virtual Device Sync app to create virtual switches for the programs so that you can activate them with other automations.


Cannot wait to try this! Thank you @erocm1231!


Have you tested with CoRE’s capture/restore function?

I will test ASAP…

PS: AEON tech guys explained a couple of months ago, that warmwhite and coldwhite is binary, ie, no transition at all, as is either warmwhite or coldwhite…

Not entirely sure that’s true? I was sure I could slide between but maybe I need to check again?

@erocm1231 did some testing last night. Few things:

  1. What does the configure button do? Didn’t seem to do anything for me on Android?

  2. This might be by design but - the custom pattern doesn’t loop around in the sense that it goes slot 1, 2, 3, 4, 5, 6, 7, 8, 1, 2, 3, 4, 5, 6, 7, 8, etc. Instead, when it reaches 8, it reverses and goes 1, 2, 3, 4, 5, 6, 7, 8, 7, 6, 5, 4, 3, 2, 1, 2, 3, 4, 5, 6, 7, 8, 7, 6, 5, 4, 3, 2, 1, etc.

  3. If I set a custom pattern with one of every colour i.e slot 1 = Red, slot 2 = Orange, slot 3 = Yellow, etc all the way to slot 8, the pattern always starts at yellow (slot 3) and even if I let it fade all the way through, it never shows red or orange in slot 1 and slot 2. I didn’t think to check if it wasn’t showing the colour or wasn’t showing whatever was in the slot.

If I select say red and orange, alternating in the slots, it’ll show the colours but again, I didn’t think to check if it was just a case of it not showing slot 1 and slot 2 rather than an issue with the colours themselves. I’ll check tonight.

This is the response I got a couple of months ago

You can only have warmWhite or coldWhite but not at the same time.
If you have WarmWhite at 100 and coldWhite at 255, then warmwhite will take higher priority over coldWhite.
WarmWhite will need to be 0 in order for ColdWhite to take over.
And both WarmWhite and ColdWhite need to be set to 0 in order for the RGB to take over according to the Z-Wave command class for color.

Let me know if you don’t understand something.

With the implementation in the DTH, the only case ColdWhite is activated is when percent is zero, in all the other values WarmWhite is activated…

@Benji Thanks guys, I will take a look and get back to you. I didn’t notice the problems you are seeing with programs so I’ll check that out. The configuration tile does not do anything at this time, but I am considering adding some of the configuration options from the documentation.

@Squares I’ll add a slider for coldWhite. I never use it and honestly forgot about it.


A little offtopic, but are you happy with the bulbs, related to the colors?

The bulbs are ok. I’m usually a big fan of Aeon products but I hope they release a version of the bulb that is smaller. The colors seem a little washed to me. The price somewhat makes up for it’s downfalls though. thesmartesthouse.com sells two packs for $80. What do you think of them?

Regarding the coldWhite, is it internally separate LEDs or is it just RGB at the same percentage? I am looking at a picture of the bulb taken apart and can’t tell.

Are you looking at my pics? I took a bunch with the ‘bulb’ off since they all came popped off when I received them.

To be honest, i expected better quality. My biggest disappointment is the warmwhite.

Osram bulbs are much better.

I also a big fan of Aeon products.

Aright, so I believe I know what is going on here. First off, the design of the bulb is to go from 1 to 8 and then back to 1. Unfortunately there isn’t anything I can do about that. As for the strange color combos, I believe that SmartThings is converting the value to an integer before sending it to the bulb. Usually that doesn’t cause any problems, but in this case the conversion messes up the value as it can’t hold all the data when the 8 colors are selected. The easiest fix is to just use 7 color choices instead of 8. I think I might be able to fix it by sending the value as bytes instead of decimal so I will try that out.

1 Like

So I checked, it’s seemingly ignoring what’s in the first two slots regardless of the colour if that helps? It has nothing to do with the colour choice in those two slots.

Ok, I just posted the change that I mentioned. Color combos seem to be working now when using all 8 color options. Just as I though, the value was too large to be stored as an integer and SmartThings was doing the conversion when sending it to the bulb. I am now converting the config parameter to 4 bytes and sending it that way. Let me know if that works for you.

1 Like

Yep! Works for me!

It’s strange, and I’m pretty certain this is a hardware/software problem with the bulb itself, not an issue with your code at all, but some colours don’t transition as well as others.

I’ve got the custom set to ‘smooth’/slow/254 with all the slots filled with different colours, is there any way, to have Smart Lighting trigger this custom setting at 10% brightness?

I don’t see the ability to adjust the brightness of the programs which is too bad. You can use my virtual device sync app to create virtual switches for the programs and have Smart Lighting turn on the 6th virtual switch that gets created. I know it is strange that it is the 6th switch, but I planned on adding a 5th premade program. I probably still will if you have any recommendations.

Will give it a go! Thank you!

Can’t think of anything right now, are there any presets from the Fibaro RGBW controller we might be able to pinch? :smiley:

I’m using THIS device handler for my Fibaro RGBW controller, it works better than the stock one, better than all the others! And this is the only one I can use with the Fibaro that all the commands of echo work.

1 Like

@Alwas, can you confirm which Echo commands you have working? I’m able to turn my lights on/off and set the level via Alexa, but I haven’t been able to set the colour yet. e.g. saying something like “Alexa, set the deviceName to green” doesn’t work. :confused:

The Fibaro I’m using with the echo is in the kitchen, so just thankful I have on/off and dim percentages. I’ve read the echo is still mostly colour blind, but I think colour only works with the hue lights as of now.

@zcapr17 I’ve never tried setting color from Alexa. Is this something that is a standard option with the Alexa + SmartThings integration?