Samsung 2016 Smart TVs as Devices

devices
echo

(Jake) #1

I did a few searches but may have somehow missed the announcement. It seems at the very least my 2016 6 series is now able to be controlled as a device. Power Off, Volume, Mute, Picture and Audio Modes all work perfectly. Power On only seems to work for a couple of minutes after turning the TV off before it fully enters sleep.

Alexa automatically added it as a switch and is able to turn it off and on.

Has anyone else had success or know if there was an official announcement for this support yet? I know there was some testing last summer but it didn’t seem to be working for anyone.

Edit: 2016 not 2015


Please help! Can't connect Samsung TV ks8000 to SmartThings hub
UPDATE: 2016 Samsung TV Smartthings Integration = BEWARE it's False Advertising - Update: Not anymore!
#2

How do you add it into SmartThings?


(Jake) #3

Add a Thing > Manual > Samsung Products > Samsung Smart TV


(Robin) #4

Not an option on U.K. shard :frowning:


(fightingmajor) #5

this really needs the ability to switch the Special Picture mode. Would be nice when I switch from Xbox to watching a tv that it would switch from Game Mode to HDR Mode.


(Mark Marino) #6

I was able to add my 2016 8-series TV this way and can control (very basic) commands on the TV but I am wondering if there is a way to display SmartThings notifications on the TV (like “Porch door is open”) while I’m watching TV.

Any clues on how to do that?


(fightingmajor) #7

You can use core.


(Bertan Aygun) #8

I am able to add 2016 KS8000 TV as a device but I had just created a separate thread on an issue. My hub starts to become unresponsive 2-3 days after I add the TV, it goes back to normal if I remove it. I’ve tried it twice now in the past month with the same outcome.


(Tony) #9

Lucky you, this is not implemented in the UK, yet sold as if it was…

Since the Samsung TV is not listed in the UK smartthing app as a Thing, is there any ways to install manually via the IDE (ie login in the US graph.api IDE). “2016 Samsung TV” is listed. What are the parameters to link with the TV (Network ID, etc?) ???


(Mark Marino) #10

I set up CoRE just to try seeing if I could send messages to the TV… having trouble figuring out the “Then” part of the Piston…

Action is currently:
Using…
Samsung Smart TV
First,
showMessage(…)
Parameter #1 type
string
Parameter #1 value
Hello, world.

I get an error back from CoRE saying “Please check the value range of input fields.”

So what’s the secret sauce to get CoRE to show notifications on the TV?


(Mark Marino) #11

Interesting. Mine’s an 8 series too. Will report back if I get the same non-responsiveness on the hub after a few days.


(fightingmajor) #12

This is from the extend thread.


(Mark Marino) #13

Thanks for the follow-up. I have tried switching it over to deviceNotification(…) parameter #1 type: string parameter #1 value Hello World, but still getting the vexing “Please check the value range of input fields.” message when I hit Done. Anybody have this working?


(fightingmajor) #14

Are you selecting your tv under Control any device?
What are you using to trigger it?


(Ricci Hoffer) #15

I ran accross that a couple times. If you hit the back arrow once or twice it will show the updated info in the poston and it will work when executed. Also if you are going back and editing the string value hit done on the key board before hitting done on the top. It seems to save the edit when the red error bars are appearing. At least when using android.


#16

I have the same question as OP … I cannot get the TV to turn ON. Just using the SmartThings app at the moment but want to be able to use scenes, logitech harmony, alexa, etc. It doesn’t work from SmartThings and therefore nowhere else either.

Am I missing something obvious?


(Jake) #17

It’s because when the TV enters a deeper level of sleep it removes power from the wireless adapter so it can’t receive a wake on lan request any more. You’d need to use your Logitech Harmony’s IR blaster to turn it on.


#18

That’s terrible. Ugh. Trying NOT to use IR blaster. The whole point of the harmony hub was to keep it hidden with the components. Would suck to have to run a wire through my wire-free zone. Is there any way to change the settings to get this to work?


(Derek) #19

Harmony hub itself is a very powerful blaster. It also has optional wires, but as long as it’s not in a cabinet it should be able to control your TV without wires.


(Jake) #20

Looks like this was recently fixed in an update. I’m not sure when, but I can now power on no matter how long the TV has been off.