Pairing Aqara to Smartthings Edge (TIPS AND TRICKS)

I know from reading various posts people run into challenges getting Aqara sensors paired to Smartthings via Edge drivers.

Having done a few deployments of this recently I have a method that works every time for me so thought I would place useful tips here hoping they help someone else also. I realize that not everyone has the same setup or the same environment but these tips should be fairly universal.

  1. Overall I have 17 Aqara devices deployed.
  • You can see below, the bulk are contact sensors but I also have vibration, temp humidity, wireless button, motion sensor , water leak and even an Aqara smart plug.

  1. 4 of those devices route through Ikea Tradfri Control Outlets.
  • These sensors were physically located at the edge of the Zigbee network so they would often drop registration.
  1. My current Zigbee channel is 20 .
  • While I have no documented proof of this yet my perception is this channel is typically 100% in getting this registered quickly and correctly.
  • Another user has channel 25 working for them .
  1. From a Drivers perspective usage breaks down like this also please note i am not saying these are the only drivers that work just the ones I am currently running.
  • QTY 7 Contact Sensors = Zigbee Sensors Edge Driver [YG] 1.8.14
  • QTY 3 Motion = Xiaomi Motion Sensor
  • QTY 3 Vibration = Zigbee Sensors Edge Driver [YG] 1.8.14
  • QTY 1 Water Leak = Zigbee Aqara Water Leak Sensor Mc
  • QTY 1 Temperature and Humidty = Xiaomi Temperature
  • QTY 1 Smart Outlet = Xiamoi Plug
  • QTY 1 Button = Xiaomi/Aqara Switch and Button v1.6

Having set everything up with the above this is the approach I take every time and every time it works to get these devices registered.

  1. I make sure that I can get the Sensor within 1 inch of the front of my Aeotec v3 hub.
  2. Run a scan for devices in Smartthings
  3. For each sensor I follow the process of holding down the pairing button for 5 seconds until I see the 3 blinks. I then press the reset button on a 1 second cadence always ending it before the scanning cycle completes. (No proof currently but again my perception of this is over a few different deployments is that ending before the scan cycle works the best)
  • For the plug its generally the same except you are holding down the Power Button
  1. Device Registers

As I have moved things around in my home I have factory restored the v3 hub and in some cases not but as long as I am on channel 20 , less than an inch between hub\sensor and follow this cadence it is 100% successful.

Hopefully this helps someone and feel free to ask any questions as I will gladly share whatever I have learned.

8 Likes

Sounds like a plan! :sunglasses: The channel 20 information is interesting; I haven’t heard that tip before. Good to know!

The one thing I would add for those who have larger properties or more devices is that when doing bench pairing (that’s what it’s called when you pair a device very close to the hub and then move it to its actual location) the device doesn’t know its true neighbors, in particular the devices closest to it that can repeat for it.

For this reason, it will generally be a good idea to do a “Zigbee heal“ after all the devices are in their correct locations. That way each device will know its real neighbors.

Doing a heal for Zigbee is easy: just leave all your devices on power except the hub. Unplug the hub and remove batteries if it has any. Leave the hub off power for about 20 minutes. This will cause the other devices to go into “panic mode“ because they can’t reach the hub. Then when the hub comes back online, the devices will all rebuild their neighbor tables, making your network more efficient.

For more tips on efficient networking, See the FAQ on range and repeaters. :sunglasses:

A Guide to Wireless Range & Repeaters - #11 by JDRoberts

6 Likes

My Zigbee channel is set to 25. Changed it little while ago when I had some interference . Been working like magic since the change. I believe I watched a video about it on YouTube by Automate Your Life. All my Aqara devices work perfect except for the vibration sensor. I just added 6 buttons and 2 of the Opple Buttons Also and zero hiccups except the vibration one .

2 Likes

That is the fun of this , you would think between all of our experiences we would get a full plan. =)

Going to add your channel 25 to the OP.

I know I tried that once very early on but found a few different articles mentioning how older Aqara devices had issues with higher channels. Obviously any 802.11 deployment is going to impact which channel is viable.

I have 3 vibration sensors deployed without issue including 1 routing through an Ikea plug currently so we know they work. Do you actually see it trying to register via CLI logs?

1 Like

I didn’t try that approach yet. I will and let you know what I find

1 Like

Anyone tested the E1 Blind Motor?
Does anyone know Will Aqara be adding support for more devices?

Surely we have some method to change Zigbee channels when IDE is read only / gone?

3 Likes

I also join channel 25.
Same exact situation and method to reassociate them. I confirm that it works and with the 25 in my house it works better than with the 20 I used before.

" * QTY 1 Temperature and Humidty = Xiaomi Temperature"

Would you be so kind as to provide a link/a clue to where this driver exist?

Yah, should be the Veon library.
This channel invite: SmartThings. Add a little smartness to your things.

1 Like

Could you share the link to the driver * QTY 1 Water Leak = Zigbee Aqara Water Leak Sensor Mc?

I’ve been using the driver from the veon channel but it seemed unstable.

Andrew - did you get ALL your AQARA drivers from the VEON library?

1 Like

could you maybe also add a driver for the Aqara Radiator Thermostat E1 Zigbee

Thanks in advance

Where can I find and enroll in the Aqara Water Leak Sensor Edge driver?

I have only relatively recent experience with Aqara devices, but this is what I have experienced:

I have at least one wired zigbee device in each room, and have always used channel 15.

In June I added an Aqara ZNCZ12LM smart plug and two Sengled ‎Smart Plugs G2, I had a mixture of DTH and Edge drivers installed, I remember that both brands were a PITA to add even within 10’ of the hub.

In August I changed to an Edge driver for the ZNCZ12LM smart plug and it has been relatively painless to add any time I have had to, even in its normal location 35’ from the hub.

Also in August I added an Aqara open/close sensor MCCGQ11LM using an Edge driver, and it took a few attempts to add, it is located within 20’ of the hub. This device has had the fewest drops from my system during all the app/firmware changes that have occured over the last few months

In September I added two more Aqara open/close sensor MCCGQ11LM using the Edge driver, the are about 70’ from the hub and also required a few attempts to add. Both of these have dropped from the hub often during all the app/firmware changes that have occured over the last few months. One much more that the other, they are about 4’ apart on my washer and dryer doors, with a Zigbee switch on each side of them. In an attempt to stop them from dropping off of the network I replaced the Z-Wave outlets for the washer and dryer with Sengled ‎Smart Plugs G2, it really did not appear to help.In the last couple of weeks with 45.00011 firmware only the one kept dropping every day, I changed the signal strength signal interval to 45 minutes, and I have not had it drop for a week! Since some time in October all my drivers are edge, and using the hold 5 seconds, click every second cadence I have been able to add the problem Aqara open/close sensor MCCGQ11LM back online first try every time, but do seem to only appear at the end of the first scan. (It maybe the twice a day practice adding it)

Also in September I added a Aqara P1 motion sensor using an edge driver, it also dropped from the hub often during all the app/firmware changes that have occured over the last few months. I also added a Sengled ‎Smart Plugs G2 close to it and it has not dropped for a while even before 45.00011.

In mid October I added one more Aqara P1 motion sensor using an edge driver, but instead of using the button I scanned the QR code and to my surprise it added in an instant! It has only dropped from the hub once or twice before 45.00011, and 45.00011 wiped out all my battery operated Zigbee devices and wired Sonoff’s, but only the one Aqara open/close sensor MCCGQ11LM has dropped since.

So I now know that the Aqara sensors can be very easily added, even a good distance from the hub, but are very sensitive to weakness in the network and or hub issues, more so than other battery powered devices.

Historically before edge my zigbee network was rock solid, the only issues I had were typically with z-wave devices especially battery operated, which are all now connected to power supplies, or replaced with Aqara sensors. I have 156 devices and approx. 175 automations and the last couple of weeks on 45.00011 are starting to remind me of the ‘old days’, but enjoying the the added speed, and local execution of automations.

Hopefully this long winded post helps someone.

1 Like

Thanks for the tips! Didn’t work for me though :confused:

First time trying with Veon’s drivers. My ZigBee channel was already set to 20, I tried with 25 as well.

I’m 99% sure that the issue is with routing (can’t really check for Edge drivers), same as I had before with DTH. It allways gets routed through some other ZigBee device, even if I put Aqara sensor next to hub.

My solution is to put down all the fuses for the wired ZigBee devices and then do the pairing. A huge PITA! So this is what I did yesterday and paired all 5 of my devices … 2 cubes, switch, temperature/humidity and motion sensors.

ST made an incredibly poor choice of icons, but kinda used to that already :confused:

Zigbee is having significant problems for many people right now, regardless of brand of device or dth/edge driver being used. This includes adding new devices.

This problem started with the hub update two versions ago, was supposed to be fixed in the most recent update, but several people have reported the problem persists. So it’s just hard to troubleshoot any zigbee devices right now. :thinking:

See discussion thread:

Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Hotfix Notes - 0.45.11

1 Like

Thanks for the info! Yes, I can see that something is definitely wrong! All my Aqara devices I added yesterday (supposedly directly, without routing) stopped working.

Motion and temp/humid sensors went online, and 2 cubes and button stopped responding.

Interstingly, I have many Zigbee dimmers, wired generic ones, and never ever had I any issues with them, not even now … just with Aqara.

I noticed one more option for the hub in the app, which is: Security mode for Zigbee, and it is ON.
I haven’t noticed this option before.

It states that in case of disconnecting the device from the hub, only the devices with high security will be able to connect automaticall again and the ones with low security will have to be manually re-added.

Is this something that could affect the devices?

Is this something that could affect the devices?

Some devices, sometimes, yes. But that’s not What’s been going on with Zigbee devices for the last two weeks. It’s a flaw in the hub firmware, which is causing the Zigbee radio to either change channel, lock up, or continually reboot.

The official suggestion is to try rebooting the hub, and that might make things work for another few hours, but then they can go bad again.

So if you run into that platform issue, there’s really nothing you can do except wait for smartthings to fix it. :disappointed_relieved:

1 Like

Yes it’s the same in my case.
today the hub had blinking blue light many times and my devices of different brands and models went offline several times. all this after the hub firmware update. Not so good. Now some devices doesn’tn work well.

1 Like