Europe - Temperature and humidity sensor. Are Xiaomi Sensors “Plug and Play” with SmartThings?

Hello all.
I’m from Europe and I just ordered a SmartThings hub (v2 UK).
I’m no expert in programming and I would like to start to create a smart home with smart capabilities using temperature and humidity sensor, followed by some smart plugs and then motion and contact sensors.
1st problem - I’ve been looking for information for days and tryed to follow some regarding the Aqara (from Xiaomi) but in the end some day it works others don’t and I don’t have a clue if I should order them or not…
Are the Xiaomi sensors easy to install?? Is it plug and just pair with the SmartThings hub to check theyr info???
Does anyone has any other documentation?
How can I just know if they are ready for SmartThings?
Sorry for all this confusion from a newb…

Thanks in advance
Best Regards
Toranja

Hi Toranja,

Xiaomi devices work fine with the Smartthings Hub v2. I have 4 door/window contacts, 3 humidity/temp sensors, 4 buttons (2 newest version), 3 power plugs, a 2 button wired switch (1 button working), 3 body sensors and a Xiaomi Cube in use and it all works without any problems for me. Pairing can take some time but the aqara devices I use all paired in 2-10 min. Until now experienced no disconnects. Related to the possible wifi interfering problems reported: I have a Fritzbox 7290.

Hi Gert.
Thanks for the feedback :slight_smile: I just got a aqara for temperature and humidity, a motion sensor and also one for the window… :smiley: cool !!!
Regarding the install/ pair did you followed some tutorial? I think we need a special handler, or not?
Thanks for your help
Toranja

Short answer: no, they are not plug and play.

Long answer: read up here

Hi,

Just install the right Device Handlers (DH). I use the “bspranger : Xiaomi Aqara …” DH’s.
For the body sensors I use “johndoyle : Xiaomi Aqara Motion Sensor…” and for the plugs also the “Mains Toggle Switch” DH’s. For the wired 2 button switch I use “simic : Aqara 2 Button Wired Wall Switch”.

Just follow the instructions you will find on the forum. Just set the Hub in discovery mode and hold the button of the aqara device 3 to 5 seconds depending on the type device. Change your position to the Hub if a device will not pair. Closer or further away. Just be patient. It will work.
Good luck!

I’m very glad that it is working for you, but there’s no question that statistically the Xiaomi devices are among the most difficult of any to get working with SmartThings, as you will see from the discussion thread that @prjct92eh2 linked to .

They are not certified to the same profile that smartthings uses, and the company never intended them to be used with anything except the Xiaomi Gateway. So they are idiosyncratic to some extent.

Whether or not they work well for any one person depends a great deal on the specific layout of your other zigbee devices, And what, if any, repeaters you are using. Again, you can find a lot of discussion of this in other threads in the forum.

There is no question that they do work well for some people, and many people try them because they are so inexpensive. But if you are going to try them, you do need to understand some of the challenges that you may run into, because they have affected a high percentage of users.

Submitted with respect.

Although they work, with some effort, “perfect” is not how I would describe them. I’ve had these fall off, refuse to pair, stop reporting correctly and taking more than 12hrs to pair correctly.

However, they are cheap and worth the hassle, IMHO.

1 Like

Hello all.

First of all sorry for the late reply, but only this week I was able to install the hub and also the first Aqara temperature and humidity sensor.
@Gert_Koolwijk - I just follow your instructions regarding this sensor and everything worked greatly :slight_smile: no issue pairing (followed a tutorial where it mentioned to press the “reset” button for 20 to 25 times and then with the DH that you mentioned everything was great :slight_smile: so great that I ordered more 3 and just paired them today… also with no issue.
Also for the first sensor (is working since thursday) and I’ve got readouts whenever a change occurs…

My opinion is that despite having to “install” a DH… everything worked out great…

By the way I just noticed that there is a “new” app for mobile… on the classic app all the sensors are working properly but on the new one all the sensors are marked as “checking the device…” - I just translated from Portuguese so this may not be accurate… but it’s something as checking or waiting for the device… As anyone seen this issue?

Best Regards and thanks for your help

Hey Toranja,

Good to read that everything is going smooth :wink:
You are right about the app. I use only the classics app, but also have installed the new app. The Hub is in ‘connected’ state. I can see all 28 devices. But under the devices tab I receive ‘can’t connect to device’ on all devices. I have read somewhere that Samsung is migrating gradually users from the old app to the new app. But I don’t know anything more about it.

Best regards and thank you too,

Gert Koolwijk

Hi Gert :slight_smile: So far so good… the motion sensor seems to work well as well…
Regarding the temperature and humidity sensor, do you have any issue regarding the color of the icon when the temperature is above certain values?
For example now my room is at 23 degrees celsius but the colour displayed it’s red… strange… I’ve already changed the code in the handler to handle celsius instead of Fahrenheit but the problem persists…
Best Regards
Toranja

Hi all,

I’ve just joined and hoping to get some help. I have a strange problem

I have v2 hub and I have successfully paired a couple of Xiaomi Aqara Temp sensors to the hub, I can see from the IDE that they are there and functioning, however, when I select one in the Smartthings app, they say can’t connect. Any ideas?

Thanks David

Sorry to answer my own question - I can see the temperature sensors in the “classic” app but not the new app.

Does anyone know if this is a feature?

Thanks