Osram lightify switch resets to default value

I am frustrated because I am so close to having what I feel is the best setup but yet there is absolutely nothing that can be done about it. The problem is I have osram lightify bulbs and I set the balance to around 3500k but as soon as someone throws the switch they reset to 100% and 2700k. I can live with the 100% but not the 2700k because now I have to get my smartphone out, launch the app, launch custom app to control balance on all 4 lights at once, and set the kelvin back to 3500k. I am more frustrated by the fact that Osram has fixed this but only if you use their hub and it will not work on smartthings. So I could ditch smartthings and I would get the function I want but then I lose the great amazon echo intergration I have now and would have to switch to IFTTT if that is even an option. I can’t just cover the switches as this is a safety concern and the new osram switch cover switch that just came out is not going to help as its a wart for sure, runs off battery (oh the fun), and only comes in white (my covers are almond). Sorry but just wanted to post a "you know what grinds my gears post"
I suppose I could blame the osram engineers who said I bet if someone throws the switch for this bulb they want 2700k. Why on earth would someone want a light bulb to go to 2700k when it is turned off an on? Is there even a remote possibility that 1 person in the world would want that as a default.

1 Like

"I am more frustrated by the fact that Osram has fixed this but only if you use their hub and it will not work on smartthings."
I thought that if you connected the bulb to the Osram Hub, that it would give you the option to change the default value from 2700K to 3500K. The procedure should therefore be: 1) connect bulb to the Lightify Gateway, set the default setting to 3500K 2) reconnect the bulb to Smartthings.

you have to reset the bulb to connect to smartthings so the default value is reset in that process from my understanding.

1 Like

Thanks for the insight, this is clearly not a solution then, but I learned something today. I know there is an action in the rule machine that sets the kelvin. Could you use the “on” event from the bulb as a trigger for setting kelvin? Not sure if that is possible with the app, and you would have to add it for each bulb,.

That might work if Kelvin is an option. Is the rule machine from github or something like that? Thanks :slight_smile:

It does work with rule machine. Smart Lighting isn’t very smart in this area. I’ve hard wired in my fixtures to get around this, plus I don’t have to worry about someone turning them off.

Ok, I tried to get the rule machine to work but I can’t figure it out. I only got it to work if I create a rule that says if dim level is above 0 on any of the bulbs then change all bulbs kelvin to 3500.(works …but only if I change the dim level. Off and On of the bulb does not trigger). I can’t find any option that says if the light is turned on or off? I tried switch and physical switch and nothing. I must be missing something here.

  1. went to github got rule machine installed and published
  2. got rule and installed and published.
  3. On android phone installed rule machine
  4. launched rule machine and hit done
  5. launched again and added trigger

Hi, where did you read this, was it in a firmware update?

I ask because Hub Firmware 17.11 says:

Additional firmware updates for OSRAM lights (US only)

So I’m wondering if may it’ll fix it? :thinking:


I believe that the firmware upgrade may not have anything to do with this capability. The bulbs already have that available in the firmware, the DTH can not harness the feature since it is manufacturer specific and Osram doesn’t publish the information.

I reached out to Osram’s technical support, but they informed me that they are not willing to disclose that information as it is proprietary.

However, I have been testing a solution for the last couple of days and am pretty close to getting it work. I am able to implement it in 4 BR30 and 2 A19 bulbs. I am still testing it as I could not set it for 2 other BR30 bulbs no matter what I did.

If you are willing to test out my code, please let me know and I will send you instructions as soon as I get a chance to cleanup the code.

Hi Ranga,

I am having the same problem here and it’s very frustrating. Could you share with me your code and I can test it out for you.



Sorry, I missed your post.

Please use this to set your default value:

Hi Ranga,
These Osram lights will make my wife divorcing me seriously! They kept changing the default kelvin back to 2700 whenever either Osram updating its firmware or SmartThings updating the hub. And my wife blamed me for kept screwing with the lights. I have tried your device handler but with no success. I wonder if because of the latest version of firmwares?


Did you go through the process of setting the default color? Or just switched the device handler?

The device handler in this thread is updated with my code. You can try using that. If it doesnt help, please send me the logs from one of the bulbs and I can try to take a look at it. I had some bulbs that didnt want to set the defaults regardless of the firmware, but I thought it was due to making some settings go bad on the bulbs during the development. And if you can, I would recommend you to update the firmware to be sure as well.

I know im a little late to the party… but got the same issue with the bulb defaulting back to warm white… i have 5 bulbs… 3 of them took 2 didnt. and im updated to the latest firmware also. I set it with the updated device handler then hit default… turn off switch and turn it back on and its reverted back… Im done with ideas… any updates??

Hi! New here. Moving to SmartThings from 433mhz automation. Already had some IKEA Trådfri bulbs, and now got three Osram CLA 60 in my SmartThings bundle. I had problems with the new Osrams not keeping their dim level after being switched off by the wall switch.That is the setup I like to use on several of my lamps, e.g. mainly use the wall switch, and have the bulbs at a default dim level, say 30-50% depending on location. Then IF I need to adjust, I can take out app or remote. Simple for kids and friends and that is the way I’ve done it with the Trådfri bulbs. But whenever I use the wall switch on the Osrams, I get 100% dim level. Is that the way it’s intended? I understand that the behavior of the Osram bulbs is not related to SmartThings though.

Well, will reply to my own post! Read all of the thread again. Tested your DTH without success, I have the non-RGB version so I though that might be it. Read about the firmware update and found out that it could be achieved in the ST hub. Followed instructions here: Osram Lightify Device Firmware Updates? Updated firmware and voila! It works! Thank you very much it seems like I now can use the Osrams as I would like.

1 Like