Help with SmartThings and Lightify bulb


#1

Howdy.

Can anyone assist me with setting up my Osram Lightify bulb? I’m rapidly losing patience with this whole thing …

The first time I think I was too far from my hub so nothing happened.

After a (partial?) reset anda move closer to the hub the phone app seemed to find the bulb but was stuck on the Identifying screen.Since then, nothing.

The best I can manage after trying to reset the bulb is a single blink rather than the 3 blinks that I should be getting.

Any ideas? Am I missing something?

Thanks in advance - much appreciated!


#2

Which model of bulb?


#3

it’s a lightify 60w clear / e27.


#4

The reason that it gets stuck on “Identifying” is because it’s not a certified device. We have to add a “fingerprint” to our platform so that we know what device you’re pairing. As this isn’t a supported device, there’s no fingerprint that matches it on our system.

Check the official list here:

That said, there’s a chance that an easy custom device type may get this working for you. Can you follow these steps for me?

  1. Log into https://graph-eu01-euwest1.api.smartthings.com/ide/logs and keep the live log page open
  2. Open our mobile app
  3. Reset the bulb and attempt to get it to pair

It should get stuck on “Identifying”, but you can then share those logs with me and I can see what I can do from my end.


#5

hi there.

unfortunately, i haven’t been able to reset the bulb again so i’ve had to contact osram support.

am i right in saying that, assuming that i can get the bulb reset, i can log in to the url that you provided on my phone and then start the app on my phone and you’ll get the log that you require?

thanks


(Jamie) #6

What I found was that you may need to delete the bulb from the smart things app first (you will need to also delete/remove any rules/smart apps that is associated with that bulb first before it will allow you to delete the bulb for the app)
Then go through the 5sec ON, 5sec off 5times to reset the bulb it will blink ONCE. Then on Smart things app search for new devices “general” search wait 60 secs if it does not pick it up turn the bulb off and on and wait a few minutes. If it still does not pick it up the yes, custom device type maybe required. Although not an officially supported bulb I have 4 working - but I am running custom device types to better suit my personal preference. I’ve also reset these bulbs numerous times.


#7

so, i’ve got a new bulb and i still can’t reset it so it seems that it’s something i’m doing rather than a faulty bulb.

does the bulb need to be next to the hub for a reset or can it be anywhere?

my bulb is in a lamp with a dimmer. would that make any difference? grasping at straws here …

and just to clarify - say my lamp is off. should the bulb blink straight after the 5th ON or will i have to turn it off again and the blink happens on what is effectively the 6th ON?

thanks in advance for your help. this whole things is extremely frustrating. the motion sensor is useless because of my pets. i’m still waiting for support to get back to me regarding the faulty socket switch so i’ve basically paid a lot of cash for a useless white box at this point.


(Jamie) #8

The 5th time or the 6th time doesn’t matter really but wait for 10 seconds I find it flashes once after 5-8 secs. Then click on search for new devices in ST app. Turn off the bulb for 2 secs then turn it back on. The bulb should then flash again and after 5-10 secs the app should pick up the new bulb.

My hub is on the middle floor, bulb is ground floor approx 5m away and through the ceiling. So distance shouldn’t be a problem. Dimmer should be ok but worth trying it in a non dimmer or max the brightness and switch the actual switch off/on if you can rather than 100 down to 0 through the dim if that makes sense??

Jamie


#9

thanks for taking the time to reply.

have been repeating the procedure that you describe multiple times without success. bit of a nightmare for something so simple and the wife thinks i’m demented.

i have tried both unscrewing the bulb and switching off at the mains (rather than dimming) to no avail.

have also tried moving closer to the hub again to no avail.

not sure that i have another lamp but will have a look as that’s the only thing that i can think if that i haven’t tried.

sheesh!


(Paolo) #10

Hi, I’m trying to add the same bulb but without success.
The app identifies the bulb but it doesn’t match any device.
I tried to set many of them (the other OSRAM bulbs, the generico zigbee switch, and some others) but no one works.

I checked in the log while identifying the device but I can’t see any log for this device (btw, I’m using graph.api.smartthings.com, not graph-eu01-euwest1.api.smartthings.com, as my hubs are registered in the first one). I tried many times removing from the network and adding it again.

Any suggestion?


(Scott G) #11

Can you look at the bulb in the My Devices section of the IDE? Clicking on it there will bring up a bunch of info. One item is called Raw Description. Copy that here. It should look like a long string of 2 and 4 digit number strings.


(Paolo) #12

Sorry, can’t find raw description!

http://imgur.com/NiKLYbo


(Scott G) #13

If you paired the bulb recently, try going to your hub’s page and clicking List Events, then filter on All at the top. You should see a Join event for the bulb and the description would have the info hopefully.

You may need to reset and re-pair the bulb to the hub (closer is better). It seems like the bulb may not have passed all the messages during join.


#14

hi, i finally got my bulb to reset and have tried the above steps but my rawDescription is blank.

anything else i can do to assist?


(Paolo) #15

http://imgur.com/Tm3NXFZ

The only data from the device is this:

{
“name”: “Thing”,
“label”: null,
“typeId”: “07b9aca9-113f-4c85-bdf0-822cfaadd787”,
“zigbeeId”: “8418260000057202”,
“hubId”: “****************”,
“deviceNetworkId”: “EF5F”,
“locationId”: “**************”,
“groupId”: null,
“parentSmartAppId”: null
}


(Scott G) #16

Hi guys, try the devicetype in this post:

Looks like it’s using endpoint 3 and for some reason the generic ST devicetypes aren’t picking it up right. Same thing happened with the light in the thread above.

If you need with applying custom code, here’s an FAQ thread about it.


Osram/Sylvania Lightify (it works)
#17

hallelujah, i actually have something working with smartthings!

thanks especially to Sticks18 for the hand-holding.

the bulb isn’t dimmable but it’s a start!


(Scott G) #18

Dimming doesn’t work? It looks like it should from a product and code perspective. If you want to start Live Logging in the IDE and try dimming in the app to see if it throws an error, maybe I can help.

If there’s no error in the log, then it’s most likely either an ST issue and might resolve itself or interference on the 2.4ghz band.


#19

thanks. will try again later this evening and post results. much appreciated!


(Paolo) #20

Thanks, it works very well :smile: (also the slider for me)

BTW, I can’t understand where did you got the endpoint descriptors!