Official Release: Honeywell Lyric (11/30/2015)

Heating and cooling. Changing from cooling to heat or vice versa will just show working in the button on the st app. Same goes for fan control. After a while buttons return to normal, but no status change. Changing temperature will show a temperature change in the st app for a few seconds, then reverts to the old temperature. Lyric app works correctly.

We’re testing a fix this week. Hang in there!

1 Like

I was very interested in this device but thanks to the community now I’m not… Until it’s fixed at least

In the same boat as others; Lyric installed fine and seemed to be working fine otherwise, but I can’t change the set temp in the ST app.

attempted to connect this device this evening but i get authentication fails within the log i get

bc6d4b26-59a9-4f50-8239-0ee813773c5e 9:48:24 PM: error Unauthorized @ line 248

when i tap on “click to enter Honeywell credentials”

Hello there, new to the whole home automation and smartthings. I’ve just moved into a new home and they had installed the Honeywell Lyric thermostats. I downloaded the Lyric app (android) and got them all setup, no problem. I recently setup a SmartThings v2 hub and installed 4 new light switches that work great. However, when I try to follow these directions for the Lyric, my authentication keeps failing on the Honeywell Credentials step. These should be the same user (email) and PW I used for the Lyric app, correct?

Not sure why it keeps failing, any ideas? (I’ve logged off/on to the Lyric app a dozen times to validate the username/pw combo and it works fine there)

Tyler, any updates on this one? Smartthings still doesn’t seem to be reporting the current Lyric set temp, nor does it allow me to change the set temp.

Honeywell issued a press release this week about the compatibility. They also reference that other wifi models are coming soon. I hope they do as I have 2 of their wifi controlled thermostats and would like the integration.

Even after the press release the Lyric is still not adjustable from SmartThings. Typical Honeywell.

Having similar issues with my v2 hub Lyric thermostat
i can see the current temp in ST, but can’t control it

I can manage the thermostat in the Lyric app


What is the status on this? Both SmartThings and Honeywell are touting integration with the Lyric, but I haven’t been able to successfully control the thermostat since week 1 or 2 of the announcement. I’ve been trying to wait patiently, but it’s been almost 2 months since the integration was announced.

Looking to purchase a Honeywell Lyric. Just wondering if this has been addressed yet?

First off, the Lyric is great without SmartThings. I spoke to Honeywell the other day and they said the issue is on Samsung’s end. They will get it worked out, so that wouldn’t stop me from getting the Lyric.

I am having an intermittent issue when a routine runs at night to set it to a certain temp (71 from 73) the furnace does turn back on even though the thermostat shows it should be heating… I wake up to a house that is (69/70)…

I just set up my new Lyric Round today. On the package it touts Smartthings integration. The Lyric app is working as expected. I was able to add the Lyric to my Smartthings and it reported current state. However it no longer refreshes let alone controls temp. I was hoping to add Smartapps to control temps based on home, away, good night, etc.

So as others are reporting it isn’t working as a Smartthing. I would be happy to help troubleshoot.

We have an update that we’re looking to deploy this week. In our testing it has fixed the issues reported in this thread. I’ll post an update when it can be installed.

1 Like

Yes please, been waiting a long time for this.

Tyler, I was testing this issue with Jody Albritton yesterday. One thing I did find, is that my FAN button does work within smartthings. But the up/down settings and heat/cold do not. So if I set the lyric stat to 64 degrees and confirm that it has been pushed down, when I poll it (IE Refresh) from the smartthings view, it will read the settings; but it will never push a change to the stat. Seems like it’s all on the smartthings side in terms of pushing changes via manual or a routine/smart apps.

Like I said, the fan button does turn it on, change it to various modes and turn it off. Just like I would expect it to . Thanks Look forward to the fix.

Yyler, My hats off to the team at Smartthings. Update applied last night–I added my Lyric back into ST and it all works beautifully. I do have one question however and maybe this will take me some tweaking, but how do we avoid conflicts in Lyric app vs smartthings. Maybe it’s easy and I have not seen yet. Like I want to tell my lryic via ST to do various things when away, return and going to bed. Lyric is also Geo Fenced so it could apply same issue, for away or arrive. I will look and play today now that it works…


Anyone else? Have you tried it yet @erocm1231 or @bang or @BatraD

If you still have it installed please uninstall it from SmartThings and try again.