Official Release: Honeywell Lyric (11/30/2015)

Hi Frank and Jamie, we have investigated the platform issue and deployed the fix for Honeywell Lyric. You can try to uninstall and install your Lyric thermostat again. Please let me know if this solve your issue.

Still not working for me. Does it make a difference that I’m still on the V1 ST Hub?

You can see in the attached pic the strange characters where, I’m guessing, the temp should be and when I click into the lyric I still get no readings.

Cheers

Jamie

Hi Jamie, it shouldn’t make any difference as it’s a cloud device. Can you provide me the live logging when you install your Lyric thermostat?

Like some of the others, ST recognizes my Lyric and views the temperature, but is unable to change it.

I have tried many times to add the Lyric but I get the same error when completing the configuration… Failed to save page: deviceList

Any help would be greatly appreciated, thanks!

Hey all,

We’re looking into some of the issues a few of you are seeing with the Honeywell Lyric integration. Stay tuned!

Thanks!

…and still no Nest support?! Come on guys, you have been promising us Nest support for over 2 years now, it cant be that hard. Stop supporting every mom and pop knockoff thermostat and get with the program. While some of these thermostats are nice and work great, Nest is still the #1 seller.

2 Lyric thermostats installed. Both show up in ST but can not change temperature, same as other users.

So I got a Lyric and set it up in SmartThings. Adjusting temperature seems to work just fine for me. I don’t think that temperature changes are reported unless I hit the refresh button or use something like Pollster. Is this the expected behaviour?

I’m having the same problem. In my logs, I see the following error when I click ‘Next’ after selecting my thermostat:

java.lang.NullPointerException: Cannot invoke method toInteger() on null object @ line 601

Well I got the Lyric to show up in ST; however, can’t adjust temp and I’m in Canada so it does it support Cesius? Also, doesn’t report current humidity setting.

I get perfect feedback and history, but no control. Live Logging shows the following error.

c4d865e0-d4f3-43d6-88a4-415d45643bf8 6:28:24 PM: debug generateStatusEvent(): thermostatStatus = Right Now: Idle, thermostatOperatingState = idle
c4d865e0-d4f3-43d6-88a4-415d45643bf8 6:28:23 PM: error Error alterSetpoint()
c4d865e0-d4f3-43d6-88a4-415d45643bf8 6:28:23 PM: debug alterSetpoint >> in mode cool trying to change heatingSetpoint to 70 coolingSetpoint to 72
c4d865e0-d4f3-43d6-88a4-415d45643bf8 6:28:19 PM: info In mode cool lowerSetpoint() to 73

This was working for me when I first set it up, but now I can’t change the temperature, and the current temp is not updating in the app. Same thing in my logs:

0d3b54da-5a66-4e15-9bfb-23119b1c3518 1:30:56 PM: debug generateStatusEvent(): thermostatStatus = Right Now: Idle, thermostatOperatingState = idle
0d3b54da-5a66-4e15-9bfb-23119b1c3518 1:30:56 PM: error Error alterSetpoint()
0d3b54da-5a66-4e15-9bfb-23119b1c3518 1:30:56 PM: debug alterSetpoint >> in mode heat trying to change heatingSetpoint to 68 coolingSetpoint to 77
0d3b54da-5a66-4e15-9bfb-23119b1c3518 1:30:53 PM: info In mode heat raiseSetpoint() to 68
0d3b54da-5a66-4e15-9bfb-23119b1c3518 1:30:42 PM: debug parsing data null

I am regretting getting rid of my rock solid Z-Wave thermostat for this one. Proves looks are not everything. :wink:

I have had the Lyric thermostat before ST, the thermostat is great, problem is the ST integration, First it does NOT work, it does not allow for temperature change. It also lacks some of the useful features, such as humidity. Hope ST fixes it, least of all, be able to change the temperature, otherwise all it is is a temperature sensor.

Its been 2 weeks since ST integrated, but nothing has been done since to fix the issues or let us know what’s going on. Not good.

Sorry for the trouble!

We’re working with Honeywell to fix the issue. So far it points to a DNS issue on their end. The error is intermittent and doesn’t effect all users.

I’m pushing very hard on this one and I’ll update the thread when we have more info.

I’m also unable to get my thermostat to change temp from the ST app!

I’m having the same issue. I can’t add Lyric to SmartThings.

For your thermostat configuration, does it have only heating system or only cooling system?

Hi Nicky, we are looking into the issue and come close for the fix. We are also collecting more information to find the root cause of it. For your thermostat configuration, does it have only heating system or only cooling system?

I am having the same issue. Two Lyrics connect to ST that are heat only and neither show temperature or allows controls in ST. Lyric app still works fine.