Official Release: Honeywell Lyric (11/30/2015)

Hi SmartThings Community!

We’ve just published official support for the Honeywell Lyric thermostat in the US.

You can add your Honeywell Lyric thermostat by clicking the Marketplace link in the SmartThings App, or follow the directions on our Support Knowledge Base.


And it works :smile:

Awesome, like the look of this over the Nest and Ecobee.

It’s grown on me too! I like how simple it is to use compared to the other smart thermostats on the market.

So it’s not working for me and I’m wondering if anyone has any thoughts or suggestions.

Uploading… this is what I’m getting. None of the information is filling in and j can’t actually control the lyric.

I’ve tried deleting and adding it back with no luck.

Any thoughts?



Was there supposed to be an attachment there?

What are you seeing at when you log in to your Honeywell account and authorize the connection?


Ohh, it works. I’ll have to get some remote temperature sensors now.

Yes. I had attached a pic of the app but it didn’t seem to upload. I am going to try and attach it again along with a screen shot of the log.

Thanks! I’ve tagged one of our engineers on this.

Hi Jamie, can you control it using the Lyric app from Honeywell? It looks like the Smart App cannot poll data from your thermostat. Does it properly connect to your home 2.4 GHz WiFi network? You can try to uninstall and install the device again. If this problem still persist, can you explain the steps you take to reproduce it?

I tested all the functions on mine and they all work through Smartthings using V2 hub. If it helps any.

Awesome, thanks Bernie. Did it go smoothly when you install the Lyric smart app?

Yup all one shot. No issues. :smile:

Hello Tyler,

I’m able to get the actual temperature from the Lyric without a problem. However, when I press any of the buttons to lower/increase temperature, nothing happens. Please help. I really appreciate it.

Hello Tyler,

SmartThings recognizes my thermostat and It send the current temperature, however i’m unable to control it.
Please help.
Thank you so much

Thanks for letting me know! I’m not immediately able to reproduce, but someone is taking a look.

I have no issues controlling the thermostat with my smart phone. It is connected to my wifi. I have tried deleting and reinstalling with no luck.

Not sure which steps you are looking for. In terms of lyrIf in smartthings…

I went to marketplace
Found the lyric
Added the device
Signed in with my lyric credentials
Clicked "allow"
Clicked next
Chose my lyric
Clicked done

Thank you for looking into it




I’m having a similar issue. I deleted/re-added my lyric to ST and also did a factory default on my Lyric.
Same problems.

I’m able to control the Lyric just fine from the Lyric APP.

I don’t believe it’s a polling issue with ST because the ambient temperature refreshes.

I just can’t change the temperature through the ST.
Any help would be greatly appreciated.


Hi Frank and Jamie, we are looking into it. Thanks for reporting the issue.