No Hub In Your Current Location (New App)

I’m trying to add a new S2 switch with QR code using the new app. Usually I use the classic app and have no issues but when I try to add this switch in the new app, after scanning the code it states “No Hub In Your Current Location” at the drop down to select the hub.

My classic app is working fine and IDE also is showing all my devices and working fine.

Any ideas on how to fix?

Check to see if you have more than one location. Click on the menu (3 bars in the upper left of the screen)…

You should see a Home location listed with a down arrow to the right. Click on that down arrow and see if there are two listed and select the other one.

Oh! I guess I should have asked if all your devices are appearing in the new app?

Sorry forgot to mention all my current devices show up fine in The new app. Just can’t add new from there.

Drop down only lists my 1 location

Have you tried both options of adding - either “Scan QR code” or by brand, choose the brand of device and going through the installation process?

Same thing if i do Scan QR Code or add by Brand

does the hub show in your device list? does it show as connected if it is listed?

menu (3 bars in upper left of screen) > devices

It doesn’t show in the device list

You will need to contact ST support and let them investigate. They will probably need to sync the data so it shows in the new app. You can click on menu and go to Contact us.

Well I contacted support and they seem to be pretty useless at this point. I’ve sent them screenshots, software version info and everything they’ve asked for and they keep asking for the same info and screenshots over and over again.

Is there anyone here on the forum that works with SmartThings chime in and help?

Sorry to hear that. All I can do is tag a few folks and hope they can assist or refer you to someone

@SamsungZell @Brad_ST @jody.albritton

This is an issue that can happen when the hub isn’t in a room. I moved the hub to Living Room and the error should be gone. You can move the hub to any room, it just needs to be somewhere.

2 Likes

Awesome! Thanks for the extremely quick fix!

1 Like

Hope it’s ok to jump in on this thread. I too am seeing the error “No Hub In Your Current Location” but only in the IDE. My smartthings app (both classic & new) work fine and I can see & manage devices, but within the IDE I am getting this error.
Now, prior to reading this thread, my hub was not in a room, but I moved it to my family room based on the advice above, but this did not eliminate the problem in the IDE. Any ideas?

EDIT: Was reading some other threads, and on a whim, instead of logging into https://graph.api.smartthings.com , I used https://graph-na02-useast1.api.smartthings.com/, and this time I saw my hub. So there appears to be something strange going on with my account.

FUN FACT: Login to IDE using https://account.smartthings.com and it will redirect users to their appropriate SHARD where the hub is located.

1 Like

Thanks, yea, I figured this out.
<sarcasm - directed at samsung, not the community which is quite helpful> stupid me… following the official documentation which says to log into https://graph.api.smartthings.com.

Slightly different issue, but similar lack of useful help from support. I use a 2015 v2 hub and almost 100% use webcore and smartapps to run the 40 ish devices. I migrated to a Samsung account a long time ago and continued to use the classic app with zero issues.

Now all of a sudden my devices have disappeared, and a blank location was added. My smartapps continue to work, and my hub appears fine in the IDE, but I am unable to delete the blank new location. Have tried all of the tricks to set default to “false” before deleting but nothing will work. Keep getting a error message when trying to delete from the IDE…

Support has been asking all basic questions without grasping the issue, and I am stuck with an angry family because settings have to be adjusted and I have no way to easily access w/out the mobile app.

Curious if anyone else has been in this situation.

Thanks!!

image

Did you try using an incognito/private tab when logging into IDE?

Item #2 in the following thread…

You can also contact ST support and ask them to remove the empty location.

I took a look and this seems to be a syncing issue. Can you check if the issue is resolved?

If it’s a default location, support can’t delete it. The only way to delete is via the new app.

1 Like

@jkp yes I was in incognito.

@Brad_ST thank you!! I have never downloaded or used the new app so did not even think to try that. After deleting the empty location everything returned back to the classic app. Big thank you and hope this can be used as a default reply from support for this type of issue in the future.

1 Like

Looks like I’m having the same issue as @Infizzle as well. Here’s the error and I actually created a new post as well. Noticed this and saw that @Brad_ST fixed it and said it was some sort of syncing issue. Wondering if he can fix mine as well. I’ve opened a ticket with support but not hopeful after reading that support asked basic questions and didn’t grasp the issue.

Oh No! Something Went Wrong!

Error
500: Internal Server Error
URI
/device/list
Reference Id
50a6f0f2-3508-44e5-a883-d865b951ac38
Date
Wed Jul 01 12:36:28 UTC 2020