Can't connect to v2 hub after moving to new app

Hi, I have a V2 hub that always worked with the old iOS app. I downloaded the new app and have attempted to use it but I can’t seem to get connected. After reading a bit about it I went back to the old app and clicked the “migrate” banner. It told me everything had been migrated. Back in the new app, nothing shows up. I figured maybe I need to re-setup everything so I add a new device, choose Wifi/Hub, and my device type SmartThings Hub 2015 (STH-ETH & Others). I enter the welcome code (which I see when I remove the back) and immediately get “There was a problem connecting to the hub. Check your network connection and try again.” Well I checked, even pinged the hub, all good. I tried power cycling (batteries out) the hub and still nothing. The front light is green. Back lights are green and yellow (next to the ethernet port). I’m kinda lost - not sure what to try next. I hear Samsung support is pretty useless.

Any suggestions?

Thanks!

  1. try signing out of the new app then sign back in.
  2. if still no devices, check to see if you have more than one Home location and if you do, switch to the other
  3. if you do not have multiple Locations, contact ST support and ask that they sync your data to the new app. It does occur from time to time for some users when first trying to use the app.

Thank you. 1 and 2 didn’t do it. Do you have a suggestion for the best way to contact ST support?

Support@smartthings.com

Whew - that finally worked. Took them a while to get me synced but they did it. Working now!

I am having this same exact issue and I have been unable to resolve it. I migrated to the new app, and only 2 of my dozen or so devices showed up. No hub is listed. I’ve tried to add the hub (v2) several times, but I keep getting the “There was a problem connecting to the hub. Check your network connection and try again.” error.

The hub shows up in IDE, it shows up in the classic app, but it will NOT show up in the new app. I only have one location listed, so I don’t think that syncing is the resolution I need.

I have opened a ticket (1016126) but so far it’s been painfully slow. I recieve one email, overnight, a day, and so far the only suggestions have been to uninstall and reinstall the app. Any help would be greatly appreciated. I’ve spent hours trying to resolve this on my own.

If you go to the menu (3 bars in the upper left of the screen), select Devices and look for your hub there. If it is listed, assign it to a room. If not listed, ST support is basically your only option. As they will need to sync data between the apps.

Thanks for the quick reply. Unfortunately, there’s no hub listed in the devices. I’ll hope that ST support will help, but so far it’s been 3 days and 3 emails, and we haven’t made any progress.

Generally, calling and speaking with custom support is the quickest way to resolve some issues. That is if calling support is available in your region.

I may have to resort to that. I try to avoid the phone if at all possible, but I think the daily emails are going to take forever. :slight_smile:

Perhaps this can help you prepare…

Heh. If only that would help. It’s more of a hard of hearing thing. I prefer to stick with text, if I can.

Well, I called. I sent a couple of screenshots, was told that the issue was going to be sent to a tech, was provided a new ticket number, and told to expect a call Tuesday/Wednesday.

Edit: I was able to find all my old devices in the new app by moving them into a room in the classic app. BUT, the hub is still not showing up and I have no idea how to move it into a room using the classic app or IDE. My email helper has resorted to asking me for the same exact information that I provided him on day one (app version, iOS version, screenshot of error message) so that’s frustrating…