SmartThings Community

Newly installed smart apps not showing in mobile app

missingapp
smartapp
installedapp

(Jason "The Enabler" as deemed so by @Smart) #1

A recent bug has surfaced when installing a smart app in the IDE. After being installed they are not showing in the mobile app.

To get correct this, follow these steps:

Go to APi -> Locations -> installed Smartapps

Tap on the recently installed smartapp.

You will see this on the screen:

Ensure that this box is NOT checked:

Tap off the edge of the pop-up. Go back to the locations screen.

Now the smartapp should be in your mobile app.

@slagle @jody.albritton @Tyler

Is there a fix coming for this soon?


SmartTiles Dashboard v5.7: Release March 2, 2016
New to Smartthings and would like to know how to get echo to work with linear garage door opener
[RELEASE] D-Link Camera Manager (Connect) - Add your D-Link IP Cameras to SmartThings! Video Streaming, Image Capture, Motion Detection and more
Published Apps will not show up in ST Mobile
[REMOVED] Nest Manager
[SUSPENDED] Blink Camera Device Handler with Motion Sensor, Live Video Streaming, Integration with SmartThings/SHM, Temperature, Signals and Push Notifications
Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support
How to show dashboard with device info page in smartapp
One ST Account Spread Across both ST Servers Graph.Api & Graph-NA02-USEast1
SmartTiles Installer <strike>disabled due to platform errors</strike>. Re-Enabled 3/24
New to Smartthings and would like to know how to get echo to work with linear garage door opener
UPDATED 10/7/2015 -- "Double Duty" - Use redundant switch presses to control other lights. You paid a lot for those switches, make them work Double Duty!
[BETA] Hue (Re)Connect - with scene handling
SmartTiles Dashboard v5.7: Release March 2, 2016
[REMOVED] Nest Manager
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

I just linked to this fix from a post in the SmartTiles website News/Outage section and Twitter. We have several reports of this from new SmartTiles users and presume many are just giving up and not reporting and/or it is affecting only a limited number of installs?


(Tina Caron) #3

I am experiencing this behavior with the Hue (Reconnect) app I just finished installing. I will try this fix and see if it helps.


(Tina Caron) #4

Sure enough, that seemed to do it. I love this forum :slight_smile: I find answers to almost all my weird problems here!


(Tim Slagle) #5

Should be fixed soon. :slight_smile:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

We’re finding some indications that SmartTiles may appear on the user’s mobile app Installed SmartApps list after "a few hours" with no manual or Support involvement required.

Some sort of database propagation / replication delay going on???


(Chris ) #7

Thanks now smart tiles shows up in my list on the mobile app.


#8

This still has not been fixed. I just installed a SmartApp and it didn’t show up until I did what the OP described.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #9

Same here. I just installed a SmartApp from RBoy, and saw the same thing happen. Once unchecked as in OP, the app showed up in the ST mobile app.

Thanks for posting this, @bamarayne
I saw this earlier today or yesterday here or there, but hadn’t installed anything new until just now. Glad I remembered this existed somewhere already. A quick, simple search of the forum brought it right up. :slight_smile:


(Frank) #10

Samething for me , I have a custome schedule app I wrote to use multiple times, it’s not showing up.


(Michael) #11

You have to remember that “fixed soon” could mean days or weeks.


(Jason "The Enabler" as deemed so by @Smart) #12

There’s a new term… It is no longer “fixed soon”… It’s now “less broken”!


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #13

If a majority of broken things around here got fixed in either days or weeks, I don’t think we’d have the volume of piss we see being spilled and foamented in our complaining threads these days.

p.s. not pointing fingers; it is what it is. we love ST and the ST Team, but are pissed that it’s been so broken for so long. So, not adding to the piss; just intending to acknowledge it in a humorous way (humor=not my strong suit. So, I try). :slight_smile:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #14

(Mark H) #15

I spent an hour and a half trying to troubleshoot a custom app I reinstalled that ran but did not show up in my Smartapp listings. A Google search lead me here to the solution. Thanks @bamarayne for documenting the error and fix


(Tim Parr) #16

I am probably being dense, but as a new SmartThings user I am not sure where to find ‘API’ Should I be in the SmartThings android app and if so which screen?


(Jason "The Enabler" as deemed so by @Smart) #17

Here ya go…
https://graph.api.smartthings.com/login/auth


(Tim Parr) #18

Excellent - Thanks a lot.


(Steve Bratt) #19

been trying to install smart tiles for three days, rebooting, re installing etc etc, this finally fixed it, so thanks for that


(John Essey) #20

Just curious if you are facing this issue, are you using a V1 Hub or V2 hub? I can not get my apps to load on my v1 hub on the newer SmartThings app. The v1 hub will load smart apps using an older version of the SmartThings app though…The v2 hub loads apps no problem.

Thanks!