New Smartthings app and Android 10

Overnight my Google Pixel mobile updated to Android 10 and now the new Smartthings app just continually says “Connecting to server. Please wait…”.

The Classic app still works.

I’ve tried uninstalling and reconnecting my account to it, no change.

Anyone else having issues?

5 Likes

Yep same problem here. Looks like we are going to have to wait for Samsung to play catchup now and downgrade back to the Classic app. Pretty poor really.

1 Like

I think you mean upgrade to the classic app :stuck_out_tongue:

6 Likes

Nope. Just posted in a similar thread. Pixel 2XL I updated last night. All seems to be working ok. I see all devices as expected & the couple of switches I’ve tried work. Both versions of the app.

I just spoke with Samsung Support for Smartthings and they are adement that Android 10 hasn’t been released yet other than early Beta versions and that a new updated app that is compatible could be month’s away once Android is released to the public.

I find it very very difficult to believe they are so out of touch.

2 Likes

I’m using a Pixel 3 and it’s still running Android 9 but I just “checked for updates” and yep, Android 10 is now available (and all over the tech news sites I see). I’ll wait a while before updating though now until I hear more about this issue. Thanks for flagging.

Same issue here. Just got off the phone with Samsung. 10 is not supported at the moment. Multiple reports apparently.

2 Likes

I upgraded my Pixel 3XL last night to Android 10, and I cannot get EITHER Smartthings app to work. The newer version spins endlessly without connecting, and the older version appears to work, but no actions to switch lights etc. actually happen. They all stall. Anyone else?

This is a real problem for me as I monitor several locations. UGH!

Post script: Old app is now working. Come on Samsung!

Second PS: I had created a new location and added a wifi outlet at a place with no hub. The new app lets you do this. The old app did not. NOW, with the old app, I can see this location and the wifi outlet but alas, no control will work!

Pixel 2, upgraded to Android 10 this morning.

Both SmartThings apps working, no issues

I had problems with a few IOT apps that need to talk to backend system but failed. Figured out that under settings>network and internet>advanced my Private DNS option was set to ‘my.googledns’. Switching this to ‘Automatic’ sorted out those apps and they now work. I had hoped it would fix the Smartthings app but no luck.

Anyone with other app issues might want to try this.

I guess the developers at ST need to speed things along? :wink:

Pixel 3 just updated to Android 10 and both new and old apps working generally fine for me, though the new app has crashed a few times when selecting rooms. I can control devices ok though.

Same issue here. Pixel 2XL. Android 10. New ST app hangs “connecting to server” or opens with no devices. Uninstalled, reinstalled app. No joy.

PIxel 2xl, Android 10. Just purchased and received Smartthings Hub.
New App hangs on “getting ready for setup” at 1%, fails with a “couldn’t sign into Samsung account” notice.

I’ve been running Android Q beta 1 , every once in awhile I’d get frustrated with the bugs and opt out of beta going back to pie, but I just couldn’t stand not having all dark so I would go back… I found that every other time smartthings would work perfectly …so it does work … I’ve just had factory reset until it gets it right… I think a fresh install settlers in better… when updating to 10 via OTA it’s doesn’t seem fresh from ground up but fresh wiped device seems to take and seems to work… also if smart things isn’t working correctly you’re going to have many many other app crashes because something just isn’t right so I might be worth the time to figure out what works, once you have a smart things loading without a hitch I’ve found in my experience the other once buggy crashing apps would seem to work flawlessly along with that handful of apps that would bug out and crash… That’s my three cents, Hope it helps let me know if you find a quicker way. I’m currently still fighting that cloud control thing… going to hit another factory reset now…

Chiming in here: my Pixel 2XL received Android 10 a couple days ago and my Smartthings app was working fine until I logged out to switch to a different account. Now I have the same issue as everyone else, endless “connecting to server”. This is a major problem and they best be taking this seriously. I can’t just get a different device to manage all of my properties because they’re way behind in app development.

Samsung offre any workaround for that bug? I try to modifié permission and its not Working anymore :frowning:

There is no solution with the current version other than going back to the old Classic version

I have the same trouble also. Google Pixel 2XL. I had to use my iPad mini to connect my washer and dryer today as the Android app does not work (for me) on Android Q. It will not connect to Samsung servers.
My washer and dryer show up in the classic app once installed with the iOS New ST app.

Cheers
J

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.