New SmartThings App - unable to login


#1

So the NEW Smartthings app, currently titled “Smarthings (Samsung Connect)” in the Google play store:
https://play.google.com/store/apps/details?id=com.samsung.android.oneconnect

I’ve installed it, and when I launch it, i get the following:

So I click “Sign In”, and get the following screen:

I’ve set my default browser to one of the ones listed, but still no joy.

Any ideas?


#2

My default browser is Chrome as well, although the webpage that the app launches does not actually open in Chrome. The settings option in that says “powered by Chrome”.


(Bob) #3

Can I ask why you installed it?
Did ST ask you to?
I’m just wondering as I received an email saying that there would be a new app coming out but to do nothing until instructed to by email from ST.


#4

Purely because I’m eager and like to mess around :slight_smile:
It’s in the Google Play store, so anyone will find it when searching for smartthings, so I figured I must be able to do something with it, even if it’s not yet been updated with the Smartthings functionality we’re used to :slight_smile:


(Bob) #5

Ah OK.
Thought I might have missed something.
I always prefer to be at the back of the queue with updates.
Hopefully everyone else will go through the grief before me. :smile:


#6

I love the bleeding edge! Latest and greatest, pushing boundaries, trying new things, and, yeah, loads of problems and bugs :smiley:


(Brad) #7

Are you on a Huawei device?


#8

Nope, a Oneplus One, running LineageOS - Android 7.1.2
I think it might be the “Android System Webview” app, built into Android, that is being used to launch the webpage.


As it says, it’s “powered by chrome” and lets apps display web content.


#9

Wifes phone doesn’t have the problem - launches the same website in the same app (the “powered by Chrome” one), but it launches and displays correctly.
So, is the account.samsung.com website detecting something else other than the browser version??
I’ll try uninstalling Chrome (I used the Beta version - told you I liked bleeding edge!), and install the regular version…


#10

You can’t use the new app yet. You haven’t been migrated to a samsung account, you have a smartthings account. There are several posts about this already.


(Jimmy) #11

we don’t know that until he actually gets to the Samsung login screen. His particular error has been common on Huawei devices, Fire Tablets, and other Android devices.


#12

That’s fixed it, your website doesn’t support Chrome beta :slight_smile:

The sort of person that likes playing with SmartThings, device handlers, smart apps etc, etc, might also be some of those 10 million downloaders of Chrome Beta :wink:


#13

Yes we do…because NO ONE CAN USE THE NEW APP YET!!!
That is, unless you’ve signed up for the beta. We have ST accounts. You have to have a Samsung Connect Account to log in to the new app.


#14

Well, I’m logged in, as I have accounts for both things, but then can’t progress much further as one of the buttons on next page does not respond.

All I’ll say too is that having an App called SmartThings in the play store, could well be confusing for new SmartThings users, especially as you say it is unable to be used for SmartThings right now. Why rename it to SmartThings if it isn’t?


#15

All of your devices and your hub will not be in the new app yet. Do you understand that? Your account hasn’t been migrated yet. OMG.


#16

Completely understand it. Chill. I’m just playing with it. Problem?
I found an App called SmartThings, thought I’d have a play around :sunglasses:


#17

You’re complaining that you can’t use something that you’re not supposed to be able to use yet. So, what;s your problem?
You can’t play around because you can’t install anything on it. LOL . it’s an empty shell.
Play around all you want. Just don’t ask for help when it isn’t finished yet.


#18

Ok, I didn’t complain. All I said was I’ve installed it, but can’t login.
I didn’t complain really.
Don’t see why I can’t ask for help playing around with something? I’m quite happy to discover the thing is useless in it’s current form.

You are most welcome to no longer help me :slight_smile:


(Jimmy) #19

This is incorrect. Anybody that activated their hub after May 2017 has a Samsung account. So they can use the same credentials in both apps and see the same setup.


#20

Oh, and the App in the play store called “SmartThings”, with fancy screenshots and loads of features listed does very much look light it should do something.

Come on, group hug, lets all be friends.
I love mucking around with stuff and poking around. This is just a form of that, and I might get nowhere, but you can’t blame a guy for trying :slight_smile: