Smartthings Android update switch slow loading times (29 Nov 20)

Just got the latest android app update today and despite everyone saying it has gotten faster, when i try to open a switch or bulb, it takes a good 6 seconds to load the insides of the device. Please visit the link below to see a screen recording of this issue.

Cleared cache, force closed the app, rebooted phone, still the same.

Edit: Buttons and Plugs also have the issue.

@Brad_ST and @blake.arnold some help here please…

Sorry for not mentioning this sooner but my region European Union.

Still nothing on my s10… must be the last in the line this time

Dont hurry up to update. Unless you want some problems…

I don’t mind, makes it more interesting, just working is boring Andreas, I got into ST knowing full well I was finding answers to questions I didn’t really have :grin:

I run nothing that is life changing, convenient yes but not life changing


It is already available on my S10.

Must be my devices stopping the update


Area 51 motion … :grinning_face_with_smiling_eyes:

1 Like

Yeah I know, hey what can I say, I was asked to solve the issue :upside_down_face:

You seem to have things sorted out :grin:

Now I renamed everything back to what they should :roll_eyes:

Still no update though

Yet another outage… []

1 Like

STILL no fix for Android 11. I’m still unable to open the detail view of my door lock. It needs to download a controller and hasn’t been able to ever since Android 11.

Apparently Samsung thinks they’re the only ones that run Android and since they haven’t updated to 11 yet, screw everyone else who has been running it for almost 3 months now.

Finally arrived this morning
No fix for ST multi sensor open close history
No link per device to connected automation or Scene
No access to gallery to personalise backgrounds
No labs section in smart apps
Load times seem no different

@SmartThings guys any help here???

Why is no one answering me? @Kianoosh_Karami can you please take a look?

My opinion you have many room and many devices display on the home screen.
Create one room with only the devices you use more frequently and hide the others …

But it was working just fine before the update…

I don’t know what to say, I updated the app yesterday and I didn’t notice delays or difference …

I don’t know… I can’t be the only one here! Both my S20 Ultra and my S9 Plus have this issue. This is the first time i deal with something like this.

No problems here either. Try contacting support so the issue gets logged.