Ikea tradfri button issue


Hi nayelyz,

Good day.
Can I ask for a help regarding my ikea tradfri button. I installed this device for so long and works pretty well. Suddenly, I noticed that it malfuntioned and was changed into a “thing”. Initially I thought it was only a battery issue. I changed but still not working. I removed the device and re-install it again. But still, when the device was added, It was added as “thing”. I’ve checked my hub drivers and a zigbee button drivers is still currently installed. I tried to changed it to zigbee button but the error pop-up came up.

I do not what to do already and I hope you could help me on this.

Thank you so much.


ST did a lot of migrations from legacy custom DTHs to Edge drivers this week. If your device ends up as a “Thing”, it means there is no stock driver that matches your device model. You will need to find a community developed driver to support your device.

Possible this driver might do the trick. I didn’t find anything else in my cursory search, but you might look to see if a driver from @philh30 or @Mariano_Colmenarejo supports it.

1 Like

Hi Bruce,

Thanks for your help. I install the drivers and it managed to determine the ikea button as a button. Unfortunately, when I tried the actual device, the state is not changing from standby mode as if it is not working at all.

Same issue. I had the Tradfri button working until Friday, then something got zapped in the back end, and it shows as a Zigbee Thing. I also have a Tradfri dimmer, and that became a Zigbee Switch, and seems to function properly!

Omg. I am not alone! All of my buttons are dead. They all connect, but they won’t control anything :frowning:

My Ikea Shortcut buttons use the IKEA Shortcut Button driver from the channel below:

Channel and Drivers Web UI (smartthings.com)


Sadly, cannot get to that page… error 403 Forbidden :frowning:

Got them. Installed them. Can’t select it from the app. Tried from PC. Didn’t work. :frowning:

Sometimes a direct link from a channel gives that error - try logging into your account first. This is the driver you need!

EDIT. OK you got it. Great

I got it. But I cannot select it through the app. :frowning: Manually changing it doesn’t work :frowning:

Personally I’ve never found these buttons easy to pair (unlike the 2 way buttons that work well). This last week I deleted one, paired again with this driver, updated firmware on the new web UI, deleted again, and paired holding the button several times for 10+ seconds. Before I’d had the problem that it got through batteries every 2-3 days, never showing more than 9% - now it shows a steady 45%, and working well so I’m optimistic.

I’m also getting the 403 error. Even logging in before doesn’t help. Can someone help? Thanks!

Try the guy’s Github page


Thanks! I’ll test tonight!

:scream: thanks!!! That one works!!! It’s a miracle!!! Ty Ty Ty Ty :+1::+1::+1:

Hi @animarcs

@h0ckeysk8er is correct, if your device was added as a thing that means that there is no stock driver that matches your device, smarthings only just recognize that is a Zigbee device and is not officially supported by SmartThings, the solution here is to find an edge driver made for the community some user already share the links on this post or you can develop one based on the SmartThings Drivers

So I had one button connected that wasn’t working, and a 2nd that I couldnt get connected at all. For the button that was connected, I eventually got it going with drivers here: Channel and Drivers Web UI After fussing with the 2nd button to get it into pairing mode (these buttons are notoriously hard to get into pairing mode) it managed to pair and install using “find device by manufacturer” in the Smartthings app “add device” and selecting Ikea button. Lo and behold, it was added as remote button, not a Zigbee Thing and is also working fine now.

I tried everything, all the drivers and 4 different devices. I get them all to connect and pair but they all stay in “Standby” mode with no reaction to the button being pushed. Can someone help me out?

This driver works great for me with the Shortcut button:


1 Like

Ever got this working? Got the same issues right now.