New Ikea tradfri Shortcut Button?

Like all of the Tradfri buttons, unscrew the back, press and hold the button in there for 4 seconds until you see the red led flashing. I love IKEA’s design on these devices.

I tried that but it doesn’t do anything, however quickly pressing it 4x makes it flash the light. Then the light just pulses after that, I’m guessing it’s to show it’s in pairing mode ?

I can’t seem to make it work… Here’s my process:

  • With the (new) app I add device and select scan nearby.
  • I press the pair button inside 4x
  • it finds a thing
  • In IDE I change the handler to ZigBee button and name it Zigbee button
  • It shows up in the app as a button, so far so good, but then it just doesn’t work.
    No battery % and nothing in the log (I’m expecting to single button presses)

yes that pulsing is pairing mode. and yes now that you said that, press and hold is sonoff, ikea is press x4

hmm odd that its not working, did you try connecting it to a light (ie press turns the light on and off) just to see if its working? Some sonoff devices you need to reconnect the device after you change the type, maybe try readding it without deleting the button first?

Tried that yes but still no luck. Guess I’ll have to wait for someone to make a specific handler or for ST to add support for the button.

I had the same result, removed and added again.

Now the button (E1812) is working.

You added it, changed the handler to zigbee button, deleted it in the app and then re-added it by rapidly pressing the pair button 4x ? (Because that’s what I’m trying, without success)

Yes, but after re-adding I had to change it again to Zigbee Button in IDE.

It’s working now ! Was kind of getting desperate… I just left it a few days and now when I came to look at it in the app it showed the battery percentage.

Great, always a challenge, smart devices

It amazes me that anyone buys smart home products at all given how hard it is to get things to work. I have a degree in computer science, haven’t been able to get this button to work even following these tips. Why the heck can’t smartthings just detect that its a Zigbee button and work with a generic handler

I know it’s very frustrating. :rage: Most smart home products work fine with their own gateway/hub. And some platforms, like apple’s Homekit, require a certification for every device, which simplifies integration, but limits the total number of devices available to choose from.

Because smartthings is a multiprotocol platform, it uses its own abstraction layer a level above the device’s protocol which makes integration a lot more complicated. So you tend to get a much wider selection of devices, but fewer features on a lot of them.

(A good example is the Aeotec Wallmote Quad 4 Button Device. It’s designed by the manufacturer recognize tap, long press, slide up, and slide down on each of the four zones. But the official smartthings integration only recognizes tap and long press.)

There’s no question that it’s annoying. Sometimes community members are able to come up with custom code that gives access to more of a Device’s features, sometimes not.

All of which is to say home automation itself can be pretty much plug and play if you are willing to choose a platform with a more limited set of devices and Automation options. If you want the versatility of the smartthings platform, you pay for that with a lot more frustration.

So far, the IKEA shortcut button is not working well with SmartThings for a lot of people. But the less expensive “dimmer“ button seems to work well if you just use it as an on/off button. ( The dimming function doesn’t work.) I don’t know if that’s of any interest to you or not.

I just started a new FAQ last week for battery operated devices that have been demonstrated to work with the current platform. I haven’t added the shortcut button to that because multiple people were reporting problems with it. :disappointed_relieved:

[2021] Battery Power Switches and Buttons

Hi James,

Sounds familiar, like Windows and device drivers?!

Same here with SmartThings devices and the device drivers: who is first with a working DTH, the vendor (Ikea), SmartThings or a “whizzkid”?

And later, when an update of the hub is there, to improve or fix bugs, you get “new undocumented features”.

Never had those practices?

Grtn Ben

As everyone knows, IKEA TRADFRI Shortcut Button works as a LOCAL button when using built-in “zigbee-button” DTH,
and it’s extremely fast.

It first pairs as a “Thing”, because the fingerprint is not yet registered in ST server, but you can change the device type into ‘zigbee switch’ in ST IDE.

However, when we use this device with the default zigbee-button DTH, we can only use ‘pushed’ event. This device is capable of sending ‘held’ event, but it’s not supported with default device handler.

The reason why ‘held’ event is not recognized in ST with default device hander is…

When this IKEA button is released, a packet with clusterInt == 0x0008, command == “07” is sent from the device.
But in the zigbee-button built-in DTH, only clusterInt == 0x0008, command == “03” is recognized as button release command.
(see line 179 of the source code)
SmartThingsPublic/zigbee-button.groovy at master · SmartThingsCommunity/SmartThingsPublic (github.com)

So I have modified original zigbee-button DTH to support the IKEA Shortcut Button.

I also added that button number is 1 in the initialize() function, and added fingerprint of the button.

If you should use ‘held’ event with this device, you could use my DTH,
BUT, if you use my DTH, it works as CLOUD device.

I hope this change is applyed in the built-in zigbee-button DTH, so that we could use this button LOCAL with ‘held’ event supported.

Addendum)
And I don’t know why… but sometimes the button does not work right after the paring.
It usually starts working after changing the group(room) of the device.

I think that invokes updated() method of the dth, and that might be the reason. (I’m not sure though.)

2 Likes

I wonder if your modified DTH will fix the same problem with the hue smart button, will test and add fingerprint if it works

It won’t work with hue smart button.

I’ve just checked how ‘hue smart button’ is implemented in zigbee2mqtt,
Fix Hue smart button integration. https://github.com/Koenkk/zigbee2mq… · Koenkk/zigbee-herdsman-converters@e874667
and, it seems that it uses on/off cluster for button event.

I think you could use built-in ikea button DTH (with some modification, if needed)
Ikea button uses On/Off cluster for button event.

Hey Iquix, I’m running on a V2 hub, was able to add the device, changed to the generic zigbee button handler but got nothing. Now I added your custom DTH but it still doesn’t work, tried changing the group also nothing. Any ideas? There’s a cloud with a bar through it now if you go in the device in the app at the top and also at the bottom in the square that says “Dimmer”.

I am still not sure why some of the people have this problem. This needs to be studied further.

Managed to get the Tradfri square button working (single press only) with the steps above by @hardluck and by adding it twice. Your result may vary. My steps are:

  • Add button to smartthings app in pairing mode (4x clicks of the switch by the battery then red light shows). Close app (completely, not just background)
  • In IDE change name to [Zigbee Button], label to [Shortcut Button], type to [ZigBee Button]. Save
  • Reopen app. Still didn’t show correctly or work. Close app
  • Put the button into pairing mode again and re-add to smartthings (don’t remove beforehand). It should remember all the names, location, etc. Close app
  • In IDE change the name to something different , eg. [Zigbee Button1]. Save
  • In IDE again change name back to [Zigbee Button]. Save
  • Reopen app, cross fingers, and hopefully it’ll show properly with the battery status and single press will work :crossed_fingers:

I had tried similar steps to above all of yesterday with no luck. Key for me was to re-add the device in the middle (even though it was added already) and then change the name back and fourth.

Good luck!