SmartThings Community

New hub v3 owner. When adding hub to app, it gets stuck on update page


(Brad) #41

That sounds correct. During the setup process is the LED blinking magenta?


(Tony Glass) #42

Yes, but it starts blinking blue at a certain point in the update.


#43

As @Tony_Glass mentions above, it starts off magenta but at some point it transitions to a blinking blue while the app is stuck at 99% of the 57MB update.


(Tony Glass) #44

Update: tried it with my old Note 5. Same thing, stuck on 99% after a full hard reset. I’m just going to go ahead with the return on Amazon. Good luck to the rest of you!


(Jacob) #45

Noob here… I’ve been having similar issues here using my iPhone 8 for set up. The app hangs up at 99% when the update is 100% downloaded

I somehow did get it to work right off the bat. Was messing around trying to learn the app and decided to do a reset to start clean and spent the rest of they day trouble shooting the blinking blue light issue. I was able to get it to work a couple of times though I am not sure what I did different. Seemed kind of random. Sometime it would work, most of the time it wouldn’t. A couple of notes that may or may not help others…

  1. I was checking to see how well it would reconnect after a power outage. It worked a couple of times, but more often than not it would just revert to blinking blue light once plugged back in.(ultimately I would like to use this in an area where I can’t run ethernet. if it doesn’t reconnect to the wireless after a power outage it is almost useless to me, for the price I’d expect the connection to be more robust)

  2. After giving the app a good long while at 99%, I would kill the app and reopen it. A lot of the times it would show the Hub as connected but it was totally unresponsive. It would even show as connect when the hub was unplugged.

  3. Blue light would go away immediately and turn green once plugged into ethernet.

Also, in case it has something to do with the wifi router, I am using an airport extreme.

Ultimately I really need this to work without being directly connected to the router. I’m going to give it a week but if there are no updates I’'ll be retuning it.


(Tony Glass) #46

Well being the hardheaded person I am, I tried it one more time with my Note 5 before taking it back. Surely enough, it worked perfectly and now is connected. My Schlage touchscreen lock is linked and now controlled by Alexa. 27th time is a charm I guess?


#47

Now make sure not to move it to a new outlet or lose power temporarily :smiley:


(Tony Glass) #48

Already had that happen lol. I switched it to another outlet and sure enough, flashing blue forever. But after unplugging it for 3 minutes, it came back online


(Jacob) #49

so you’re suggesting to unplug and replug until it connects over the wireless?


(Tony Glass) #50

No. I got mine setup finally, but when I moved it to the outlet I wanted it on, it never reconnected. Wasn’t until I pulled the plug for 3 minutes and plugged back in that it reconnected


#51

Same problem. Just purchased hub v3 today. Stuck at 99% on update.


(Greg) #52

Had the same issue. I used Ethernet to get it working, but couldn’t give up on getting the WiFi to work. I factory reset the hub, cleared the data and cache in the app, and tried WiFi again. App was hanging at 99% (as it did in the past), but when I looked at the hub I had a solid green light. Waited another minute and the app said complete. Not sure if Samsung changed something or I was just lucky. Wanted to share with everyone.


(Richard Brown) #53

I had the same issue, faffed around with using wired instead which connected but then wouldn’t connect if I tried it wirelessly. I had to factory reset and start again, which btw, the instructions on some Samsung pages are incorrect. After that, mine stuck at 99% on the app, but watching the hub, it actually finished updating, power cycled then joined the wifi (LED green) and if I closed the app and reopened the hub had connected ok. The factory reset instructions on 1 samsung page says to disconnect the power cable, press reset for 30 seconds until flashing yellow, what it fails to say is put the cable BACK in after pressing the button; I did think it was weird that there was no power during the reset (hence it not working until finding the correct way) !

This is wrong: (or was when I pasted it here, hopefully they’ll update it)

This is right: https://www.samsung.com/us/support/troubleshooting/TSG01109547/#factory-reset-a-smartthings-hub-2018


#54

Thanks. Unfortunately a factory reset doesn’t do anything for most of us having this issue. Have probably factory reset several dozen times.


(Richard Brown) #55

It’s very flakey tbh… it will connect to wifi, then if you power off and on it sometimes connects and sometimes doesn’t. I’ve assigned a static IP address on the router for wired and wireless MAC addresses which it does pick up, sometimes. At the moment the only way it’s stable is using ethernet connection. Not very impressed so far.


(Tony Glass) #56

Guys, your immediate solution for now is to get another device to set up the hub with. Factory reset your hub, if you don’t have another phone in your house, ask a friend to come over and do it with theirs (get on your wifi, download smart things app, log in to your samsung account, set up hub). It didn’t work for me the first time, but on my old Note 5, it eventually worked


(MarkB) #57

How many people that are having this issue have a mesh router setup that has a 5GHz and 2.4GHz signal combined into one SSID, like Google mesh router? I think this may be part of the problem but can’t confirm if the Smartthings hub is 2.4 or 5. If only 2.4 then it may be trying to connect to the 5GHz signal but failing.


#58

Hello all - I am new to the forum, but after the last four days in SmartThings not so pleasant location, I feel I have been working with this device for years!!!
Short version: I have been having all of the issues discussed above since I got my first device earlier this week. Based on Lodans post, I actually tried a couple of tests and got some surprising but successful results. First, I turned off my 5G SSID and attempted to connect/configure device. FAILURE. I then turned off the 2.4 and turned on 5G - SUCCESS! I even was able to power down the device and have it reconnect. Previously, when I powered down the device, it wouldn’t connect. If anyone wants more details, post and I’ll try to provide additional details.

UPDATE: might have been a bit early declaring victory. HUB seems to connect/report status, but having issues connecting lights. Will post update when I resolve this issue.


(Jimmy) #59

it is both. It puts preference to the 5 ghz band to avoid zigbee interference.


#60

So much for my overly optimistic first post. I am about ready to return both HUBs (both v3) and forget about the whole smart home concept. That is unless someone can point me in a direction I haven’t thought of (yet).

I have multiple SSIDs operating in my house. Main network, Golf, Sierra, and Tango for different purposes, with wifi passwords ranging in length from 12 characters to 63 characters and using probably every ASCII character between the different networks. I am broadcasting on both 2.4 and 5 G frequencies on all SSIDs and have band steering configured to “push” clients to 5 G. On the back end, they are on different VLANs and subnets, going through a standalone firewall. I have an S7 fully updated phone and fully updated SmartThings app.

I originally purchased HUB1 and started setting it up. The lack of instructions didn’t prepare me for the HUB connecting to the network my phone was on and I was prepared to enter the SSID and associated password. After pretty much a FULL day, I finally ignored the instructions on how to do a factory reset and was able to get it done. YEAH, some success! I then “moved” my phone to Tango network and if I remember correctly, I think the setup was without much issue. I added a number of smart light bulbs to the configuration and they seem to function correctly. Second success (I thought).

At this point, I unplugged the HUB to move it to a central location since it was configured and functioning. OOPS! Plugged it in and it never re-synced to the network. Back to my work counter, several factory resets later, testing on each and every network I had available with varying results. Some times I couldn’t even get the HUB to complete the setup and when it did complete the setup, it would never re-connect to the network after power cycling it.

After an hour on the phone with Samsung tech support (nice person, not effective in solving my problem), my cell connection dropped. I didn’t call back. So, off I go to buy HUB2.

Fresh out of the box, phone on Tango, what could go wrong? Connected first time and sure enough, when I unplugged the HUB and plugged it back in, no network connection. So post above picks up at this point. I try 2.4 and no connection, 5 G connects and stays connected after a power cycle. However, I can’t reconnect the light bulbs that connected back on day 1 or was it day 2?

I do have a history of being able to find undocumented features (bugs) in software/hardware, but this is getting frustrating.

I have multiple phones, computers, and tablets that are able to connect to any of the networks without issue.

HELP, please!