2018/2015 Model Hub Firmware Release Notes - 0.34.09

UPDATE 12/21

We have made changes to more accurately mark child devices offline when appropriate. This change, along with the below planned changes in the 34.09 update, will begin being released to users in a 34.11 update starting today. We have updated the status page to reflect this and will update again when the release is complete.


UPDATE 12/16

The 0.34.09 firmware update has been temporarily paused while we investigate customer feedback. We will provide an update when the release is resumed and provide additional details on any changes in the release window.


We will begin rolling out Samsung SmartThings Hub firmware version 0.34.09 starting tomorrow. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)

Release Date: 15 December 2020 ~ 18 December 2020

Note that this release may be spread out over a few days, so you may not see your Hub update the first day of the release period.

Release Notes:

Features

Z-Wave Enhancements

  • Added support for local handling of temperature, thermostat mode, thermostat fan mode, and thermostat operating state reports on the Z-Wave Battery Thermostat DTH.

Zigbee Enhancements

  • Firmware updates for the SmartThings Smart Bulb:
    • Changes to more quickly rejoin the network if the network parameters change.
  • Updates that position the 2015 model Hub to support upcoming features and updates (stay tuned for more updates on when this functionality goes live):
    • Added Zigbee 3 Support for Samsung SmartThings Hub 2015 (Hub v2).
    • Increased the number of Zigbee end devices that can directly connect to the Samsung SmartThings Hub 2015 (Hub v2) to 64 to match the Hub v3.

Bug Fixes

  • Fixed an issue where a Z-Wave device is not automatically removed after the device has been factory reset.
  • Added a change for an issue with Schlage BE469ZP Z-Wave Lock where user code triggered locks/unlocks were not logged in the lock’s history.
  • Reliability improvements to hub connected device health reporting.
  • Minor bug fixes and improvements.
4 Likes

Was z-wave OTA firmware updates dropped? No mention of it in these release notes.

1 Like

Z-Wave OTA/Device Firmware Update is currently only available for the users enrolled in the Hub Firmware Beta program, given that this feature is still in the Beta stage.

We are hoping we can release this to all users in the future firmware releases.

8 Likes

Anyone know when the lowBatteryThresholds values showed up for devices (at least for zigbee)?

image

I have a few ZIgbee sensors showing up with 0% battery (and are working fine), and when looking in the IDE to see what’s up I noticed these new values.

1 Like

Many months ago. November 2019.

Does this update include the wifi hubs?

I know the many of those have been there a while, but lowbatterythresholds? I don’t recall seeing those before, and I’m only seeing that on only a handful of sensors from various manufacturers and type (all using stock handlers too).

Here’s the PR from October 2019. It’s only the ST multi, motion and button.

When I loaded my SmartThings app today it said there was an update for my hub. I accepted. My hub has been inactive ever since (over 2 hours)

I have a v2 hub model STH-ETHH-250. In the SmartThings app it says the firmware is 000.032.00012.

Both the green and yellow LEDs on the ethernet port of the hub are lit solid and the front LED is blinking blue.

If tried twice now to reboot the hub by disconnecting ethernet, ac power and removing the batteries for 60 seconds. Each time I reconnect the hub the green and yellow ethernet LEDs begin blinking and then go solid.

What can I do to recover the hub back to a working state?

Did you happen to catch a screen shot? Hub updates have always been silently pushed in the background without any choice from the user.

This was an update for the plug-in controller version the devices use, as @prjct92eh2 said already you are unable to opt-out of Hub Firmware updates. Your Hub as well as other device cards likely said “Downloading…” when you loaded the App.

To check what plug-in version you are using:

  1. Open the App.
  2. Click into a device card.
  3. Click the three dot/kebab Menu in the upper right-hand corner.
  4. Click on “Information.”
  5. The “Controller version” is the plug-in version. Most current version as of 12/15/2020 is 2.1.19-11.

I can understand the confusion. In this case it is a coincidence of when you clicked on your Hub, there was a plug-in version update available and it was applied after you acknowledged it. This update would’ve been applied had you clicked into any other device as well.

3 Likes

Thanks for the clarification @garrett.kranz. Is there any way to see change logs for plugin updates?

2 Likes

No, I didn’t catch the screen. However after more investigations it l found in the event list for my hub that today at: 2020-12-15 5:12:48.000 AM EST (2020-12-15T10:12:48.000Z) the hub went into a disconnected state and at 2020-12-15 5:18:02.000 AM EST (2020-12-15T10:18:02.000Z) is went inactive.

So I guess the SmartThings app message was an update for the app? But it looks like separately from the app update, the hub update that went out today crashed my hub.

It’s still inactive and the ethernet LEDs are lit solid.

Yes. It looks like that is what happened. My SmartThings app Controller Version is 2.1.19-11.

So I also found in my Hub’s event list that at 2020-12-15T10:12:48.000Z it disconnected and at 2020-12-15T10:18:02.000Z it went into inactive. It’s been inactive ever since and the ethernet LEDs are on solid.

The 32.09 Hub Firmware Update had not started rollout yet when you mentioned having issues, so that is not possible. While it is clear you are having some connection troubles, neither the Plug-In update nor the Hub Firmware Update can be to blame.

Did you receive a Hub offline notification? If not, power down your Hub until you do receive the Hub offline notification and try powering it back on afterwards. If you did receive a Hub offline notification, then I would point the troubleshooting towards the Router/ISP in use.

Well according to the SmartThings Status SmartThings Status the firmware update was released today at 10:00am EST " Samsung SmartThings Hub 2018 and 2015 model firmware version 0.34.09 will be released to customers starting tomorrow, Tuesday December 15th."

And yes I did receive an Hub offline message

Well according to the SmartThings Status SmartThings Status the firmware update was released today at 10:00am EST " Samsung SmartThings Hub 2018 and 2015 model firmware version 0.34.09 will be released to customers starting tomorrow, Tuesday December 15th."

And yes I did receive an Hub offline message

Ah ok, I don’t monitor those. Looks like it works on any device using those stock DTH’s like my Iris motion sensors. Thanks for sharing this info. I guess I never noticed this before.

1 Like

I don’t know if I have the new firmware on my hub as the app won’t let me open any device specific screens, including the hub itself. Any time I tap on a configured device card it opens a white screen and then immediately dismisses it, no error messages. I do not remember it mentioning a firmware upgrade.

Yesterday everything was working fine. This morning (9-10AM PST) I tried to open the Thermostat card, and I got a message saying something along the lines “A new device handler is available/required”, can’t remember exactly. It forced me to update, I could cancel, but then I still could not open the device panel to set a temperature. After allowing/accepting the update I’ve been stuck with the following behavior

I do appear to be apple to control the lights, on/off, using the switch buttons on the device cards, but of course I can’t dim any dimmable lights, or set/control the thermostat in any way.

What happened, and how do I fix this? Ironically I’ve been slowing transitioning away from my Vera controller to move everything over to Smartthings, and now its not working. I could certainly do with some help.

I had recently updated the iPhone app to the latest, 1.6.55-452 release. I’ve tried rebooting both the iPhone and the Hub.

Just realized I can log into the IDE, and that is currently showing Hub v3 US on 000.032.00012.

Cheers, Mark.

Sounds like you received the plugin update for the app that another user reported above in this thread. Try signing out of the app and sign back in. Note: when you signout, you lose your current arrangement of your dashboard. If that does not resolve the issue… uninstall the app and perform a fresh install.

2 Likes