New hub v3 owner. When adding hub to app, it gets stuck on update page


(Andrew Wilcock) #21

Try stopping the app and then starting it again.
This worked for me and update had been done.
Seems to hang after update has completed.


#22

@Andrew, this was attempted several times. Didn’t make a difference.


(MarkB) #23

I have a Pixel 3


(Steve White) #24

That seems to be the standard of operation for SmartThings support as of late. I have 2 tickets open, one on 11/25 which I have received no response. I’m not sure whats up. Support has always been decent and responsive, until now.


#25

Steve, I have been chatting with @Brad_ST and he seems to be pondering a fix for this. Apparently this is something that has affected several ST customers. My phone is an iPhone X, and I suffered from the same hang up at update instal when setting up a new hub. I’m still monitoring every thread I can find on how to get one of the v3 hubs I bought to actually come online and function correctly. Thankfully, I have only purchased one switch to work with this hub so far, and it works fine manually. I would be very angry if I had tons of switches and automations hung up over this!


(Sérgio L.) #26

Hi there. I was having the same problem with the update.
Start from scratch but with ethernet and the update was sucessuful, but everytime i try to change it to wifi (with a soft reset, because i have read somewhere it was the only way) the update comes and it gets stuck again.
So for now im leaving with ethernet.


(Tony Glass) #27

Yes, me and TexMurphy have been messaging privately. He has a S8+ , I have the S9+. So there’s definitely a problem with the newer Samsung phones. However I’ve tried, unsuccessfully, to setup with my ipod which i use for music at the gym. It let’s me select a WiFi network and enter the password (which I never saw on the Samsung), but now hangs at 100% during the update.


(Brad) #28

On Samsung Galaxy devices, the SmartThings app selects your current Wi-Fi connection which is why it doesn’t prompt to select a network. Changes to improve this behavior in-app will likely be coming.

When the app hangs at 100% what color is the LED on the Hub and how long are you letting it sit in that state?

I have been trying to reproduce this issue and I do notice a significant lag between 99% (57/57MB) and setup completing. In my testing, the LED will go from blinking magenta, to red briefly, and then blinking blue for about 1 minute before solid green. I have also experienced the Hub LED changing to solid green while the app still indicates 99%.


#29

Can’t recall exact timing but generally it goes from blinking magenta to blinking blue (endlessly). Never green.


#30

@Brad_ST I reset my hub today, and it connected wired. It went through the update process, and it went online without problems. Then I moved it to set up the wireless connection. It would never do anything except blink blue, so I reset it again for set up via wifi. This time it hung up again . I am attaching a screen shot so you can see what I’m getting. I’m using an iPhone X.


(Tony Glass) #31

Same. With my iPod, it’ll hang at 100% flashing blue indefinitely until the “it shouldn’t take this long to update” warning. Another bit of info: when I try with my ipod, I have to manually add the hub, it is not automatically recognized even though it is flashing red and green.


(Brad) #32

This is expected. iPhones do not support the automatic discovery of devices within the SmartThings app.


(Brad) #33

How long did you leave it in this state?


#34

My pic was at 5:43 central, and it’s now 5:58 central and phone is showing the same thing. Hub is flashing blue.


(Tony Glass) #35

Until I got an error message. Maybe <= 10 minutes


#36

Hey @Brad_ST, if I get the hub connected via ethernet, how do I correctly get it moved to wifi without having to go through the reset process and new setup? I can try that for you if you’d like.


(Brad) #37

You currently can’t move the hub from ethernet to wi-fi without a soft reset and re-downloading the update. To the best of my knowledge, the hub is downloading the update but is failing to complete the setup.


#38

Bummer. So best case now is just to connect it wired, and use it like that?


(Brad) #39

If the setup is failing via Wi-Fi, then yes, Ethernet is the only option while we investigate.


(Tony Glass) #40

Could you please verify that I’m resetting properly when testing with my ipod?

I depress the reset button while unplugged, plug it in continuing to hold reset until the flashing yellow goes solid then release button. Then wait for about 10 minutes until red and green flash on the hub. Then I start the setup process. Is this correct? That’s what I’ve been doing but the setup hangs at 100% and stays there until the error message pops up. Is it possible this device is bricked?