Need big help here. Zwave devices adding but showing offline

Got a real bizarre problem here folks.

I wanted to add a GE toggle switch next to an existing one in the same 3 gang box. Wired up fine. When I went to add it I got this warning I’d never seen before that it didn’t connect securely and to go into exlcude mode to take it out and re add it. I did that but I got the same warning message so I said ‘Skip’ and it shows up in the app but offline. Also could not change the name of it…but I CAN in the graph API and it updates the label in the app but still shows offline.

Troubleshooting some more I thought maybe the switch was bad. Well stupid me I removed a known working switch in the same box and when I tried to re add it I GET THE SAME ERROR and now it is showing offline!!!

So now I’m hosed on both, to just pursue the insanity I added a switch that I had been meaning to pair but hadn’t as it wasn’t important. SAME ERROR and showing offline!

But now here is where things go sideways. If I look at the history of the switch it will show current times when the switch is turned off and on! So messages are getting to the hub and conversely to the app.


I worked with Smartthings support, tried a Z-wave repair, tried several zwave exludes and re adds. I moved the hub to another location and BRIEFLY the switches showed online, but that was when i went to go rename on in Graph API and it updated the app and showed offline again!

I could really use some clues on this as Smartthings support have no idea.

model for the GE toggle switch? brand/model for the others? when you ran z-wave repair, were there any error messages or ghost devices?

@nathancu loves helping with z-wave :slight_smile:

1 Like

you have a strange definition of love J… I LOVE whiskey - not Zwave. But yeah I was just looking at this one.

The S2 (‘didn’t connect securely’) thing I think is a symptom, not the issue. Someone else reported a similar problem recently with some old GE gear where they’d go offline immediately after joining, and a power bounce for the device solved it.

Yeah - model numbers and the errors in the repair list would be a good start.

1 Like

Both the formerly working switch and the one I added are both ZW3004.

No messages in the Zwave repair, it just completes.

A further observation, an IOS device with the smarrthings app installed shows the devices offline, but you can tap the tile to toggle the switches on and off. I can’t do that with my S20 with the android app installed. On and off history shows up under the device history.

They also all show online in the graph API.

1 Like

Did you run the repair in the app or in the IDE? The app has a funny way of running without showing any result.

Thanks for the online offline and iOS v. Android thing - this smells kinda like an app issue. Do you have Actiontiles or SharpTools installed per chance? If so can they control the devices?

I ran it in both.

I dont know what those things are you mention, so I’m guessing no.

Web based UI for Smartthings. They have a free trial.

In this case it’s helpful to see if we have device control outside of the app. If we do it’s PURELY an App / display issue. if not you have a device control / zwave issue. We have to figure that out first. Unfortunately the new app reports anything it doesn’t understand as ‘OFFLINE’ so we don’t yet know if the App is just confused or if the device is truly not available.

I have had similar problems adding a ST outlet and a ST Water Leak Sensor. In Announcements and at it mentions outage for maintenance and firmware updates so I gave up until that’s finished.

i think you mean it mentions maintenance and firmware updates but not outages. the firmware update for today is finished for the Samsung Connect Home and Samsung SmartThings WiFi models.

there is another scheduled update for monday for the v2/v3/aeotec hubs.

anyway, i doubt the firmware is the cause of the offline devices :slight_smile:

I added these two problem devices to sharptools and can control them through that. They seem to indicate status correctly and I can dim and undim them.


Ok. If thats the case its a display issue in the app, not the device or ZWave.

What device handler is your switch using?

The one it detected I guess. Shows up as Dimmer Switch.

I uninstalled Smartthings and reinstalled, same problem. I don’t disagree it may be an app issue, but ther is something deeper here that is causing it to persist through an uninstall like that, like it accesses the API differently than some of these 3rd party apps.

Also something strange is I’m also connected to Alexa and any time I add a device it shows up instantly in the Alexa app. That’s not happening now so that’s the reason I think something deeper is going on.

It persists through the reinstall because its most likely a DTH problem related to the way the device responds to the updates to device health. (one of the big changes to new platform - device health expects certain responses that have to be handled properly in the DTH and if it doesn’t the platform marks the device offline) I haven’t worked out exactly how the device handler interacts with Alexa but these have a history of issues with the app side of the platform: Jasco 45705 Offline but Working - Devices & Integrations - SmartThings Community

What happens if you change the device type in the IDE to ZWave Switch? (Works for almost all basic Jasco devices)

Tried Z-Wave Switch and Z-Wave Switch Generic. no change.

I read that article but it was from 2019 and I added one of these switches just fine a month ago. What has happened here is a very very recent change.

I am aware - and the diagnosis still fits.

So here’s the rub and I’m afraid it’s not good news. We know that particular device (pre Zwave Plus, and a couple iterations of Jasco devices) doesn’t report status correctly 100% of the time. (Probably has something to do with this) I don’t know if that’s a Jasco thing or a ST not reading the signals thing - but either way doesn’t matter, they just don’t. That’s been known for a while. I have a very strong suspicion the device isn’t responding to a health check ping and the app marks it off. But we know the device still works - see Sharptools.

Add in there are also some very recent platform changes that seem to be changing how devices interact at the DTH level (no we don’t know exactly what it was, unfortunately) with the app. The SharpTools thing though is the nail in the coffin - because of THAT I’m almost 100% certain it’s a display issue in the app itself. If groovy can control it and the app displays it offline - it’s app all the way.

Because of all the changes we can’t rely on 'it’s always worked and I didn’t change anything" ST Changed so much in the last two months (app, firmware, Groovy Platform, Rules API, all of it has RECENT changes) that’s no longer valid. Whether its the way the device is reporting causing the issue (my bet, BTW), or if the app misreading something causing the issue doesn’t matter. The app seems to be misreading the device as offline and without a DTH update specifically to handle whatever its misreading you’re probably not going to get much farther. This is the point where I’d look at how many of these I had and determine if my time was worth the fight. (I just did this with a $100 Cooper scene controller - and the Cooper lost the battle. There’s a Zooz Zen32 in its place as of last week.)

I’m also kind of stunned it still works - the old Jascos like the ZW3004, 3005, 3006 are notorious for the big capacitor in the middle of the board failing. I used to have 16, I now have one left, and its days are numbered.

@Kianoosh_Karami - anything we’re missing?

And this is reinforcing the case for an app issue to me… Simulated Alexa Switch online in IDE, but offline in app


I am migrating from my ADT hub to a Connect Home hub. This morning I removed 3 GE switches (ZW4003), Z-Wave (not +), from the old hub and added to the new without problem. Everything fine in app and IDE. I stopped working on the migration to allow for the new Connect Home firmware to install - releasing sometime today (it installed fine around lunch). Later today, I added a new bulb to my Hue hub. Everything is fine for it in the IDE - online, status is correct, etc. Shows offline in the ST app. On the device page the status would update correctly when changing it in the Hue app. I read that a few others were posting on here with basically the same problem. I opened a new zigbee Ecolink open/close sensor (4655BC0-R) to see if it did the same. It did - all fine in the IDE, shows offline in the app. I can open/close it and watch the status correctly change in the app device page - while it says it is offline. All of these devices are using the default DTH - I haven’t changed any of them. Something is off at ST - I’m sure they will correct it and they will go online sooner or later. Hope this helped.

1 Like

They aren’t old. The switch I put in today had a date code of 2018. 3-4 years old is not old for equipment that is supposed to provide utility. Heck I still have some new in box from jasco I just got, same model so they still make them to this day. I expect a light switch to last a long time and a standard to be supported even longer. If I am somehow expected to replace all my light switches every 5 years then this is not a serious enterprise this is a hobby.

Sounds like Smartthings has broken basic Zwave compatibility through their “upgrades”

I’m hoping I’m adding to the thread here, and I’m not hi-jacking it but recently, one of my switches started blinking. My usual fix it to just replace it.

It replaced it with a Zooz zen21 v3. It seems to have paired, except for the “security” warning. The device that was added was offline, and no amount of re-adding fixed it. I thought I’d get a different brand to see if that would fix it.

I got a leviton z-wave switch. To my chagrin, I got the exact same result. Device added, but offline.

I did notice that toggling the device updates it’s state on the app. So i decided to experiment, and on webcore, sync’d the switch’s status to another switch. Lo-and-behold, it works.

Unfortunately, during my “repair” process, another one of my switching started blinking, and now it seems that switch is fated to be in the same situation.

so it sounds like AS USUAL I pick the wrong time to be messing with my Zwave network and seem to have picked the perfect time for Smartthings to muck everything up and go home for the weekend.