Simulated Alexa Switch online in IDE, but offline in app

Hey guys,

First post. I have previously used the Simulated Alexa Switch device handler to install a virtual switch that integrates with an Alexa routine. This switch is still working perfectly.

As of yesterday, when I try to create a second simulated Alexa switch, it appears online in IDE, but offline in the app and is not recognized by Alexa as a device.

I have tried deleting and reinstalling the switch that doesn’t work, rebooting the hub, making changes to the switch in IDE, and everything short of deleting and reinstalling the device handler because that will mess up the switch that is working.

Does anyone know why this might be happening?

i’m having the same problem with a new enbrighten zigbee switch. shows as offline in the app but online in IDE, yet i can turn it in and off in the app.

I’m having both these problems as well. First I added the z-wave switch and it shows offline in the app, despite showing online in the IDE. I can also turn it on and off in the app as well as in actiontiles, but alexa and homebridge don’t see it. Then I tried to create a simulated switch to see if I could finagle the online status, but the new simulated switch also shows offline. I have other simulated switches that are online and working correctly.

Samsung is really testing my patience. Ever since the cutover, it’s been one thing or another…

This happened to me recently. I fixed it by opening the app, opening the Alexa switch in the app, and though it was showing offline, I clicked on the on/off button a few times. It woke it up. Trick was you had to be in the device, not looking at the tiles.

There appears to be a bug affecting many people with both physical devices and virtual devices where the device shows online to the groovy platform but off-line to the new platform, which means it’s off-line in automations.

This seems to be happening with any device added recently.

No workaround yet, but lots of discussion in the forum under different topic titles. :disappointed_relieved:

Devices added in April 2021 show online in IDE, offline in automations and app (both physical and virtual devices)

1 Like

FYI, official status from smartthings:


Woohoo! All is working now. Thanks for the help all.

1 Like