Jasco/GE ZW4008 (NEW) Showing offline after pairing

Howdy,

No, this isn’t a “I have a device I’ve been using for years and it’s showing offline” post.

This is a “I just successfully installed and paired this device (and it’s showing online after pairing), but won’t respond to commands and shows offline” post.

It’s been a while since I’ve added a new z-wave device, I had a light switch go out, replaced it with the same “type”. I went to add it using the SmartThings app, had me scan the QR code (S2 + SmartStart), it finds it right away, lets me name it, but when I tap it on it to control it, it shows the cloud with an X through it, and it won’t come back online.

I’ve removed it, factory reset it and tried to add it again, same result. Did this 3x times. The last time, I figured I would go into the IDE and see what is going on, the device doesn’t even show up connected to the hub.

So my question is this… Is this switch even being added to my Z-Wave hub (SmartThings v2 I think) since it’s not even showing in the IDE, or is it being added to my phone as a wireless whatever device (Samsung S22)?

It’s not a Zigbee switch, it says Z-Wave+ on the box. This is the first time I’ve had to scan a QR code for “security”, is that what is messing this up?

The broken clouds mean that the device hasn’t reported its state yet. It could be that it just hasn’t sent a report, that it isn’t set up properly to report state to the hub, or that there’s some issue from when it joined.

First thing to try is physically toggling the device. Then try swiping down on the device in the app to trigger a refresh. Take note of which way does/doesn’t work.

2 Likes

The Groovy IDE is no longer reliable. Your device has probably joined with an Edge driver. To confirm that, click on the three dots in the top right corner. If “Driver” appears as an option, your device joined using Edge. There are a number of threads around regarding the migration from DTH to Edge. This one is the official announcement:

1 Like

Okay. I’ll give it a little bit of time. It did use the new ‘Edge’ driver (I have the driver option in the settings).

Not used to actually waiting for this stuff to connect, it’s usually just there.

It shouldn’t take time - it should be near immediate when you toggle physically or swipe down to refresh from the app. At worst you may need to close the app and reopen it since it sometimes fails to clear those clouds when data comes in.

The next simple thing to try is rebooting your ST hub. Edge drivers run on your hub, so there’s a chance that something is hung up and needs to be restarted. Try toggling/refresh after that.

If either toggling or refreshing doesn’t work to update the device then it’s on to the next stage of troubleshooting.

  • If refresh works but not physical interaction, I would guess it’s that the lifeline association wasn’t set
  • If physical works but not refresh, then best guess is the driver not sending the correct requests to the device
  • If neither works then my first thought is that it’s an issue with S2 security, and would try joining by ‘scan for device’ instead of with the QR code

Since it’s using Edge, the tool for any sort of debugging is the logging function in the Command Line Interface. I have instructions for running Edge logging at the link below. Logging at this point would give some info on what (if anything) is being received from the device, and whether the device is acknowledging receipt of commands sent by the hub. It’s not terribly user friendly or easy to interpret though.

1 Like